Forum: Ruby on Rails Strange Rails/Postgres/WEBrick messages

Ec6916acbdd5252c4acbcf2d1d788fb4?d=identicon&s=25 cat123 (Guest)
on 2012-08-09 13:07
(Received via mailing list)
Hi:
I'm on Ruby1.9.3/Rails3.2.6, Postgres 9.1.3, WEBrick 1.31.

I'm a newbie and am over half way through the excellent Michael Hartl
tutorial.
I'm having several issues and not sure if they're interrelated:

1) When I navigate in my browser (in WEBrick), each time I navigate to a
different page on the site I'm building, I get about 10-15 messages all
saying the same thing (coming from it looks like pretty much every file
(both the standard files [eg. like jquery, etc], and my custom .css.scss
files) in my assets/javascripts and assets/stylesheets folders (I don't
have any images in the assets/images folder):

-0500
304 Not Modified (
WARN Could not determine content-length of response body. Set
content-length of the response or set Response#chunked = true

2) All my pages look good in the browser except an "Update your profile"
page. The view (and debug box I added) look totally gobblygook. I tried
re-typing the entire code for the corresponding
app/views/users/edit.html.erb file but it still looks the same.

3) In an effort to trouble shoot, I exited the Terminal (to reset), then
did a
$ bundle exec rake db:test:prepare
and in the process discovered my postgres server returned:
FATAL : database "rhgb_test" does not exist.
I tried it again, got the same message so I'm pretty sure it's related
to
that.
I entered my postgres db, did a   \l   (to get the list of dbs)   and it
shows I do have "rhgb_test" along with the corresponding
"rhgb_development"
database.

4) When #3 above happened, it reminded me that a few days earlier I did
an
rspec test, which had a long command so I wanted to put it on two lines
with a   \    to start the new line (and finish the rest of the
command).
I accidentally entered a    /   instead (newbie mistake) and, before I
realized what I had done, I had pressed "enter" and found myself in "no
man's land" with no prompt or anything and I couldn't get out of it. I
tried:
CNTL + d + Enter
CNTL + c + Enter
exit
q
nothing helped. So I just closed out of Terminal by closing the window,
then relaunched, entered the rspec test I wanted to do and when I looked
at
my postgres server it said:
FATAL: database "rhgb_test" does not exist
Everything seemed to work fine (tests worked, etc) so I continued with
what
I was doing, but then a day or two after that, I noticed, when shutting
down, my postgres server said:
FATAL: database "rhgb_test" does not exist
WARNING: corrupted statistics file "pg_stat_tmp/pgstat.stat"      # (I
take
good notes since I'm learning :-)

My question:
1) could I have somehow corrupted my file when I entered that rspec test
command with a    /     instead of a    \   ?
2) is it possible to somehow fix that? (e.g. did it possibly cause some
sort of weird command internally that's now messing things up, that I
could
undo?)
3) if I can correct it, how do I do this?
4) if I can't correct it, would it be best for me to just drop the
entire
two dbs ("rhgb_test" and its corresponding "rhgb_development") and start
from scratch? (I only have a few test users and only 3 tables in the db
at
the moment). Or, will that "weird command" live on, even with a new db?
5) do you think this may be related to the strange "view" file ("Update
your profile") that I mentioned above? And the strange WEBrick -0500
multiple messages I receive every time I navigate to a new page in the
browser?

Would greatly appreciate anyone's help,
Thanks,
cat
Please log in before posting. Registration is free and takes only a minute.
Existing account

NEW: Do you have a Google/GoogleMail, Yahoo or Facebook account? No registration required!
Log in with Google account | Log in with Yahoo account | Log in with Facebook account
No account? Register here.