Forum: Ruby on Rails config.cache_classes true or false in test environment?

407961424f12d857dc77c09f9b296a16?d=identicon&s=25 Tsvetelina B. (tsvetelina_b)
on 2012-06-27 15:14
(Received via mailing list)
Hello, since two days I have problem with a scenario that started to
fails
with the error that there is a missing link. I narrowed the problem to
config/environments/test.rb  and config.cache_classes and I change the
value now the scenario is passing with config.cache_classes = true. Here
is
my full test.rb:

RbpCm::Application.configure do

  config.action_mailer.default_url_options = { :host => PATH_TO_USE }

  config.action_mailer.delivery_method = :test

  config.cache_classes = true

  config.whiny_nils = true

  config.consider_all_requests_local       = true
  config.action_view.debug_rjs             = true
  config.action_controller.perform_caching = false

  config.log_level = :debug

  config.action_mailer.raise_delivery_errors = false

  config.active_support.deprecation = :log

  config.action_dispatch.best_standards_support = :builtin

end

I looked in google about config.cache_classes and I understood that if I
set it to false then my objects will be reloaded on every request. I
found
that capybara wants this to be set to true. I am using cucumber and
capybara, rails 3.0.9 and ruby 1.9.2-p290
Can you tell me what are the proper settings for test.rb and for
config.cache_classes?
Please log in before posting. Registration is free and takes only a minute.
Existing account

NEW: Do you have a Google/GoogleMail, Yahoo or Facebook account? No registration required!
Log in with Google account | Log in with Yahoo account | Log in with Facebook account
No account? Register here.