Forum: Ruby on Rails rails - postgres error: Reason: Incompatible library version: libpq.5.dylib requires version 1.0.0 o

1975f82475504c1102128d880f4f35c5?d=identicon&s=25 Dc Dieci (dcdieci)
on 2012-06-21 14:42
Hi,

I am stuck with the setup of Ruby (1.9.3), Rails and Postgres (9.0.8) on
my Mac (10.6.8). Everytime when I run rails console I get the following
error:

/Users/dc/.rvm/gems/ruby-1.9.3-head@global/gems/pg-0.13.2/lib/pg.rb:4:in
`require':
dlopen(/Users/dc/.rvm/gems/ruby-1.9.3-head@global/gems/pg-0.13.2/lib/pg_ext.bundle,
9): Library not loaded: @loader_path/../lib/libssl.dylib (LoadError)
  Referenced from: /usr/lib/libpq.5.dylib
  Reason: Incompatible library version: libpq.5.dylib requires version
1.0.0 or later, but libssl.0.9.8.dylib provides version 0.9.8 -
/Users/dc/.rvm/gems/ruby-1.9.3-head@global/gems/pg-0.13.2/lib/pg_ext.bundle
    from
/Users/dc/.rvm/gems/ruby-1.9.3-head@global/gems/pg-0.13.2/lib/pg.rb:4:in
`<top (required)>'
    from
/Users/dc/.rvm/gems/ruby-1.9.3-head@global/gems/bundler-1.1.4/lib/bundler/runtime.rb:68:in
`require'
    from
/Users/dc/.rvm/gems/ruby-1.9.3-head@global/gems/bundler-1.1.4/lib/bundler/runtime.rb:68:in
`block (2 levels) in require'
    from
/Users/dc/.rvm/gems/ruby-1.9.3-head@global/gems/bundler-1.1.4/lib/bundler/runtime.rb:66:in
`each'
    from
/Users/dc/.rvm/gems/ruby-1.9.3-head@global/gems/bundler-1.1.4/lib/bundler/runtime.rb:66:in
`block in require'
    from
/Users/dc/.rvm/gems/ruby-1.9.3-head@global/gems/bundler-1.1.4/lib/bundler/runtime.rb:55:in
`each'
    from
/Users/dc/.rvm/gems/ruby-1.9.3-head@global/gems/bundler-1.1.4/lib/bundler/runtime.rb:55:in
`require'
    from
/Users/dc/.rvm/gems/ruby-1.9.3-head@global/gems/bundler-1.1.4/lib/bundler.rb:119:in
`require'
    from /Users/dc/Documents/Aptana Studio 3
Workspace/http/config/application.rb:7:in `<top (required)>'
    from
/Users/dc/.rvm/gems/ruby-1.9.3-head@global/gems/railties-3.2.6/lib/rails/commands.rb:39:in
`require'
    from
/Users/dc/.rvm/gems/ruby-1.9.3-head@global/gems/railties-3.2.6/lib/rails/commands.rb:39:in
`<top (required)>'
    from script/rails:6:in `require'
    from script/rails:6:in `<main>'

I really don't know how to fix this. I already tried installing a
different Postgres version and I still get the same error.

I already posted on stackoverflow, but since it is very specific i
thought it might help to have it here again, so please dont bother.

best
philip
Please log in before posting. Registration is free and takes only a minute.
Existing account

NEW: Do you have a Google/GoogleMail, Yahoo or Facebook account? No registration required!
Log in with Google account | Log in with Yahoo account | Log in with Facebook account
No account? Register here.