Forum: JRuby Starting with jruby getting segfaults.

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
Tim Uckun (Guest)
on 2012-06-03 14:38
(Received via mailing list)
Hey guys.

I am running ubuntu 12-04 it's a relatively new install. I installed
rvm and jruby-1.7.preview and also openjdk 1.7

 ruby -v
jruby 1.7.0.preview1 (ruby-1.9.3-p203) (2012-05-19 00c8c98) (OpenJDK
64-Bit Server VM 1.7.0_03) [linux-amd64-java]

I went into one my rails projects and tried to run bundle on it but it
failed on some native client gems (pg, rubyracer, twitter bootstrap
rails etc) so I commented them out.  Now when I run bundle it just
does a segfault and takes down nailgun with it.

Fetching gem metadata from
[1]+  Aborted                 (core dumped) ( JRUBY_OPTS='' jruby
--ng-server 2>&1 > /dev/null )

Any clues as to what is going on?
09a41a085f93af8644a7e2e35ba987af?d=identicon&s=25 Charles N. (headius)
on 2012-06-08 20:57
(Received via mailing list)
Do you get any "hs*" files in the current dir when it crashes? Those
usually have information about what the JVM was doing when it crashed.

If you don't have one of those, it's likely it still died in native
code, but probably native code tied to JRuby rather than an extension.

- Charlie
09a41a085f93af8644a7e2e35ba987af?d=identicon&s=25 Charles N. (headius)
on 2012-06-08 20:59
(Received via mailing list) a bug so we can track this.

On Fri, Jun 8, 2012 at 1:56 PM, Charles Oliver Nutter
This topic is locked and can not be replied to.