Forum: Ruby on Rails problems on os x tiger (with xcode 2.2)

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
F6176c324ae018957b32b63785b82e38?d=identicon&s=25 warnero (Guest)
on 2005-12-08 05:22
(Received via mailing list)
It appears that I'm able to install and update just about everything,
however when i try and run rails [project] I keep getting this error
message:
    Rails requires Ruby version 1.8.2 (2004-12-25) or later.
    You're running 1.8.2 (2004-11-03); please upgrade to continue.

I have tried to run this (which appears to have worked, but not solved
the issue):
http://www.tonyarnold.com/articles/2005/08/10/roll...

I found this:
http://hivelogic.com/articles/2005/12/01/ruby_rail...
which recommends actually building ruby, but I haven't seen others
with this issue on the list, is this really what I need to do?

Just starting a new project after playing around with this on panther
and would like to get back on track again.

-warner
84962fcce3fbde5aef15001d60e242ae?d=identicon&s=25 grzm (Guest)
on 2005-12-08 06:10
(Received via mailing list)
On Dec 8, 2005, at 13:22 , Warner Onstine wrote:

> I found this:
> http://hivelogic.com/articles/2005/12/01/
> ruby_rails_lighttpd_mysql_tiger
> which recommends actually building ruby, but I haven't seen others
> with this issue on the list, is this really what I need to do?

That's what I did. It's painless. Dan Benjamin's instructions are
clear and easy to follow.


Michael Glaesemann
grzm myrealbox com
Eea7ad39737b0dbf3de38874e0a6c7d8?d=identicon&s=25 justin (Guest)
on 2005-12-08 07:52
(Received via mailing list)
Michael Glaesemann wrote:
> and easy to follow.
I agree.

But first double-check that you have whatever new Ruby, gem and Rails
you installed on your PATH, e.g.

$ which ruby
/usr/local/bin/ruby
$ ruby -v
ruby 1.8.2 (2004-12-25) [powerpc-darwin8.3.0]

regards

   Justin
280b41a88665fd8c699e83a9a25ef949?d=identicon&s=25 steve (Guest)
on 2005-12-08 19:31
(Received via mailing list)
Warner Onstine wrote:
> It appears that I'm able to install and update just about everything,
> however when i try and run rails [project] I keep getting this error
> message:

Check out [Locomotive][1].

--Steve

[1]: http://locomotive.sourceforge.net/
This topic is locked and can not be replied to.