Forum: Ruby-Gnome 2 Visual Ruby start up

9669b5d39251d98a5ed35ef9d8e73ec1?d=identicon&s=25 Timothy Barnes (barnes7td)
on 2012-05-24 23:20
Eric,

I like the project. I was wondering why, when I start a new project, the
scaffold doesn't create a main file that allows the base window
application to run. Also it appears that the main file is a ruby file
but does not use the .rb extension. Is this true? Is this intended?

I look forward to trying visual ruby out.

Timothy
(barnes7td)
0d130f179f85401f248e6ebc2ef8292f?d=identicon&s=25 Eric C. (eric_c)
on 2012-05-25 03:59
Hi Timothy:


Thanks for pointing that out.  I fixed  the latest version so it
installs a file main.rb.

Now. If you open an empty folder, it should create a "Hello World"
project as in the video on the main page, visualruby.net.

You can test this by:

gem uninstall visualruby
gem install visualruby

open a blank folder, and click the run button.

If this doesn't work for you, please let me know.

Thanks,
Eric
9669b5d39251d98a5ed35ef9d8e73ec1?d=identicon&s=25 Timothy Barnes (barnes7td)
on 2012-05-25 15:41
Eric,

The new gem worked great. Right now I have only tried this on Windows
XP. And when I run it I get an error:

Gtk-WARNING **:Unknown property: GtkMenu.ubuntu-local

This doesn't stop vr from running. Just wanted to give you feedback.

Timothy
9669b5d39251d98a5ed35ef9d8e73ec1?d=identicon&s=25 Timothy Barnes (barnes7td)
on 2012-05-25 16:08
Nevermind about the warning. I noticed it has already been brought to
your attention earlier.

Timothy

P.S. I will trying setting up visualruby on my mac tonight and let you
know what happens.
0d130f179f85401f248e6ebc2ef8292f?d=identicon&s=25 Eric C. (eric_c)
on 2012-05-25 23:47
Thank you Timothy.  Yes, that gyk-local warning pops up on my XP machine
too.  I just ignore it.  Glade likes to spit out a bunch of warnings.
Many don't seem to have any effect.

Please let me know how to install on the MAC.  It hangs on my friends
computer.  Any feedback would be greatly appreciated.

Best,
Eric
9669b5d39251d98a5ed35ef9d8e73ec1?d=identicon&s=25 Timothy Barnes (barnes7td)
on 2012-05-28 22:03
Eric,

I have am running OS X "snow leopard" and did a gem install visualruby
and it worked just fine. I am using RVM , ruby 1.9.2p180, XQuartz 2.6.3.
I have attached a screenshot for proof.

It also worked on ruby 1.9.3p125.

I have used green shoes quite a bit and have worked through most of the
gtk dependencies. That is maybe why it worked so easily for me.

Let me know if I can help any further.

Timothy
D9ba13de4e62fcabffa4403731434e42?d=identicon&s=25 Eric C. (eric_c65)
on 2012-05-29 03:24
Hey Timothy:

Thanks that's great news.  I need to understand how to install gtk on
the MAC.  Can you give me instructions?

What are the gtk dependencies?

Keep in mind that I know nothing about mac os.

Thanks,
Eric
Please log in before posting. Registration is free and takes only a minute.
Existing account

NEW: Do you have a Google/GoogleMail, Yahoo or Facebook account? No registration required!
Log in with Google account | Log in with Yahoo account | Log in with Facebook account
No account? Register here.