Forum: Ferret Frustrating Ferret

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
Amir Z. (Guest)
on 2012-05-24 15:19
I stuck in search element problem. I am trying to install ferret on my
window 7. But tried a lot but couldn't succeed.

I ran following command to install the ferret gem.

gem install ferret
gem install ferret --version (all versions)
gem install ferret -v 0.11.5
gem install ferret -v 0.11.6
gem install ferret -v
gem install ferret -v=0.11.6 --platform mswin32

I also changed the devkit, got a updated kit and change requisite path
in fstub

But couldn't succeed. Always it gives me following error
ERROR:  Error installing ferret:
        ERROR: Failed to build gem native extension.

        c:/RailsInstaller/Ruby1.9.2/bin/ruby.exe extconf.rb
creating Makefile

c:/RailsInstaller/Ruby1.9.2/bin/ruby -e "puts 'EXPORTS',
'Init_ferret_ext'"  > f
ferret.c:297:22: error: 'struct RString' has no member named 'len'
make: *** [ferret.o] Error 1

Gem files will remain installed in
.1/gems/ferret-0.11.6 for inspection.
Results logged to

Please help me.

Any help or suggestion is appreciable.

This topic is locked and can not be replied to.