Forum: JRuby require 'java' circular dependency

Bec38d63650c8912b6ba9b557fb953b9?d=identicon&s=25 Roger Pack (rogerdpack)
on 2012-05-23 18:02
Hello all.
Noticed today that with yesterday's build, I get this "scary" message:


$ jruby -ve "require 'java'"
jruby 1.7.0.preview1 (ruby-1.9.3-p203) (2012-05-17 c550df6) (Java
HotSpot(TM) Client VM 1.6.0_32) [Windows 7-x86-java]
c:/dev/ruby/downloads/jruby/lib/ruby/shared/rubygems/custom_require.rb:36
warning: loading in progress, circular require considered harmful - java
  require at org/jruby/RubyKernel.java:991
  require at
c:/dev/ruby/downloads/jruby/lib/ruby/shared/rubygems/custom_require.rb:36
   (root) at c:/dev/ruby/downloads/jruby/lib/ruby/shared/jruby.rb:1
  require at org/jruby/RubyKernel.java:991
   (root) at
c:/dev/ruby/downloads/jruby/lib/ruby/shared/rubygems/custom_require.rb:1
  require at
c:/dev/ruby/downloads/jruby/lib/ruby/shared/rubygems/custom_require.rb:36
  require at org/jruby/RubyKernel.java:991
   (root) at
file:/C:/dev/ruby/downloads/jruby/lib/jruby.jar!/jruby/java/java_ext/java.io.rb:1
   (root) at
c:/dev/ruby/downloads/jruby/lib/ruby/shared/rubygems/custom_require.rb:1
  require at org/jruby/RubyKernel.java:991
  require at
c:/dev/ruby/downloads/jruby/lib/ruby/shared/rubygems/custom_require.rb:36
   (root) at
file:/C:/dev/ruby/downloads/jruby/lib/jruby.jar!/jruby/java/java_ext.rb:6
  require at org/jruby/RubyKernel.java:991
   (root) at
c:/dev/ruby/downloads/jruby/lib/ruby/shared/rubygems/custom_require.rb:1
   (root) at -e:1
c:/dev/ruby/downloads/jruby/lib/ruby/shared/rubygems/custom_require.rb:36
warning: loading in progress, circular require considered harmful - java
  require at org/jruby/RubyKernel.java:991
  require at org/jruby/RubyKernel.java:991
  require at
c:/dev/ruby/downloads/jruby/lib/ruby/shared/rubygems/custom_require.rb:36
   (root) at c:/dev/ruby/downloads/jruby/lib/ruby/shared/jruby.rb:148
  require at org/jruby/RubyKernel.java:991
   (root) at
c:/dev/ruby/downloads/jruby/lib/ruby/shared/rubygems/custom_require.rb:1
  require at
c:/dev/ruby/downloads/jruby/lib/ruby/shared/rubygems/custom_require.rb:36
  require at org/jruby/RubyKernel.java:991
   (root) at
file:/C:/dev/ruby/downloads/jruby/lib/jruby.jar!/jruby/java/java_ext/java.io.rb:1
   (root) at
c:/dev/ruby/downloads/jruby/lib/ruby/shared/rubygems/custom_require.rb:1
  require at org/jruby/RubyKernel.java:991
  require at
c:/dev/ruby/downloads/jruby/lib/ruby/shared/rubygems/custom_require.rb:36
   (root) at
file:/C:/dev/ruby/downloads/jruby/lib/jruby.jar!/jruby/java/java_ext.rb:6
  require at org/jruby/RubyKernel.java:991
   (root) at
c:/dev/ruby/downloads/jruby/lib/ruby/shared/rubygems/custom_require.rb:1
   (root) at -e:1

May want to clean that...
-r
F1d37642fdaa1662ff46e4c65731e9ab?d=identicon&s=25 Charles Nutter (headius)
on 2012-06-08 21:45
(Received via mailing list)
Confirmed. Toss into a bug (JIRA or GH).

- Charlie
Bec38d63650c8912b6ba9b557fb953b9?d=identicon&s=25 Roger Pack (rogerdpack)
on 2012-06-09 16:22
Bec38d63650c8912b6ba9b557fb953b9?d=identicon&s=25 Roger Pack (rogerdpack)
on 2012-06-12 22:00
And fixed, thanks!
Please log in before posting. Registration is free and takes only a minute.
Existing account

NEW: Do you have a Google/GoogleMail, Yahoo or Facebook account? No registration required!
Log in with Google account | Log in with Yahoo account | Log in with Facebook account
No account? Register here.