Forum: Italian Ruby user group Installazione de ruby on rails ubuntu 12

A60814b57c6f518f59eb04a14f46272f?d=identicon&s=25 bat cla (batcla)
on 2012-05-07 11:03
Buongiorno a tutti,
Sono nuovo in Ruby on Rails.
Per piacere una mano vorrei sapere i passi esatti per installare
Ruby on Rails in Ubuntu 12 o Win 7 64bit
Sono due giorni che cerco di installarlo ma non riesco.
Sono un cretino.
Ho visto tutoriali pero uno é differente dall'altro

Arrivo a la fine le do http://localhost:3000
e non si inicia.

Una mano per piacere a un "Novato"

Grazie
Un saluto
321db48bf4bdf48da05e781325aed20a?d=identicon&s=25 Maurizio De magnis (olistik)
on 2012-05-07 11:23
(Received via mailing list)
L'ho fatto da poco su Ubuntu 12.04 (32 bit) installato da 0 con Virtual
Box, appena riesco a chiudere un processo in corso, apro la macchina
virtuale e ti condivido il documento con *tutti* i passaggi :-)

Maurizio
--
My profile <https://plus.google.com/100973969013103507046/about>




2012/5/7 bat cla <batcla@hotmail.es>
A60814b57c6f518f59eb04a14f46272f?d=identicon&s=25 bat cla (batcla)
on 2012-05-07 11:30
Maurizio De magnis wrote in post #1059796:
> L'ho fatto da poco su Ubuntu 12.04 (32 bit) installato da 0 con Virtual
> Box, appena riesco a chiudere un processo in corso, apro la macchina
> virtuale e ti condivido il documento con *tutti* i passaggi :-)
>
> Maurizio
> --
> My profile <https://plus.google.com/100973969013103507046/about>
>
>
>
>
> 2012/5/7 bat cla <batcla@hotmail.es>

Grazie
sto diventando matto,
non capisco perche el localhost:3000
non fa niente ho notato tanta confusione

Grazie Mille

Un saluto
60d195c28fdbcb111932b5f1b90c012d?d=identicon&s=25 Andrea Mazzanti (Guest)
on 2012-05-07 11:41
(Received via mailing list)
Installato sulla 12 senza problemi con caro vecchio sistema: $gem
install rails --v 3.2.2
Ciao
Andrea Mazzanti

Program Manager MSN - Bing - Microsoft Corp

Mail: mazzantia@hotmail.com
Skype: Gammaglobulino
Linkedin: http://www.linkedin.com/in/andreamazzanti

m. UK  +447577124243
m. IT   +393481512952
m. ES   +393481512952



 > Date: Mon, 7 May 2012 11:30:52 +0200
32d80da41830a6e6c1bb3eb977537e3e?d=identicon&s=25 Alessandro R. (alessandro_r)
on 2012-05-07 11:44
(Received via mailing list)
http://ryanbigg.com/2010/12/ubuntu-ruby-rvm-rails-and-you/

io ho seguito questo ed  andato tutto alla grande!

2012/5/7 Andrea Mazzanti <mazzantia@hotmail.com>
A60814b57c6f518f59eb04a14f46272f?d=identicon&s=25 bat cla (batcla)
on 2012-05-07 11:51
Alessandro R. wrote in post #1059805:
> http://ryanbigg.com/2010/12/ubuntu-ruby-rvm-rails-and-you/
>
> io ho seguito questo ed  andato tutto alla grande!
>
> 2012/5/7 Andrea Mazzanti <mazzantia@hotmail.com>

Grazie
ho provato con rvm ma mi da errore
non lo so sicuramente faccio qualcosa che non va

un saluto
A60814b57c6f518f59eb04a14f46272f?d=identicon&s=25 bat cla (batcla)
on 2012-05-07 12:03
bat cla wrote in post #1059807:
> Alessandro R. wrote in post #1059805:
>> http://ryanbigg.com/2010/12/ubuntu-ruby-rvm-rails-and-you/
>>
>> io ho seguito questo ed  andato tutto alla grande!
>>
>> 2012/5/7 Andrea Mazzanti <mazzantia@hotmail.com>
>
> Grazie
> ho provato con rvm ma mi da errore
> non lo so sicuramente faccio qualcosa che non va
>
> un saluto

Grazie
vado e lo provo
speriamo che tutto vada bene

Un saludo
321db48bf4bdf48da05e781325aed20a?d=identicon&s=25 Maurizio De magnis (olistik)
on 2012-05-07 12:09
(Received via mailing list)
2012/5/7 bat cla <batcla@hotmail.es>

> Maurizio De magnis wrote in post #1059796:
> > L'ho fatto da poco su Ubuntu 12.04 (32 bit) installato da 0 con Virtual
> > Box, appena riesco a chiudere un processo in corso, apro la macchina
> > virtuale e ti condivido il documento con *tutti* i passaggi :-)
>

Eccolo: https://gist.github.com/2627011

Maurizio
--
My profile <https://plus.google.com/100973969013103507046/about>
A60814b57c6f518f59eb04a14f46272f?d=identicon&s=25 bat cla (batcla)
on 2012-05-07 12:41
Maurizio De magnis wrote in post #1059809:
> 2012/5/7 bat cla <batcla@hotmail.es>
>
>> Maurizio De magnis wrote in post #1059796:
>> > L'ho fatto da poco su Ubuntu 12.04 (32 bit) installato da 0 con Virtual
>> > Box, appena riesco a chiudere un processo in corso, apro la macchina
>> > virtuale e ti condivido il documento con *tutti* i passaggi :-)
>>
>
> Eccolo: https://gist.github.com/2627011
>
> Maurizio
> --
> My profile <https://plus.google.com/100973969013103507046/about>

Scusatemi
prima di installare Ruby on Rails mi conviene instalar MYsql server
e se la risposta é si que cosa installo lampp o Mysql server solo
321db48bf4bdf48da05e781325aed20a?d=identicon&s=25 Maurizio De magnis (olistik)
on 2012-05-07 13:33
(Received via mailing list)
2012/5/7 bat cla <batcla@hotmail.es>

> Scusatemi
> prima di installare Ruby on Rails mi conviene instalar MYsql server
>

Di default le applicazioni rails create non usano mysql, bensi' sqlite,
quindi no, mysql non e' necessario.

Su Ubuntu ti consiglio di installare i pacchetti "sqlite3" e
"libsqlite3-dev" per far si che l'applicazione rails riesca a gestire il
database:

sudo apt-get install sqlite3 libsqlite3-dev

e qualora tu non l'abbia ancora fatto, dall'interno della tua
applicazione
rails esegui "bundle install".

Se riscontri degli errori, incollali qua, cosi' capiamo meglio il tuo
problema :-)

e se la risposta  si que cosa installo lampp o Mysql server solo
>

qualora decidessi di migrare da sqlite a mysql, ti consiglio di
installare
il server mysql tramite apt-get:

sudo apt-get install mysql-server mysql-client libmysqlclient-dev

e poi aggiornare la tua applicazione.
Per maggiori informazioni, c'e' l'insostituibile guida:

http://guides.rubyonrails.org/getting_started.html

Maurizio
--
My profile <https://plus.google.com/100973969013103507046/about>
A60814b57c6f518f59eb04a14f46272f?d=identicon&s=25 bat cla (batcla)
on 2012-05-07 14:01
Maurizio De magnis wrote in post #1059819:
> 2012/5/7 bat cla <batcla@hotmail.es>
>
>> Scusatemi
>> prima di installare Ruby on Rails mi conviene instalar MYsql server
>>
>
> Di default le applicazioni rails create non usano mysql, bensi' sqlite,
> quindi no, mysql non e' necessario.
>
> Su Ubuntu ti consiglio di installare i pacchetti "sqlite3" e
> "libsqlite3-dev" per far si che l'applicazione rails riesca a gestire il
> database:
>
> sudo apt-get install sqlite3 libsqlite3-dev
>
> e qualora tu non l'abbia ancora fatto, dall'interno della tua
> applicazione
> rails esegui "bundle install".
>
> Se riscontri degli errori, incollali qua, cosi' capiamo meglio il tuo
> problema :-)
>
> e se la risposta  si que cosa installo lampp o Mysql server solo
>>
>
> qualora decidessi di migrare da sqlite a mysql, ti consiglio di
> installare
> il server mysql tramite apt-get:
>
> sudo apt-get install mysql-server mysql-client libmysqlclient-dev
>
> e poi aggiornare la tua applicazione.
> Per maggiori informazioni, c'e' l'insostituibile guida:
>
> http://guides.rubyonrails.org/getting_started.html
>
> Maurizio
> --
> My profile <https://plus.google.com/100973969013103507046/about>

Grazie
eri incredibile
fino a hora non ho avuto nessun problema
la cosa che mi da un po di vergogna é che utilizeró il foro
costantemente.
Sto cominciando con ruby e devo e voglio imparare
un una ultima cosa come posso vedere se tutto é installato corettamente

Grazie di nuovo
Ciao
A60814b57c6f518f59eb04a14f46272f?d=identicon&s=25 bat cla (batcla)
on 2012-05-07 14:11
$ rails new prova
ERROR:

      create  test/fixtures
      create  test/fixtures/.gitkeep
      create  test/functional
      create  test/functional/.gitkeep
      create  test/integration
      create  test/integration/.gitkeep
      create  test/unit
      create  test/unit/.gitkeep
      create  test/performance/browsing_test.rb
      create  test/test_helper.rb
      create  tmp/cache
      create  tmp/cache/assets
      create  vendor/assets/javascripts
      create  vendor/assets/javascripts/.gitkeep
      create  vendor/assets/stylesheets
      create  vendor/assets/stylesheets/.gitkeep
      create  vendor/plugins
      create  vendor/plugins/.gitkeep
         run  bundle install
Fetching gem metadata from https://rubygems.org/.........
Using rake (0.9.2.2)
Using i18n (0.6.0)
Using multi_json (1.3.4)
Using activesupport (3.2.3)
Using builder (3.0.0)
Using activemodel (3.2.3)
Using erubis (2.7.0)
Using journey (1.0.3)
Using rack (1.4.1)
Using rack-cache (1.2)
Using rack-test (0.6.1)
Using hike (1.2.1)
Using tilt (1.3.3)
Using sprockets (2.1.3)
Using actionpack (3.2.3)
Using mime-types (1.18)
Using polyglot (0.3.3)
Using treetop (1.4.10)
Using mail (2.4.4)
Using actionmailer (3.2.3)
Using arel (3.0.2)
Using tzinfo (0.3.33)
Using activerecord (3.2.3)
Using activeresource (3.2.3)
Using bundler (1.1.3)
Installing coffee-script-source (1.3.1)
Installing execjs (1.3.1)
Installing coffee-script (2.2.0)
Using rack-ssl (1.3.2)
Installing json (1.7.1) with native extensions
Installing rdoc (3.12)
Using thor (0.14.6)
Using railties (3.2.3)
Installing coffee-rails (3.2.2)
Installing jquery-rails (2.0.2)
Using rails (3.2.3)
Installing sass (3.1.17)
Installing sass-rails (3.2.5)
Installing sqlite3 (1.3.6) with native extensions
Gem::Installer::ExtensionBuildError: ERROR: Failed to build gem native
extension.

        /home/claudio/.rbenv/versions/1.9.3-p194/bin/ruby extconf.rb
checking for sqlite3.h... no
sqlite3.h is missing. Try 'port install sqlite3 +universal'
or 'yum install sqlite-devel' and check your shared library search path
(the
location where your sqlite3 shared library is located).
*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of
necessary libraries and/or headers.  Check the mkmf.log file for more
details.  You may need configuration options.

Provided configuration options:
  --with-opt-dir
  --without-opt-dir
  --with-opt-include
  --without-opt-include=${opt-dir}/include
  --with-opt-lib
  --without-opt-lib=${opt-dir}/lib
  --with-make-prog
  --without-make-prog
  --srcdir=.
  --curdir
  --ruby=/home/claudio/.rbenv/versions/1.9.3-p194/bin/ruby
  --with-sqlite3-dir
  --without-sqlite3-dir
  --with-sqlite3-include
  --without-sqlite3-include=${sqlite3-dir}/include
  --with-sqlite3-lib
  --without-sqlite3-lib=${sqlite3-dir}/lib
  --enable-local
  --disable-local


Gem files will remain installed in
/home/claudio/.rbenv/versions/1.9.3-p194/lib/ruby/gems/1.9.1/gems/sqlite3-1.3.6
for inspection.
Results logged to
/home/claudio/.rbenv/versions/1.9.3-p194/lib/ruby/gems/1.9.1/gems/sqlite3-1.3.6/ext/sqlite3/gem_make.out
An error occured while installing sqlite3 (1.3.6), and Bundler cannot
continue.
Make sure that `gem install sqlite3 -v '1.3.6'` succeeds before
bundling.
claudio@claudio-pc:~$ ^C




Maurizio De magnis wrote in post #1059819:
> 2012/5/7 bat cla <batcla@hotmail.es>
>
>> Scusatemi
>> prima di installare Ruby on Rails mi conviene instalar MYsql server
>>
>
> Di default le applicazioni rails create non usano mysql, bensi' sqlite,
> quindi no, mysql non e' necessario.
>
> Su Ubuntu ti consiglio di installare i pacchetti "sqlite3" e
> "libsqlite3-dev" per far si che l'applicazione rails riesca a gestire il
> database:
>
> sudo apt-get install sqlite3 libsqlite3-dev
>
> e qualora tu non l'abbia ancora fatto, dall'interno della tua
> applicazione
> rails esegui "bundle install".
>
> Se riscontri degli errori, incollali qua, cosi' capiamo meglio il tuo
> problema :-)
>
> e se la risposta  si que cosa installo lampp o Mysql server solo
>>
>
> qualora decidessi di migrare da sqlite a mysql, ti consiglio di
> installare
> il server mysql tramite apt-get:
>
> sudo apt-get install mysql-server mysql-client libmysqlclient-dev
>
> e poi aggiornare la tua applicazione.
> Per maggiori informazioni, c'e' l'insostituibile guida:
>
> http://guides.rubyonrails.org/getting_started.html
>
> Maurizio
> --
> My profile <https://plus.google.com/100973969013103507046/about>
A1bc8563b294df7078d1ce3d634f5d17?d=identicon&s=25 Luigi Maselli - grigio.org (grigio)
on 2012-05-07 14:12
Puoi provare a dare il comando:

gem list

oppure
vai su: http://localhost:3000/rails/info/properties
Poi dipende cosa intendi per "tutto é installato corettamente"

Ciao
Luigi

bat cla wrote in post #1059823:
>
> Grazie
> eri incredibile
> fino a hora non ho avuto nessun problema
> la cosa che mi da un po di vergogna é che utilizeró il foro
> costantemente.
> Sto cominciando con ruby e devo e voglio imparare
> un una ultima cosa come posso vedere se tutto é installato corettamente
>
> Grazie di nuovo
> Ciao
A60814b57c6f518f59eb04a14f46272f?d=identicon&s=25 bat cla (batcla)
on 2012-05-07 14:28
$ gem List

journey (1.0.3)
jquery-rails (2.0.2)
json (1.7.1, 1.5.4)
mail (2.4.4)
mime-types (1.18)
minitest (2.5.1)
multi_json (1.3.4)
polyglot (0.3.3)
rack (1.4.1)
rack-cache (1.2)
rack-ssl (1.3.2)
rack-test (0.6.1)
rails (3.2.3)
railties (3.2.3)
rake (0.9.2.2)
rdoc (3.12, 3.9.4)
sass (3.1.17)
sass-rails (3.2.5)
sprockets (2.1.3)
thor (0.14.6)
tilt (1.3.3)
treetop (1.4.10)
tzinfo (0.3.33)

2-http://localhost:3000/rails/info/properties

pagina "Unable to connect"

Nella Istalazione non mi ha dato errori

grazie



Luigi Maselli - grigio.org wrote in post #1059826:
> Puoi provare a dare il comando:
>
> gem list
>
> oppure
> vai su: http://localhost:3000/rails/info/properties
> Poi dipende cosa intendi per "tutto é installato corettamente"
>
> Ciao
> Luigi
>
> bat cla wrote in post #1059823:
>>
>> Grazie
>> eri incredibile
>> fino a hora non ho avuto nessun problema
>> la cosa che mi da un po di vergogna é che utilizeró il foro
>> costantemente.
>> Sto cominciando con ruby e devo e voglio imparare
>> un una ultima cosa come posso vedere se tutto é installato corettamente
>>
>> Grazie di nuovo
>> Ciao
321db48bf4bdf48da05e781325aed20a?d=identicon&s=25 Maurizio De magnis (olistik)
on 2012-05-07 14:33
(Received via mailing list)
> *** extconf.rb failed ***
Mmh, come sospettavo, non riesce ad installarti la gemma sqlite3.

Hai provato a fare:

sudo apt-get install sqlite3 libsqlite3-dev

?

Maurizio
--
My profile <https://plus.google.com/100973969013103507046/about>




2012/5/7 bat cla <batcla@hotmail.es>
A60814b57c6f518f59eb04a14f46272f?d=identicon&s=25 bat cla (batcla)
on 2012-05-07 14:42
Maurizio
ho instato sqlite 3 e mi crea il progetto

per il localhost:3000 non mi funziona

Grazie

Maurizio De magnis wrote in post #1059832:
>> *** extconf.rb failed ***
> Mmh, come sospettavo, non riesce ad installarti la gemma sqlite3.
>
> Hai provato a fare:
>
> sudo apt-get install sqlite3 libsqlite3-dev
>
> ?
>
> Maurizio
> --
> My profile <https://plus.google.com/100973969013103507046/about>
>
>
>
>
> 2012/5/7 bat cla <batcla@hotmail.es>
321db48bf4bdf48da05e781325aed20a?d=identicon&s=25 Maurizio De magnis (olistik)
on 2012-05-07 14:45
(Received via mailing list)
Qual'e' l'output dei comandi:

rails server


e

curl http://localhost:3000


?

Maurizio
--
My profile <https://plus.google.com/100973969013103507046/about>




2012/5/7 bat cla <batcla@hotmail.es>
A60814b57c6f518f59eb04a14f46272f?d=identicon&s=25 bat cla (batcla)
on 2012-05-07 14:57
Il progetto lo chiamo (rere)

$cd rere

$rere>rails server

  from
/home/claudio/.rbenv/versions/1.9.3-p194/lib/ruby/gems/1.9.1/gems/bundler-1.1.3/lib/bundler/runtime.rb:68:in
`block (2 levels) in require'
  from
/home/claudio/.rbenv/versions/1.9.3-p194/lib/ruby/gems/1.9.1/gems/bundler-1.1.3/lib/bundler/runtime.rb:66:in
`each'
  from
/home/claudio/.rbenv/versions/1.9.3-p194/lib/ruby/gems/1.9.1/gems/bundler-1.1.3/lib/bundler/runtime.rb:66:in
`block in require'
  from
/home/claudio/.rbenv/versions/1.9.3-p194/lib/ruby/gems/1.9.1/gems/bundler-1.1.3/lib/bundler/runtime.rb:55:in
`each'
  from
/home/claudio/.rbenv/versions/1.9.3-p194/lib/ruby/gems/1.9.1/gems/bundler-1.1.3/lib/bundler/runtime.rb:55:in
`require'
  from
/home/claudio/.rbenv/versions/1.9.3-p194/lib/ruby/gems/1.9.1/gems/bundler-1.1.3/lib/bundler.rb:119:in
`require'
  from /home/claudio/rere/config/application.rb:7:in `<top (required)>'
  from
/home/claudio/.rbenv/versions/1.9.3-p194/lib/ruby/gems/1.9.1/gems/railties-3.2.3/lib/rails/commands.rb:53:in
`require'
  from
/home/claudio/.rbenv/versions/1.9.3-p194/lib/ruby/gems/1.9.1/gems/railties-3.2.3/lib/rails/commands.rb:53:in
`block in <top (required)>'
  from
/home/claudio/.rbenv/versions/1.9.3-p194/lib/ruby/gems/1.9.1/gems/railties-3.2.3/lib/rails/commands.rb:50:in
`tap'
  from
/home/claudio/.rbenv/versions/1.9.3-p194/lib/ruby/gems/1.9.1/gems/railties-3.2.3/lib/rails/commands.rb:50:in
`<top (required)>'
  from script/rails:6:in `require'
  from script/rails:6:in `<main>'


2-PROVA
$ rails new ./rere

  from
/home/claudio/.rbenv/versions/1.9.3-p194/lib/ruby/gems/1.9.1/gems/bundler-1.1.3/lib/bundler/runtime.rb:68:in
`block (2 levels) in require'
  from
/home/claudio/.rbenv/versions/1.9.3-p194/lib/ruby/gems/1.9.1/gems/bundler-1.1.3/lib/bundler/runtime.rb:66:in
`each'
  from
/home/claudio/.rbenv/versions/1.9.3-p194/lib/ruby/gems/1.9.1/gems/bundler-1.1.3/lib/bundler/runtime.rb:66:in
`block in require'
  from
/home/claudio/.rbenv/versions/1.9.3-p194/lib/ruby/gems/1.9.1/gems/bundler-1.1.3/lib/bundler/runtime.rb:55:in
`each'
  from
/home/claudio/.rbenv/versions/1.9.3-p194/lib/ruby/gems/1.9.1/gems/bundler-1.1.3/lib/bundler/runtime.rb:55:in
`require'
  from
/home/claudio/.rbenv/versions/1.9.3-p194/lib/ruby/gems/1.9.1/gems/bundler-1.1.3/lib/bundler.rb:119:in
`require'
  from /home/claudio/rere/config/application.rb:7:in `<top (required)>'
  from
/home/claudio/.rbenv/versions/1.9.3-p194/lib/ruby/gems/1.9.1/gems/railties-3.2.3/lib/rails/commands.rb:53:in
`require'
  from
/home/claudio/.rbenv/versions/1.9.3-p194/lib/ruby/gems/1.9.1/gems/railties-3.2.3/lib/rails/commands.rb:53:in
`block in <top (required)>'
  from
/home/claudio/.rbenv/versions/1.9.3-p194/lib/ruby/gems/1.9.1/gems/railties-3.2.3/lib/rails/commands.rb:50:in
`tap'
  from
/home/claudio/.rbenv/versions/1.9.3-p194/lib/ruby/gems/1.9.1/gems/railties-3.2.3/lib/rails/commands.rb:50:in
`<top (required)>'
  from script/rails:6:in `require'
  from script/rails:6:in `<main>'



Maurizio De magnis wrote in post #1059836:
> Qual'e' l'output dei comandi:
>
> rails server
>
>
> e
>
> curl http://localhost:3000
>
>
> ?
>
> Maurizio
> --
> My profile <https://plus.google.com/100973969013103507046/about>
>
>
>
>
> 2012/5/7 bat cla <batcla@hotmail.es>
321db48bf4bdf48da05e781325aed20a?d=identicon&s=25 Maurizio De magnis (olistik)
on 2012-05-07 15:03
(Received via mailing list)
Prova a dare l'output di questi comandi:

rbenv rehash
> which rails
> rails -v


Maurizio
--
My profile <https://plus.google.com/100973969013103507046/about>
5ffafe70176a99f175d16192fd5be69e?d=identicon&s=25 Luca P. (luca_p)
on 2012-05-07 15:04
(Received via mailing list)
OT, ma usano tutti rbenv tranne me?
La prossima macchina che tiro su lo provo.

On Mon, May 7, 2012 at 3:02 PM, maurizio de magnis <
321db48bf4bdf48da05e781325aed20a?d=identicon&s=25 Maurizio De magnis (olistik)
on 2012-05-07 15:04
(Received via mailing list)
Ah, vedo che stai usando rbenv, assicurati che non sia presente anche
rvm e
in caso fosse presente, rimuovilo con:

rvm implode


Maurizio
--
My profile <https://plus.google.com/100973969013103507046/about>
321db48bf4bdf48da05e781325aed20a?d=identicon&s=25 Maurizio De magnis (olistik)
on 2012-05-07 15:05
(Received via mailing list)
On 7 May 2012 15:03, Luca Pradovera <luca.pradovera@gmail.com> wrote:

> OT, ma usano tutti rbenv tranne me?
> La prossima macchina che tiro su lo provo.
>

E' nu babba' =)

Maurizio
--
My profile <https://plus.google.com/100973969013103507046/about>
A60814b57c6f518f59eb04a14f46272f?d=identicon&s=25 bat cla (batcla)
on 2012-05-07 15:07
Maurizio De magnis wrote in post #1059841:
> Prova a dare l'output di questi comandi:
>
> rbenv rehash
>> which rails
>> rails -v
>
>
> Maurizio
> --
> My profile <https://plus.google.com/100973969013103507046/about>


I Risultati:

claudio@claudio-pc:~$ which rails
/home/claudio/.rbenv/shims/rails
claudio@claudio-pc:~$ rails -v
Rails 3.2.3
321db48bf4bdf48da05e781325aed20a?d=identicon&s=25 Maurizio De magnis (olistik)
on 2012-05-07 15:14
(Received via mailing list)
On 7 May 2012 15:07, bat cla <batcla@hotmail.es> wrote:
>
> I Risultati:
>
> claudio@claudio-pc:~$ which rails
> /home/claudio/.rbenv/shims/rails
> claudio@claudio-pc:~$ rails -v
> Rails 3.2.3


Ok, qua sembra andare tutto correttamente.
Giusto per sicurezza, hai installato anche bundler?

gem install bundler


Poi, ho letto i log che hai passato prima, ma non vedo la causa
dell'errore, sei sicuro di averli copiati interamente?

riprova con:

rails new justatest 2> new-app.txt

rails server 2> server.txt


e posta il contenuto di new-app.txt e server.txt
A60814b57c6f518f59eb04a14f46272f?d=identicon&s=25 bat cla (batcla)
on 2012-05-07 15:24
identical  app/assets/javascripts/application.js
   identical  app/assets/stylesheets/application.css
   identical  app/controllers/application_controller.rb
   identical  app/helpers/application_helper.rb
       exist  app/mailers
       exist  app/models
   identical  app/views/layouts/application.html.erb
   identical  app/mailers/.gitkeep
   identical  app/models/.gitkeep
       exist  config
   identical  config/routes.rb
   identical  config/application.rb
   identical  config/environment.rb
       exist  config/environments
   identical  config/environments/development.rb
   identical  config/environments/production.rb
   identical  config/environments/test.rb
       exist  config/initializers
   identical  config/initializers/backtrace_silencers.rb
   identical  config/initializers/inflections.rb
   identical  config/initializers/mime_types.rb
    conflict  config/initializers/secret_token.rb
Overwrite /home/claudio/justatest/config/initializers/secret_token.rb?
(enter "h" for help) [Ynaqdh]

A questo punto lo do Y

       exist
   identical  README.rdoc
   identical  Rakefile
   identical  config.ru
   identical  .gitignore
   identical  Gemfile
       exist  app
   identical  app/assets/images/rails.png
   identical  app/assets/javascripts/application.js
   identical  app/assets/stylesheets/application.css
   identical  app/controllers/application_controller.rb
   identical  app/helpers/application_helper.rb
       exist  app/mailers
       exist  app/models
   identical  app/views/layouts/application.html.erb
   identical  app/mailers/.gitkeep
   identical  app/models/.gitkeep
       exist  config
   identical  config/routes.rb
   identical  config/application.rb
   identical  config/environment.rb
       exist  config/environments
   identical  config/environments/development.rb
   identical  config/environments/production.rb
   identical  config/environments/test.rb
       exist  config/initializers
   identical  config/initializers/backtrace_silencers.rb
   identical  config/initializers/inflections.rb
   identical  config/initializers/mime_types.rb
    conflict  config/initializers/secret_token.rb
Overwrite /home/claudio/justatest/config/initializers/secret_token.rb?
(enter "h" for help) [Ynaqdh] ^C
claudio@claudio-pc:~$ clear

claudio@claudio-pc:~$ rails new justatest 2> new-app.txt
       exist
   identical  README.rdoc
   identical  Rakefile
   identical  config.ru
   identical  .gitignore
   identical  Gemfile
       exist  app
   identical  app/assets/images/rails.png
   identical  app/assets/javascripts/application.js
   identical  app/assets/stylesheets/application.css
   identical  app/controllers/application_controller.rb
   identical  app/helpers/application_helper.rb
       exist  app/mailers
       exist  app/models
   identical  app/views/layouts/application.html.erb
   identical  app/mailers/.gitkeep
   identical  app/models/.gitkeep
       exist  config
   identical  config/routes.rb
   identical  config/application.rb
   identical  config/environment.rb
       exist  config/environments
   identical  config/environments/development.rb
   identical  config/environments/production.rb
   identical  config/environments/test.rb
       exist  config/initializers
   identical  config/initializers/backtrace_silencers.rb
   identical  config/initializers/inflections.rb
   identical  config/initializers/mime_types.rb
    conflict  config/initializers/secret_token.rb
Overwrite /home/claudio/justatest/config/initializers/secret_token.rb?
(enter "h" for help) [Ynaqdh] Y
       force  config/initializers/secret_token.rb
   identical  config/initializers/session_store.rb
   identical  config/initializers/wrap_parameters.rb
       exist  config/locales
   identical  config/locales/en.yml
   identical  config/boot.rb
   identical  config/database.yml
       exist  db
   identical  db/seeds.rb
       exist  doc
   identical  doc/README_FOR_APP
       exist  lib
       exist  lib/tasks
   identical  lib/tasks/.gitkeep
       exist  lib/assets
   identical  lib/assets/.gitkeep
       exist  log
   identical  log/.gitkeep
       exist  public
   identical  public/404.html
   identical  public/422.html
   identical  public/500.html
   identical  public/favicon.ico
   identical  public/index.html
   identical  public/robots.txt
       exist  script
   identical  script/rails
       exist  test/fixtures
   identical  test/fixtures/.gitkeep
       exist  test/functional
   identical  test/functional/.gitkeep
       exist  test/integration
   identical  test/integration/.gitkeep
       exist  test/unit
   identical  test/unit/.gitkeep
   identical  test/performance/browsing_test.rb
   identical  test/test_helper.rb
       exist  tmp/cache
       exist  tmp/cache/assets
       exist  vendor/assets/javascripts
   identical  vendor/assets/javascripts/.gitkeep
       exist  vendor/assets/stylesheets
   identical  vendor/assets/stylesheets/.gitkeep
       exist  vendor/plugins
   identical  vendor/plugins/.gitkeep
         run  bundle install
Using rake (0.9.2.2)
Using i18n (0.6.0)
Using multi_json (1.3.4)
Using activesupport (3.2.3)
Using builder (3.0.0)
Using activemodel (3.2.3)
Using erubis (2.7.0)
Using journey (1.0.3)
Using rack (1.4.1)
Using rack-cache (1.2)
Using rack-test (0.6.1)
Using hike (1.2.1)
Using tilt (1.3.3)
Using sprockets (2.1.3)
Using actionpack (3.2.3)
Using mime-types (1.18)
Using polyglot (0.3.3)
Using treetop (1.4.10)
Using mail (2.4.4)
Using actionmailer (3.2.3)
Using arel (3.0.2)
Using tzinfo (0.3.33)
Using activerecord (3.2.3)
Using activeresource (3.2.3)
Using coffee-script-source (1.3.1)
Using execjs (1.3.1)
Using coffee-script (2.2.0)
Using rack-ssl (1.3.2)
Using json (1.7.1)
Using rdoc (3.12)
Using thor (0.14.6)
Using railties (3.2.3)
Using coffee-rails (3.2.2)
Using jquery-rails (2.0.2)
Using bundler (1.1.3)
Using rails (3.2.3)
Using sass (3.1.17)
Using sass-rails (3.2.5)
Using sqlite3 (1.3.6)
Using uglifier (1.2.4)
Your bundle is complete! Use `bundle show [gemname]` to see where a
bundled gem is installed.




Maurizio De magnis wrote in post #1059848:
> On 7 May 2012 15:07, bat cla <batcla@hotmail.es> wrote:
>>
>> I Risultati:
>>
>> claudio@claudio-pc:~$ which rails
>> /home/claudio/.rbenv/shims/rails
>> claudio@claudio-pc:~$ rails -v
>> Rails 3.2.3
>
>
> Ok, qua sembra andare tutto correttamente.
> Giusto per sicurezza, hai installato anche bundler?
>
> gem install bundler
>
>
> Poi, ho letto i log che hai passato prima, ma non vedo la causa
> dell'errore, sei sicuro di averli copiati interamente?
>
> riprova con:
>
> rails new justatest 2> new-app.txt
>
> rails server 2> server.txt
>
>
> e posta il contenuto di new-app.txt e server.txt
321db48bf4bdf48da05e781325aed20a?d=identicon&s=25 Maurizio De magnis (olistik)
on 2012-05-07 15:28
(Received via mailing list)
Perfetto, ora se entri dentro la cartella del progetto creato e lanci

rails server


non dovresti ottenere degli errori (spero ;-))

Maurizio
--
My profile <https://plus.google.com/100973969013103507046/about>
A60814b57c6f518f59eb04a14f46272f?d=identicon&s=25 bat cla (batcla)
on 2012-05-07 15:32
Maurizio De magnis wrote in post #1059850:
> Perfetto, ora se entri dentro la cartella del progetto creato e lanci
>
> rails server
>
>
> non dovresti ottenere degli errori (spero ;-))
>
> Maurizio
> --
> My profile <https://plus.google.com/100973969013103507046/about>

Maurizio hai una pazienza infinita

claudio@claudio-pc:~$ cd justatest
claudio@claudio-pc:~/justatest$ rails server
/home/claudio/.rbenv/versions/1.9.3-p194/lib/ruby/gems/1.9.1/gems/execjs-1.3.1/lib/execjs/runtimes.rb:50:in
`autodetect': Could not find a JavaScript runtime. See
https://github.com/sstephenson/execjs for a list of available runtimes.
(ExecJS::RuntimeUnavailable)
  from
/home/claudio/.rbenv/versions/1.9.3-p194/lib/ruby/gems/1.9.1/gems/execjs-1.3.1/lib/execjs.rb:5:in
`<module:ExecJS>'
  from
/home/claudio/.rbenv/versions/1.9.3-p194/lib/ruby/gems/1.9.1/gems/execjs-1.3.1/lib/execjs.rb:4:in
`<top (required)>'
  from
/home/claudio/.rbenv/versions/1.9.3-p194/lib/ruby/gems/1.9.1/gems/coffee-script-2.2.0/lib/coffee_script.rb:1:in
`require'
  from
/home/claudio/.rbenv/versions/1.9.3-p194/lib/ruby/gems/1.9.1/gems/coffee-script-2.2.0/lib/coffee_script.rb:1:in
`<top (required)>'
  from
/home/claudio/.rbenv/versions/1.9.3-p194/lib/ruby/gems/1.9.1/gems/coffee-script-2.2.0/lib/coffee-script.rb:1:in
`require'
  from
/home/claudio/.rbenv/versions/1.9.3-p194/lib/ruby/gems/1.9.1/gems/coffee-script-2.2.0/lib/coffee-script.rb:1:in
`<top (required)>'
  from
/home/claudio/.rbenv/versions/1.9.3-p194/lib/ruby/gems/1.9.1/gems/coffee-rails-3.2.2/lib/coffee-rails.rb:1:in
`require'
  from
/home/claudio/.rbenv/versions/1.9.3-p194/lib/ruby/gems/1.9.1/gems/coffee-rails-3.2.2/lib/coffee-rails.rb:1:in
`<top (required)>'
  from
/home/claudio/.rbenv/versions/1.9.3-p194/lib/ruby/gems/1.9.1/gems/bundler-1.1.3/lib/bundler/runtime.rb:68:in
`require'
  from
/home/claudio/.rbenv/versions/1.9.3-p194/lib/ruby/gems/1.9.1/gems/bundler-1.1.3/lib/bundler/runtime.rb:68:in
`block (2 levels) in require'
  from
/home/claudio/.rbenv/versions/1.9.3-p194/lib/ruby/gems/1.9.1/gems/bundler-1.1.3/lib/bundler/runtime.rb:66:in
`each'
  from
/home/claudio/.rbenv/versions/1.9.3-p194/lib/ruby/gems/1.9.1/gems/bundler-1.1.3/lib/bundler/runtime.rb:66:in
`block in require'
  from
/home/claudio/.rbenv/versions/1.9.3-p194/lib/ruby/gems/1.9.1/gems/bundler-1.1.3/lib/bundler/runtime.rb:55:in
`each'
  from
/home/claudio/.rbenv/versions/1.9.3-p194/lib/ruby/gems/1.9.1/gems/bundler-1.1.3/lib/bundler/runtime.rb:55:in
`require'
  from
/home/claudio/.rbenv/versions/1.9.3-p194/lib/ruby/gems/1.9.1/gems/bundler-1.1.3/lib/bundler.rb:119:in
`require'
  from /home/claudio/justatest/config/application.rb:7:in `<top
(required)>'
  from
/home/claudio/.rbenv/versions/1.9.3-p194/lib/ruby/gems/1.9.1/gems/railties-3.2.3/lib/rails/commands.rb:53:in
`require'
  from
/home/claudio/.rbenv/versions/1.9.3-p194/lib/ruby/gems/1.9.1/gems/railties-3.2.3/lib/rails/commands.rb:53:in
`block in <top (required)>'
  from
/home/claudio/.rbenv/versions/1.9.3-p194/lib/ruby/gems/1.9.1/gems/railties-3.2.3/lib/rails/commands.rb:50:in
`tap'
  from
/home/claudio/.rbenv/versions/1.9.3-p194/lib/ruby/gems/1.9.1/gems/railties-3.2.3/lib/rails/commands.rb:50:in
`<top (required)>'
  from script/rails:6:in `require'
  from script/rails:6:in `<main>'
321db48bf4bdf48da05e781325aed20a?d=identicon&s=25 Maurizio De magnis (olistik)
on 2012-05-07 15:38
(Received via mailing list)
On 7 May 2012 15:32, bat cla <batcla@hotmail.es> wrote:
[cut]

> Maurizio hai una pazienza infinita
>

;-)

claudio@claudio-pc:~$ cd justatest
> claudio@claudio-pc:~/justatest$ rails server
>
>
/home/claudio/.rbenv/versions/1.9.3-p194/lib/ruby/gems/1.9.1/gems/execjs-1.3.1/lib/execjs/runtimes.rb:50:in
> `autodetect': Could not find a JavaScript runtime. See
> https://github.com/sstephenson/execjs for a list of available runtimes.
> (ExecJS::RuntimeUnavailable)
>

ok, mancherebbe solo:

sudo apt-get install nodejs
A60814b57c6f518f59eb04a14f46272f?d=identicon&s=25 bat cla (batcla)
on 2012-05-07 15:48
Maurizio De magnis wrote in post #1059852:
> On 7 May 2012 15:32, bat cla <batcla@hotmail.es> wrote:
> [cut]
>
>> Maurizio hai una pazienza infinita
>>
>
> ;-)
>
> claudio@claudio-pc:~$ cd justatest
>> claudio@claudio-pc:~/justatest$ rails server
>>
>>
>
/home/claudio/.rbenv/versions/1.9.3-p194/lib/ruby/gems/1.9.1/gems/execjs-1.3.1/lib/execjs/runtimes.rb:50:in
>> `autodetect': Could not find a JavaScript runtime. See
>> https://github.com/sstephenson/execjs for a list of available runtimes.
>> (ExecJS::RuntimeUnavailable)
>>
>
> ok, mancherebbe solo:
>
> sudo apt-get install nodejs

Finalmente
Maurizio Grazie
mi piacerebbe saper lo che tu sai
hora faccio un file con tutte i passi necessari.
Una ultima cosa ....
Con que ID tu programmi?

Cuando vieni a Madrid ti invito a una "Paella"

Grazie di tutto
Un saluto
321db48bf4bdf48da05e781325aed20a?d=identicon&s=25 Maurizio De magnis (olistik)
on 2012-05-07 15:52
(Received via mailing list)
On 7 May 2012 15:48, bat cla <batcla@hotmail.es> wrote:

> Finalmente
> Maurizio Grazie
>

Prego!


> mi piacerebbe saper lo che tu sai
> hora faccio un file con tutte i passi necessari.
>

Ho fatto il gist proprio per questo motivo, cosi' le volte successive
non
incappo negli stessi problemi ;-)


> Una ultima cosa ....
> Con que ID tu programmi?
>

Su GitHub uso il nick "olistik" mentre tutti i miei profili (twitter,
etc)
sono qui:

https://plus.google.com/100973969013103507046/about

Cuando vieni a Madrid ti invito a una "Paella"
>

Ottimo! =)
4f4122bc3b9999d9050f0b1a10b63251?d=identicon&s=25 Andrea Reginato (reis)
on 2012-05-07 15:53
(Received via mailing list)
Maurizio for president!

2012/5/7 maurizio de magnis <maurizio.demagnis@gmail.com>

> On 7 May 2012 15:48, bat cla <batcla@hotmail.es> wrote:
>
> > Finalmente
> > Maurizio Grazie
>
> Prego!
>

--
Andrea Reginato
Lelylan | reThink your house
http://lelylan.com
321db48bf4bdf48da05e781325aed20a?d=identicon&s=25 Maurizio De magnis (olistik)
on 2012-05-07 15:57
(Received via mailing list)
On 7 May 2012 15:53, Andrea Reginato <andrea.reginato@gmail.com> wrote:

> Maurizio for president!
>

[image: Inline images 1]
A60814b57c6f518f59eb04a14f46272f?d=identicon&s=25 bat cla (batcla)
on 2012-05-07 18:37
Attachment: json.PNG (5 KB)
Maurizio De magnis wrote in post #1059859:
> On 7 May 2012 15:53, Andrea Reginato <andrea.reginato@gmail.com> wrote:
>
>> Maurizio for president!
>>
>
> [image: Inline images 1]
Ciao Maurizio,
quasi, quasi sono riuscito a istalarlo anche in windows 7
pero mi da un errore
ti mando una imagine del errore

mi quiede "JSON"
un saluto
321db48bf4bdf48da05e781325aed20a?d=identicon&s=25 Maurizio De magnis (olistik)
on 2012-05-07 18:43
(Received via mailing list)
On 7 May 2012 18:37, bat cla <batcla@hotmail.es> wrote:

> Ciao Maurizio,
> quasi, quasi sono riuscito a istalarlo anche in windows 7
> pero mi da un errore
> ti mando una imagine del errore
>
> mi quiede "JSON"
>

Ti dice che devi installare il DevKit, prova a scaricarlo e a seguire le
istruzioni presenti nella pagina github menzionata :-)

Maurizio
--
My profile <https://plus.google.com/100973969013103507046/about>
A60814b57c6f518f59eb04a14f46272f?d=identicon&s=25 bat cla (batcla)
on 2012-05-07 18:55
bat cla wrote in post #1059892:
> Maurizio De magnis wrote in post #1059859:
>> On 7 May 2012 15:53, Andrea Reginato <andrea.reginato@gmail.com> wrote:
>>
>>> Maurizio for president!
>>>
>>
>> [image: Inline images 1]
> Ciao Maurizio,
> quasi, quasi sono riuscito a istalarlo anche in windows 7
> pero mi da un errore
> ti mando una imagine del errore
>
> mi quiede "JSON"
> un saluto

OK ho trovato dove sbagliavo grazie a tutti
Please log in before posting. Registration is free and takes only a minute.
Existing account

NEW: Do you have a Google/GoogleMail, Yahoo or Facebook account? No registration required!
Log in with Google account | Log in with Yahoo account | Log in with Facebook account
No account? Register here.