Forum: JRuby Rails installation question: jRuby and IBM J9 JVM

1f77113371c7d36eae5c8a1f10137438?d=identicon&s=25 Pete Helgren (Guest)
on 2012-05-03 17:20
(Received via mailing list)
Running 'gem install rails'  with jRuby 1.6.7.2 and the IBM J9 JVM
(running it what would be equivalent to an AIX environment) delivers
several of these kinds of messages:
/usr/local/jruby-1.6.7.2/lib/ruby/site_ruby/1.8/rubygems/installer.rb:380
warning:
executable? does not in this environment and will return a dummy value

Question #1: Is there a way to tell which gem it is complaining about?

After the gem installation I saw this error and then an ugly stack
trace:
30 gems installed
Installing ri documentation for i18n-0.6.0...
Got throwable in Signal initialisation :
java.lang.IllegalArgumentException:
Unknown signal: INFO
java.lang.IllegalArgumentException: Unknown signal: INFO
         at
com.ibm.misc.AbstractSignalInfo.getSignalNumber(AbstractSignalInfo.java:47)
...........

Question #2:
None of the ri documentation installed.  Not fatal but annoying.  Any
idea what causes this (well, any idea of what unknown signal INFO is?)

I posted similar errors with jRuby about 13 months ago but got no
response.  I am presenting a session on jRuby and Rails at a conference
next week and would sure like to have something to demo.  Way back in
the jRuby 1.4 days Rails 2.x would run fine so I don't know what exactly
has changed in jRuby, Rails and maybe the JVM that is now causing the
issue.

'rails new'  and bundler also generate similar warnings but in pressing
ahead I can start rails but get this error when rendering the default
"Welcome" page:
Error compiling asset rails.png:
NotImplementedError: stat.st_gid unsupported or native support failed to
load

Missing gem perhaps?

Anyway, any assistance in working through these gem errors would be
appreciated.

--
Pete Helgren
Value Added Software, Inc
www.petesworkshop.com
GIAC Secure Software Programmer-Java
Please log in before posting. Registration is free and takes only a minute.
Existing account

NEW: Do you have a Google/GoogleMail, Yahoo or Facebook account? No registration required!
Log in with Google account | Log in with Yahoo account | Log in with Facebook account
No account? Register here.