Forum: IronRuby Error while installing Cucumber in IronRuby 1.1.1

4a4042832284e30749eacd55034feccc?d=identicon&s=25 Jialiang L. (jialiang_l)
on 2010-11-07 13:36
Hi there,

While I try to install Cucumber in IronRuby 1.1.1, and I got this error:

ERROR:While executing gem... (TypeError)
    can't convert NilClass into String

Looks like it is a null class exception. But I could not locate the
error just base on the error message.

Anyone have this problem before? Any help would be appreciated

Thanks in advance

Leo
D088176a3887d1effb8f267d2ec6f1b8?d=identicon&s=25 Mike Hatfield (Guest)
on 2010-11-07 15:26
(Received via mailing list)
Hi Leo,

There seems to be a general problem with the new igem installer.  I
haven't
been able to figure it out, but there's a fair bit of discussion on a
previous thread (without resolution).  I am looking forward to this
being
fixed.

Most gems I have tried to install since upgrading give me this same
NilClass
error message.

Mike
4a4042832284e30749eacd55034feccc?d=identicon&s=25 Jialiang L. (jialiang_l)
on 2010-11-09 03:45
Hi Mike,

Thanks for the quick reply.

Too bad there is not solution for this problem. I might install IronRuby
1.1 and see if it works.

Thanks

Leo
This topic is locked and can not be replied to.