Forum: Ruby on Rails Relative URL

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
C7180e54a366e1db76873df94e661843?d=identicon&s=25 numknuf (Guest)
on 2005-12-04 14:47
I'm trying to use a non default webserver with Rails and succesfully
does this by calling the disptacher directly, by setting the environment
variables: REQUEST_URI and SCRIPT_NAME

My problem is that the relative path is incorrect when I identify myself
as anything else than apache. In request.rb the @@relative_url_root is
only set when the webserver is apache. Is this default wanted behaviour?
Or is there another way of achieving this without settings routes?
C7180e54a366e1db76873df94e661843?d=identicon&s=25 numknuf <numknuf@gmail.com> (Guest)
on 2005-12-05 07:54
anyone?
E555e7c34196967444a47a96395a23ab?d=identicon&s=25 skaes (Guest)
on 2005-12-06 09:54
(Received via mailing list)
numknuf wrote:

>
You can set relative_url_root in your environment.rb file.

ActionController::AbstractRequest.relative_url_root = "/my_app_root"

HTH,

-- stefan

http://railsexpress.de/blog
C7180e54a366e1db76873df94e661843?d=identicon&s=25 numknuf (Guest)
on 2005-12-06 21:03
Thanks, that will solve my problem.
This topic is locked and can not be replied to.