Forum: Radiant CMS Fresh install (error): comparison of String with 60 failed

37bf689f37c69732158e782020db84f9?d=identicon&s=25 Jordon Bedwell (envygeeks)
on 2010-11-03 20:52
(Received via mailing list)
Rack 1.2
Rails 3
Ruby 1.9.2

Perhaps you guys and gals can help me figure out how to fix this error:

Processing SiteController#show_page (for # at 2010-11-03 14:32:33) [GET]
  Parameters: {"controller"=>"site", "action"=>"show_page", "url"=>"/"}


ArgumentError (comparison of String with 60 failed):
  radiant (0.9.1) vendor/radius/lib/radius/parser/scan.rb:421:in `<'
  radiant (0.9.1) vendor/radius/lib/radius/parser/scan.rb:421:in `block
in perform_parse'
  radiant (0.9.1) vendor/radius/lib/radius/parser/scan.rb:417:in `loop'
  radiant (0.9.1) vendor/radius/lib/radius/parser/scan.rb:417:in
`perform_parse'
  radiant (0.9.1) vendor/radius/lib/radius/parser/scan.rb:22:in
`operate'
  radiant (0.9.1) vendor/radius/lib/radius/parser.rb:37:in `tokenize'
  radiant (0.9.1) vendor/radius/lib/radius/parser.rb:29:in `parse'
  radiant (0.9.1) app/models/page.rb:302:in `parse'
  radiant (0.9.1) app/models/page.rb:307:in `parse_object'
  radiant (0.9.1) app/models/page.rb:127:in `render'
  radiant (0.9.1) app/models/page.rb:117:in `process'
  radiant (0.9.1) app/controllers/site_controller.rb:62:in
`process_page'
  radiant (0.9.1) app/controllers/site_controller.rb:21:in `show_page'
  <internal:prelude>:10:in `synchronize'
  passenger (3.0.0) lib/phusion_passenger/rack/request_handler.rb:96:in
`process_request'
  passenger (3.0.0)
lib/phusion_passenger/abstract_request_handler.rb:513:in
`accept_and_process_next_request'
  passenger (3.0.0)
lib/phusion_passenger/abstract_request_handler.rb:274:in `main_loop'
  passenger (3.0.0)
lib/phusion_passenger/classic_rails/application_spawner.rb:321:in
`start_request_handler'
  passenger (3.0.0)
lib/phusion_passenger/classic_rails/application_spawner.rb:275:in `block
in handle_spawn_application'
  passenger (3.0.0) lib/phusion_passenger/utils.rb:479:in `safe_fork'
  passenger (3.0.0)
lib/phusion_passenger/classic_rails/application_spawner.rb:270:in
`handle_spawn_application'
  passenger (3.0.0) lib/phusion_passenger/abstract_server.rb:357:in
`server_main_loop'
  passenger (3.0.0) lib/phusion_passenger/abstract_server.rb:206:in
`start_synchronously'
  passenger (3.0.0) lib/phusion_passenger/abstract_server.rb:180:in
`start'
  passenger (3.0.0)
lib/phusion_passenger/classic_rails/application_spawner.rb:149:in
`start'
  passenger (3.0.0) lib/phusion_passenger/spawn_manager.rb:219:in `block
(2 levels) in spawn_rails_application'
  passenger (3.0.0)
lib/phusion_passenger/abstract_server_collection.rb:132:in
`lookup_or_add'
  passenger (3.0.0) lib/phusion_passenger/spawn_manager.rb:214:in `block
in spawn_rails_application'
  passenger (3.0.0)
lib/phusion_passenger/abstract_server_collection.rb:82:in `block in
synchronize'
  <internal:prelude>:10:in `synchronize'
  passenger (3.0.0)
lib/phusion_passenger/abstract_server_collection.rb:79:in `synchronize'
  passenger (3.0.0) lib/phusion_passenger/spawn_manager.rb:213:in
`spawn_rails_application'
  passenger (3.0.0) lib/phusion_passenger/spawn_manager.rb:132:in
`spawn_application'
  passenger (3.0.0) lib/phusion_passenger/spawn_manager.rb:275:in
`handle_spawn_application'
  passenger (3.0.0) lib/phusion_passenger/abstract_server.rb:357:in
`server_main_loop'
  passenger (3.0.0) lib/phusion_passenger/abstract_server.rb:206:in
`start_synchronously'
  passenger (3.0.0) helper-scripts/passenger-spawn-server:99:in `<main>'
Efc9d9d149b91368c764d4eaee4c58ca?d=identicon&s=25 John Muhl (johnmuhl)
on 2010-11-03 21:05
(Received via mailing list)
On Wed, Nov 3, 2010 at 2:51 PM, Jordon Bedwell <jordon@envygeeks.com>
wrote:
> Rack 1.2
> Rails 3
> Ruby 1.9.2
>
> Perhaps you guys and gals can help me figure out how to fix this error:

try:

Rack 1.1.0
Rails 2.3.8 (Radiant has it vendored so your Rails 3 above is not
being loaded; i.e. you don't need to install Rails at all)
Ruby 1.8.7

Radiant does not run on any of the software you mentioned.
09477c358c5897d44121a248326e16d7?d=identicon&s=25 Jim Gay (Guest)
on 2010-11-03 21:15
(Received via mailing list)
On Nov 3, 2010, at 4:04 PM, john muhl wrote:

> Rails 2.3.8 (Radiant has it vendored so your Rails 3 above is not
> being loaded; i.e. you don't need to install Rails at all)
> Ruby 1.8.7
>
> Radiant does not run on any of the software you mentioned.

YET
37bf689f37c69732158e782020db84f9?d=identicon&s=25 Jordon Bedwell (envygeeks)
on 2010-11-03 21:53
(Received via mailing list)
On 11/03/2010 03:14 PM, Jim Gay wrote:
>> try:
>>
>> Rack 1.1.0
>> Rails 2.3.8 (Radiant has it vendored so your Rails 3 above is not
>> being loaded; i.e. you don't need to install Rails at all)
>> Ruby 1.8.7
>>
>> Radiant does not run on any of the software you mentioned.
>
> YET

Will do, thanks for pointing that out.
This topic is locked and can not be replied to.