Forum: Rails deployment SSL on Heroku

47ef98571db9f39e0062b88aaaa93134?d=identicon&s=25 Daniel Rove (drom)
on 2012-02-27 13:27
Since Heroku has integrated the piggybank_ssl addon by default, trying:

heroku addons:add piggyback_ssl
or
heroku addons:add ssl:piggyback

results in:
! This add-on is now a standard Heroku platform feature.
! Your apps can already use piggyback SSL.

But accessing: mywebsite.herokuapp.com results in:
SSL is not enabled
mywebsite.herokuapp.com does not have SSL enabled.

And I have the config.force_ssl = true in my production.rb

So, any hint of what i am missing ???
D8fd374e9e1811e5b5b8f37b667916bd?d=identicon&s=25 Max Maxwell (aamax)
on 2013-02-09 02:07
try specifying https on the front of your url... (?)

https://mywebsite.herokuapp.com



Daniel Rove wrote in post #1049029:
> Since Heroku has integrated the piggybank_ssl addon by default, trying:
>
> heroku addons:add piggyback_ssl
> or
> heroku addons:add ssl:piggyback
>
> results in:
> ! This add-on is now a standard Heroku platform feature.
> ! Your apps can already use piggyback SSL.
>
> But accessing: mywebsite.herokuapp.com results in:
> SSL is not enabled
> mywebsite.herokuapp.com does not have SSL enabled.
>
> And I have the config.force_ssl = true in my production.rb
>
> So, any hint of what i am missing ???
This topic is locked and can not be replied to.