Forum: Rails-ES Problema con la instalación de Gosu

374df51e1b94cff290cbc4116db6fa2c?d=identicon&s=25 Andrés CS (andrek)
on 2012-01-25 18:22
Tengo un problema al instalar la libreria/biblioteca Gosu
(http://www.libgosu.org/), yo la intento instalar con los siguientes
pasos:

1) Descargo la libreria/biblioteca Gosu versión: 0.7.41
(gosu-windows-0.7.41.zip  17-Dec-2011 05:29   9.7M)

2) Abro: RubyGems Package Manager (Inicio => Todos los programas =>
Ruby-185-21 => RubyGems => RubyGems Package Manager).

3) En base a: "gem install gosu"

gem: ruta del archivo "gem.bat".
install: es un comando para instalar.
gosu: ruta del archivo "Gosu.hpp".

Introdusco el siguiente codigo:

"c:\ruby>bin\gem install C:\ruby\LibGosu\Gosu\Gosu"

Que es lo mismo que (se entiende que detras de LibGosu esta escrita la
ruta por defecto): "c:\ruby>" que es: "c:\ruby\"):

"c:\ruby>bin\gem.bat install LibGosu\Gosu\Gosu.hpp"

El error que me produce es este:
"ERROR: while executing gem ... (Gem::RemoteSourceException)
HTTP Response 302"

* Versiones que tengo instaladas.

Ruby: 1.8.5
RubyGems: 0.9.0

Tengo Window Seven, espero respuesta. Muchas Gracias.
B2a871b025bd3b1f05c8f439c3b22c4f?d=identicon&s=25 Roberto Porcar (flamerz)
on 2012-01-26 16:19
Hola Andrés, aprovecho el hilo ya que estoy con lo mismo que tu.

llevo 2 horas intentando instalar Gosu en mi windows xp, sin resultados.
Si consigo algun avance escribiré en el foro.

este es el error:

C:\Ruby\bin>ruby gem install gosu --debug -V
Exception `NameError' at
C:/Ruby/lib/ruby/site_ruby/1.8/rubygems/command_manager
.rb:177 - uninitialized constant Gem::Commands::InstallCommand
Exception `Gem::LoadError' at
C:/Ruby/lib/ruby/site_ruby/1.8/rubygems/dependency
.rb:247 - Could not find psych (>= 1.2.1, ~> 1.2) amongst []
Exception `LoadError' at
C:/Ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.
rb:36 - no such file to load -- psych
Exception `LoadError' at
C:/Ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.
rb:62 - no such file to load -- psych
Exception `Zlib::DataError' at
C:/Ruby/lib/ruby/site_ruby/1.8/rubygems.rb:563 -
incorrect header check
ERROR:  While executing gem ... (Zlib::DataError)
    incorrect header check
        C:/Ruby/lib/ruby/site_ruby/1.8/rubygems.rb:563:in `inflate'
        C:/Ruby/lib/ruby/site_ruby/1.8/rubygems.rb:563:in `inflate'
        C:/Ruby/lib/ruby/site_ruby/1.8/rubygems/spec_fetcher.rb:122:in
`fetch_sp
ec'
        C:/Ruby/lib/ruby/site_ruby/1.8/rubygems/spec_fetcher.rb:95:in
`fetch_wit
h_errors'
        C:/Ruby/lib/ruby/site_ruby/1.8/rubygems/spec_fetcher.rb:94:in
`map'
        C:/Ruby/lib/ruby/site_ruby/1.8/rubygems/spec_fetcher.rb:94:in
`fetch_wit
h_errors'
        C:/Ruby/lib/ruby/site_ruby/1.8/rubygems/dependency_installer.rb:110:in
`
find_gems_with_sources'
        C:/Ruby/lib/ruby/site_ruby/1.8/rubygems/dependency_installer.rb:228:in
`
find_spec_by_name_and_version'
        C:/Ruby/lib/ruby/site_ruby/1.8/rubygems/dependency_installer.rb:259:in
`
install'
        C:/Ruby/lib/ruby/site_ruby/1.8/rubygems/commands/install_command.rb:121:
in `execute'
        C:/Ruby/lib/ruby/site_ruby/1.8/rubygems/commands/install_command.rb:115:
in `each'
        C:/Ruby/lib/ruby/site_ruby/1.8/rubygems/commands/install_command.rb:115:
in `execute'
        C:/Ruby/lib/ruby/site_ruby/1.8/rubygems/command.rb:278:in
`invoke'
        C:/Ruby/lib/ruby/site_ruby/1.8/rubygems/command_manager.rb:147:in
`proce
ss_args'
        C:/Ruby/lib/ruby/site_ruby/1.8/rubygems/command_manager.rb:117:in
`run'
        C:/Ruby/lib/ruby/site_ruby/1.8/rubygems/gem_runner.rb:65:in
`run'
        gem:21

tengo instalado el ruby: rubyinstaller-1.8.7-p357.exe
B2a871b025bd3b1f05c8f439c3b22c4f?d=identicon&s=25 Roberto Porcar (flamerz)
on 2012-01-26 16:52
Andrés, a ver si te sirve esto:
http://kidsruby.com/download

creo que viene todo preinstalado y no deberia fallar :)
374df51e1b94cff290cbc4116db6fa2c?d=identicon&s=25 Andrés CS (andrek)
on 2012-01-26 23:10
Bueno pesa 125MB :S, pero ya estoy en la descarga.

Algo que estoy notando es que no hay muchas personas utilizando este
lenguaje porque carece de soporte, las personas que saben de esto no
ayudan y los otros que no sabemos no nos ayudamos así como tu me ayudas
sin saber, por eso siempre doy indicaciones de mis pasos para que los
que no saben tengan una ídea de que hacer.

Muchas gracias espero que me sirva, cuando logre solucionar todo el
problema voy hacer una guia para tener instalado "Ruby + RubyGems +
Gosu" para que los nuevos no tengan esos problemas.
This topic is locked and can not be replied to.