Forum: Ruby on Rails weird capistrano error: caching old hostnames?

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Af25c598c54850cd55e07b1d060df9e1?d=identicon&s=25 Mike Chai (mlchai)
on 2011-12-27 02:22
(Received via mailing list)
I'm trying to move my app to a new server, and in the deploy.rb file I
updated the hostname to reflect the new server. However, when I run
any cap task it still contacts the old server no matter what, and I
can't figure out why this is. There is no reference to the old server
anywhere I can see.
C1e5a9e9344b6d31b9df7303e6dc378a?d=identicon&s=25 Craig White (Guest)
on 2011-12-27 03:20
(Received via mailing list)
On Mon, 2011-12-26 at 17:20 -0800, Mike C wrote:
> I'm trying to move my app to a new server, and in the deploy.rb file I
> updated the hostname to reflect the new server. However, when I run
> any cap task it still contacts the old server no matter what, and I
> can't figure out why this is. There is no reference to the old server
> anywhere I can see.
----
did you have a subversion or git server on your old server so there
remain references to that server?

did you run a recursive grep to search for references?

grep -r OLD_SERVER_NAME /path/to/RAILS_ROOT

Craig


--
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.
This topic is locked and can not be replied to.