Forum: wxRuby ERROR - libwx_gtk2u_media-2.8.so.0: cannot open shared object file

68a5555793b90f1375a6153a1afc2e62?d=identicon&s=25 Alejandro Riedel (Guest)
on 2011-10-30 03:22
(Received via mailing list)
Hi all,

I've been working with wxruby for a while with an Ubuntu 10.04
environment
mounted with VMWare over Windows.

Now, I'm trying to set it up in a new environment. It's Ubuntu 11.04,
using
RVM with both ruby 1.8.7 and 1.9.2 installed.

I installed wxruby and wxruby-ruby19 accordingly within corresponding
gemsets.

Now, when I try to launch an app that works in my old environment I'm
getting this error...

*>.../custom_require.rb:36:in `require': libwx_gtk2u_media-2.8.so.0:
cannot
open shared object file*

I tried installing the libraries related to wxGTK but they were already
installed and updated...

$sudo apt-get install libwxgtk2.8-dev
>libwxgtk2.8-dev is already the newest version.
$sudo apt-get install libwxgtk2.8-0
>libwxgtk2.8-0 is already the newest version.

How can I solve this?

I don't know if it helps but I installed both wxruby versions using 'gem
install' command...

Thanks in advance,
Alex

*ALEJANDRO RIEDEL**
*
*LinkedIn <http://ar.linkedin.com/pub/alejandro-riedel/13/5a7/356> -
github<https://github.com/alejandroriedel>
 - Blog <http://alejandroriedel.blogspot.com> -
twitter<http://twitter.com/alejandroriedel>
*
85991f138ede6236f35eb98da22b7b01?d=identicon&s=25 Marvin Gülker (quintus)
on 2011-10-30 10:33
(Received via mailing list)
Am 30.10.2011 03:06, schrieb Alejandro Riedel:
> Hi all,

Hi Alejandro,

> Now, I'm trying to set it up in a new environment. It's Ubuntu 11.04,
> using RVM with both ruby 1.8.7 and 1.9.2 installed.

> Now, when I try to launch an app that works in my old environment I'm
> getting this error...
>
> />.../custom_require.rb:36:in `require': libwx_gtk2u_media-2.8.so.0:
> cannot open shared object file/

It's a known problem with Ubuntu Maverick and Natty. They removed the
media library you're missing from wxWidgets -- and there's no way to
install it separately besides compiling wxWidgets yourself. See this
bug, which is fixed in Ubuntu Oneiric:

https://bugs.launchpad.net/ubuntu/+source/wxwidget...

And don't try to compile wxWidgets yourself, you'll run straight into a
bug in pixman which causes wxRuby to crash:

https://bugs.launchpad.net/ubuntu/+source/pixman/+bug/756237

> I tried installing the libraries related towxGTK but they were already
> installed and updated...
>
> $sudo apt-get install libwxgtk2.8-dev
>  >libwxgtk2.8-dev is already the newest version.
> $sudo apt-get install libwxgtk2.8-0
>  >libwxgtk2.8-0 is already the newest version.
>
> How can I solve this?

Upgrade to Oneiric and hope both bugs are gone. As the first one is
officially marked as "fixed" it should be; the second one *may* be,
because on my Arch Linux system, which uses pixman 0.22.2, that bug is
gone as well. But I don't know wheather that pixman made it into Ubuntu
Oneiric or if the version was published after the feature freeze.

Finally, there has been a lengthy discussion along wxRuby devs and users
here: http://www.ruby-forum.com/topic/1246679

Vale,
Marvin
This topic is locked and can not be replied to.