Forum: Ruby on Rails Unable to rake db:create

B6c5b79701222be7e399075e4e0e8d0a?d=identicon&s=25 Premanshu Mishra (premanshu)
on 2010-10-12 07:02
I m using ruby 1.8.7 on rails 2.3.5 with mysql 5.0 on windows.
C:\Ruby187\rails\accounts>rake db:create
(in C:/Ruby187/rails/accounts)
rake aborted!
syntax error on line 2, col 0: `encoding:utf8'

The following is the yml file i'm using

development:
adapter:mysql
encoding:utf8
reconnect:false
database:accounts_development
pool:5
username:
password:
host:localhost

There are no spaces in the file. Only one after password

In mysql i haven't set any password.(Though the default is root as whem
mysql console i open it asks for pwd and on entering root it opens).

Kindly suggest.

Premanshu
E1957b5e4fc7128511d167e79dd499da?d=identicon&s=25 rajeevsharma86 (Guest)
on 2010-10-12 07:11
(Received via mailing list)
What is  the error please run rake db:create --trace and post resluts
here

On Tue, Oct 12, 2010 at 10:32 AM, Premanshu Mishra
<lists@ruby-forum.com>wrote:

> encoding:utf8
> mysql console i open it asks for pwd and on entering root it opens).
> "Ruby on Rails: Talk" group.
> To post to this group, send email to rubyonrails-talk@googlegroups.com.
> To unsubscribe from this group, send email to
>
rubyonrails-talk+unsubscribe@googlegroups.com<rubyonrails-talk%2Bunsubscribe@googlegroups.com>
> .
> For more options, visit this group at
> http://groups.google.com/group/rubyonrails-talk?hl=en.
>
>


--
Thanks:
Rajeev sharma
B6c5b79701222be7e399075e4e0e8d0a?d=identicon&s=25 Premanshu Mishra (premanshu)
on 2010-10-12 07:17
@Rajeev,
Pls  find the results

C:\Ruby187\rails\accounts>rake db:create --trace
(in C:/Ruby187/rails/accounts)
** Invoke db:create (first_time)
** Invoke db:load_config (first_time)
** Invoke rails_env (first_time)
** Execute rails_env
** Execute db:load_config
rake aborted!
syntax error on line 2, col 0: `encoding:utf8'
C:/Ruby187/lib/ruby/1.8/yaml.rb:133:in `load'
C:/Ruby187/lib/ruby/1.8/yaml.rb:133:in `load'
C:/Ruby187/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:902:in
`databas
e_configuration'
C:/Ruby187/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/tasks/databases.rake:4
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:636:in `call'
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:636:in
`execute'
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:631:in `each'
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:631:in
`execute'
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:597:in
`invoke_with_cal
l_chain'
C:/Ruby187/lib/ruby/1.8/monitor.rb:242:in `synchronize'
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:590:in
`invoke_with_cal
l_chain'
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:607:in
`invoke_prerequi
sites'
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:604:in `each'
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:604:in
`invoke_prerequi
sites'
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:596:in
`invoke_with_cal
l_chain'
C:/Ruby187/lib/ruby/1.8/monitor.rb:242:in `synchronize'
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:590:in
`invoke_with_cal
l_chain'
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:583:in `invoke'
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2051:in
`invoke_task'
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2029:in
`top_level'
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2029:in `each'
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2029:in
`top_level'
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2068:in
`standard_excep
tion_handling'
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2023:in
`top_level'
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2001:in `run'
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2068:in
`standard_excep
tion_handling'
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:1998:in `run'
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/bin/rake:31
C:/Ruby187/bin/rake:19:in `load'
C:/Ruby187/bin/rake:19
E1957b5e4fc7128511d167e79dd499da?d=identicon&s=25 rajeevsharma86 (Guest)
on 2010-10-12 07:22
(Received via mailing list)
please see syntax error on line 2, col 0: `encoding:utf8' provide space
as
per http://guides.rubyonrails.org/getting_started.html

On Tue, Oct 12, 2010 at 10:47 AM, Premanshu Mishra
<lists@ruby-forum.com>wrote:

> rake aborted!
> C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:631:in `each'
> `invoke_prerequi
> `invoke_with_cal
> `standard_excep
> C:/Ruby187/bin/rake:19
> .
> For more options, visit this group at
> http://groups.google.com/group/rubyonrails-talk?hl=en.
>
>


--
Thanks:
Rajeev sharma
B6c5b79701222be7e399075e4e0e8d0a?d=identicon&s=25 Premanshu Mishra (premanshu)
on 2010-10-12 07:45
I have provided the spaces as well but no luck.

The error this time though is :

rake aborted!
syntax error on line 8, col 15: `Æ'

Premanshu
E1957b5e4fc7128511d167e79dd499da?d=identicon&s=25 rajeevsharma86 (Guest)
on 2010-10-12 07:52
(Received via mailing list)
paste output with trace

On Tue, Oct 12, 2010 at 11:15 AM, Premanshu Mishra
<lists@ruby-forum.com>wrote:

> Posted via http://www.ruby-forum.com/.
>
>


--
Thanks:
Rajeev sharma
B6c5b79701222be7e399075e4e0e8d0a?d=identicon&s=25 Premanshu Mishra (premanshu)
on 2010-10-12 08:06
The output is all same except:

rake aborted!
syntax error on line 8, col 15: `n'

The yml file at [application_name]/config/ is as follows:

development:
 adapter:mysql
 encoding:utf8
 reconnect:false
 database:accounts_development
 pool:5
 username: root
 password:
 host:localhost
E1957b5e4fc7128511d167e79dd499da?d=identicon&s=25 rajeevsharma86 (Guest)
on 2010-10-12 08:13
(Received via mailing list)
please provide a traced aoutput

On Tue, Oct 12, 2010 at 11:36 AM, Premanshu Mishra
<lists@ruby-forum.com>wrote:

>  reconnect:false
> You received this message because you are subscribed to the Google Groups
> "Ruby on Rails: Talk" group.
> To post to this group, send email to rubyonrails-talk@googlegroups.com.
> To unsubscribe from this group, send email to
>
rubyonrails-talk+unsubscribe@googlegroups.com<rubyonrails-talk%2Bunsubscribe@googlegroups.com>
> .
> For more options, visit this group at
> http://groups.google.com/group/rubyonrails-talk?hl=en.
>
>


--
Thanks:
Rajeev sharma
B6c5b79701222be7e399075e4e0e8d0a?d=identicon&s=25 Premanshu Mishra (premanshu)
on 2010-10-12 08:26
C:\Ruby187\rails\accounts>rake db:migrate --trace
(in C:/Ruby187/rails/accounts)
** Invoke db:migrate (first_time)
** Invoke environment (first_time)
** Execute environment
rake aborted!
syntax error on line 8, col 15: `¼+?'
C:/Ruby187/lib/ruby/1.8/yaml.rb:133:in `load'
C:/Ruby187/lib/ruby/1.8/yaml.rb:133:in `load'
C:/Ruby187/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:902:in
`databas
e_configuration'
C:/Ruby187/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:437:in
`initial
ize_database'
C:/Ruby187/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:141:in
`process
'
C:/Ruby187/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:113:in
`send'
C:/Ruby187/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:113:in
`run'
C:/Ruby187/rails/accounts/config/environment.rb:9
C:/Ruby187/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original
_require'
C:/Ruby187/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`require'
C:/Ruby187/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/active_support/depende
ncies.rb:156:in `require'
C:/Ruby187/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/active_support/depende
ncies.rb:521:in `new_constants_in'
C:/Ruby187/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/active_support/depende
ncies.rb:156:in `require'
C:/Ruby187/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/tasks/misc.rake:4
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:636:in `call'
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:636:in
`execute'
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:631:in `each'
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:631:in
`execute'
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:597:in
`invoke_with_cal
l_chain'
C:/Ruby187/lib/ruby/1.8/monitor.rb:242:in `synchronize'
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:590:in
`invoke_with_cal
l_chain'
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:607:in
`invoke_prerequi
sites'
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:604:in `each'
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:604:in
`invoke_prerequi
sites'
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:596:in
`invoke_with_cal
l_chain'
C:/Ruby187/lib/ruby/1.8/monitor.rb:242:in `synchronize'
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:590:in
`invoke_with_cal
l_chain'
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:583:in `invoke'
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2051:in
`invoke_task'
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2029:in
`top_level'
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2029:in `each'
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2029:in
`top_level'
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2068:in
`standard_excep
tion_handling'
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2023:in
`top_level'
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2001:in `run'
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2068:in
`standard_excep
tion_handling'
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:1998:in `run'
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/bin/rake:31
C:/Ruby187/bin/rake:19:in `load'
C:/Ruby187/bin/rake:19
E1957b5e4fc7128511d167e79dd499da?d=identicon&s=25 rajeevsharma86 (Guest)
on 2010-10-12 08:50
(Received via mailing list)
provide space in 8th line after
password:

On Tue, Oct 12, 2010 at 11:56 AM, Premanshu Mishra
<lists@ruby-forum.com>wrote:

> `databas
> `run'
> C:/Ruby187/lib/ruby/gems/1.8/gems/activesupport-2.3.5/lib/active_support/depende
> `execute'
> C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:604:in `each'
> C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:583:in `invoke'
> C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2023:in
> --
> http://groups.google.com/group/rubyonrails-talk?hl=en.
>
>


--
Thanks:
Rajeev sharma
B6c5b79701222be7e399075e4e0e8d0a?d=identicon&s=25 Premanshu Mishra (premanshu)
on 2010-10-12 09:47
I had provided a space as well.
The output is :

rake aborted!
syntax error on line 8, col 15: `n'
C:/Ruby187/lib/ruby/1.8/yaml.rb:133:in `load'
C:/Ruby187/lib/ruby/1.8/yaml.rb:133:in `load'
C:/Ruby187/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:902:in
`databas
e_configuration'
C:/Ruby187/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/tasks/databases.rake:4
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:636:in `call'
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:636:in
`execute'
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:631:in `each'
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:631:in
`execute'
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:597:in
`invoke_with_cal
l_chain'
C:/Ruby187/lib/ruby/1.8/monitor.rb:242:in `synchronize'
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:590:in
`invoke_with_cal
l_chain'
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:607:in
`invoke_prerequi
sites'
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:604:in `each'
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:604:in
`invoke_prerequi
sites'
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:596:in
`invoke_with_cal
l_chain'
C:/Ruby187/lib/ruby/1.8/monitor.rb:242:in `synchronize'
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:590:in
`invoke_with_cal
l_chain'
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:583:in `invoke'
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2051:in
`invoke_task'
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2029:in
`top_level'
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2029:in `each'
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2029:in
`top_level'
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2068:in
`standard_excep
tion_handling'
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2023:in
`top_level'
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2001:in `run'
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2068:in
`standard_excep
tion_handling'
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:1998:in `run'
C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/bin/rake:31
C:/Ruby187/bin/rake:19:in `load'
C:/Ruby187/bin/rake:19

Pls let me know if the genrated yml file has to be changed a lot. I have
truncated my file to

test:
 adapter:mysql
 encoding:utf8
 reconnect:false
 database:accounts_test
 pool:5
 username: root
 password:
 host:localhost
E1957b5e4fc7128511d167e79dd499da?d=identicon&s=25 rajeevsharma86 (Guest)
on 2010-10-12 10:01
(Received via mailing list)
no man its about space only you have to give a space after evry columns

On Tue, Oct 12, 2010 at 1:17 PM, Premanshu Mishra
<lists@ruby-forum.com>wrote:

> C:/Ruby187/lib/ruby/gems/1.8/gems/rails-2.3.5/lib/tasks/databases.rake:4
> C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:590:in
> `invoke_with_cal
> C:/Ruby187/lib/ruby/gems/1.8/gems/rake-0.8.7/lib/rake.rb:2029:in `each'
> tion_handling'
>  encoding:utf8
> --
> You received this message because you are subscribed to the Google Groups
> "Ruby on Rails: Talk" group.
> To post to this group, send email to rubyonrails-talk@googlegroups.com.
> To unsubscribe from this group, send email to
>
rubyonrails-talk+unsubscribe@googlegroups.com<rubyonrails-talk%2Bunsubscribe@googlegroups.com>
> .
> For more options, visit this group at
> http://groups.google.com/group/rubyonrails-talk?hl=en.
>
>


--
Thanks:
Rajeev sharma
E7cff3cfd41c495e1012227d7dc24202?d=identicon&s=25 Luis Lavena (luislavena)
on 2010-10-12 13:49
(Received via mailing list)
On Oct 12, 2:02am, Premanshu Mishra <li...@ruby-forum.com> wrote:
> encoding:utf8
> reconnect:false
> database:accounts_development
> pool:5
> username:
> password:
> host:localhost
>
> There are no spaces in the file. Only one after password
>

YAML is a very space sensitive format. You need to respect spaces in
nested keys and also between keys and their values.

If you respected the generated config/database.yml would notice it.

See this:

http://pastie.org/1215173

Notice the 2 leading spaces and the space between ":"

Also, you need an username.

Please, save the file in plain text, not UTF (the weird characters
you're getting in the output is due garbage added by your editor).
--
Luis Lavena
E13891805dea24b162089988a4c6af37?d=identicon&s=25 Raghavendra Joshi (Guest)
on 2010-10-12 14:49
(Received via mailing list)
hi,
Actually while installing mysql 5.0 it asks for password. Google for
how to set the password in mysql and in your database.yml file,
maintain single space between every field e.g. adapter: mysql,
encoding: utf8 and so on..... This might solve your problem.
E13891805dea24b162089988a4c6af37?d=identicon&s=25 Raghavendra Joshi (Guest)
on 2010-10-12 14:56
(Received via mailing list)
hi,
you better reinstall mysql. While installing it will ask for password.
and default user name is "root"
B6c5b79701222be7e399075e4e0e8d0a?d=identicon&s=25 Premanshu Mishra (premanshu)
on 2010-10-13 09:36
Hi all,

Thanks a ton for the suggestions..It has finally worked...The problem
was with the yaml file and spaces..
D7361c2f13a02e8f9c72e80b1dbef0ea?d=identicon&s=25 pvvsmk p. (pvvsmk_p)
on 2013-09-04 16:04
Thanks to you all.....  rajeevsharma and others

Finally it was worked... :D


rake db:migrate --trace and utf-8 was working for me to get out from the
error... i successfully installed ruby193 in my windows8 and connected
it with mysql5.6     Thanks to every body.... if any one need the
instructions how to install ruby193 i will send you the document with
instructions :D  mail me at pvvsmk.adm.srin@gmail.com
Please log in before posting. Registration is free and takes only a minute.
Existing account

NEW: Do you have a Google/GoogleMail, Yahoo or Facebook account? No registration required!
Log in with Google account | Log in with Yahoo account | Log in with Facebook account
No account? Register here.