Forum: wxRuby problems installing with ruby 1.9 os x

2d844f88c7eda26c4a42df32569fb1cf?d=identicon&s=25 Kevin Watt (Guest)
on 2011-07-10 17:32
(Received via mailing list)
Hi!

I get this when I use the main 'wxruby' package:

/Users/inspire/.rvm/rubies/ruby-1.9.2-p180/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
`require':
dlopen(/Users/inspire/.rvm/gems/ruby-1.9.2-p180@newap/gems/wxruby-1.9.3-universal-darwin/lib/wxruby2.bundle,
9): no suitable image found.  Did find: (LoadError)


Then when I try to install 'wxruby-ruby19', I get:
weft_qda-1.0.1 ➤ gem install wxruby-ruby19
ERROR:  Could not find a valid gem 'wxruby-ruby19' (>= 0), here is why:
          Found wxruby-ruby19 (2.0.0), but was for platforms
x86_64-linux ,x86-darwin-9 ,x86-linux ,x86-mingw32
ERROR:  Possible alternatives: earth-ruby19, errata-ruby19, rdf-ruby19,
rpam-ruby19, ruby2ruby


Thanks!,
Kevin Watt
2d352e436babbf3d80d4a6171220cd5b?d=identicon&s=25 Chloro Form (tony44)
on 2011-08-12 09:02
you can download the gem from here:

http://rubyforge.org/frs/?group_id=35

there's more posts on this forum regarding the topic and how to get
going with ruby, wxruby and OSX.

Good luck
T
This topic is locked and can not be replied to.