Forum: wxRuby wxruby gem loaded, but require 'wxruby' not found

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
56c8db2891b2d2714ff22be005859285?d=identicon&s=25 Alex DeCaria (deke)
on 2010-03-05 04:16
I have wxruby gem installed.  This is confirmed by gem list command.
But when I run the sample code below I get an error that states:

trout.rb:1:in `require': no such file to load  -- wxruby (Load Error)
from trout.rb:1:in `<main>'

What might be wrong?



require 'wxruby'

class TroutApp < App
  def on_init
    frame =, -1, 'Tiny wxRuby Application')
    panel =, -1, 'You are a trout!',
                            , 1), DEFAULT_SIZE,
2d352e436babbf3d80d4a6171220cd5b?d=identicon&s=25 Chloro Form (tony44)
on 2010-03-05 07:23
try require 'wx'.
56c8db2891b2d2714ff22be005859285?d=identicon&s=25 Alex DeCaria (deke)
on 2010-03-05 11:46
Tony Meier wrote:
> try require 'wx'.

That worked!  But now I get a window that pops up saying "The program
can't start because msvcrt-ruby18.dll is missing from your computer!"
I'm using Ruby 1.9, so why is it looking for a Ruby 1.8 file?

Does wxruby work with Ruby 1.9?  Did I install the wrong gem?

-- Alex
This topic is locked and can not be replied to.