Forum: Redcloth RedCloth on Windows

7bda03c8d540f11f65931e082ac50de0?d=identicon&s=25 W. Szabo Peter (Guest)
on 2010-02-18 23:56
(Received via mailing list)
How to Install RedCloth on Windows?

The usual way fails:

 >gem install RedCloth

Building native extensions.  This could take a while...

ERROR:  Error installing RedCloth:

        ERROR: Failed to build gem native extension.

C:/Ruby/bin/ruby.exe extconf.rb

creating Makefile


'make' is not recognized as an internal or external command,

operable program or batch file.

Gem files will remain installed in

 for inspection.

Results logged to


I tried with Cygwin, but I think I messed up the Cygwin install or
setup, since

$  gem install RedCloth


C:\Ruby\bin\ruby.exe:  No such file or directory --
/cygdrive/c/Ruby/bin/gem  <LoadError>

I issued gem install RedCloth on Linux and it worked. I copied the
files, but I can’t use them on windows. Since NetBeans IDE gives Missing
these required gems:   RedCloth

Other gems work. Only RedCloth does not.

Any idea what to do?

Thanks a lot,


D469019a435a5dbd5c792016fdf67a0b?d=identicon&s=25 Jon Forums (jonm)
on 2010-02-19 02:57
(Received via mailing list)
> Any idea what to do?

I don't know what Windows version of Ruby you're using, but I'm able to
successfully use RedCloth using the RubyInstaller from in combination with the MSys/MinGW DevKit
DevKit from

In a nutshell, this combination enables Windows users to compile many of
the native C-based extensions that either don't currently offer a
mingw32 binary gem or no binary gems period.  FYI, we maintain a list of
the status of many of the native C-based gems that work or don't work
with the above environment at

My environment...

C:\Users\Jon\Documents>ruby --version
ruby 1.9.1p378 (2010-01-10 revision 26273) [i386-mingw32]

C:\Users\Jon\Documents>gem --version

C:\Users\Jon\Documents>gem list RedCloth -d

*** LOCAL GEMS ***

RedCloth (4.2.2)
    Author: Jason Garber
    Installed at: C:/ruby191/lib/ruby/gems/1.9.1

    RedCloth-4.2.2 - Textile parser for Ruby.
7bda03c8d540f11f65931e082ac50de0?d=identicon&s=25 W. Szabo Peter (Guest)
on 2010-02-19 03:24
(Received via mailing list)
Thanks a lot, I tried with Cygwin, but this is a lot easier, and work.
Why I had to do the hard way?!
Thanks again,
Problem solved.
7bd03a0ee81ca778cd458b8e1bc5b618?d=identicon&s=25 Chris Niswander (Guest)
on 2010-02-19 22:48
(Received via mailing list)
You might say something about the specific version(s)
you were using: of Windows, Ruby, anything else?

I installed the RedCloth gem *with no problems* a few months ago
   - on a Windows 2000 system
   - with Ruby 1.8.6 (2008-08-11 patchlevel 287) [i386-mswin32]

Because I wanted to use webby, I installed the webby gem first:
   gem install webby
   gem install RedCloth

The version of RedCloth?
   The directory in the gems/1.8 dir is named
   The directories are dated 2009-09-19, files 2009-09-21

So, this is my non-bug report. :-)
This topic is locked and can not be replied to.