Hi guys, I installed rails 3 beta, and the gem i18n (active_support dependency). After this, when I migrated my app to rails 2.3.5, it was 2.3.2, it became to raise an error when I ran rcov reports. The error is: /usr/lib/ruby/gems/1.8/gems/i18n-0.3.3/lib/i18n/core_ext/string/ interpolate.rb:88:in `%': one hash required (ArgumentError) from /usr/lib/ruby/gems/1.8/gems/rcov-0.9.6/lib/rcov/formatters/ text_report.rb:21:in `print_info' from /usr/lib/ruby/gems/1.8/gems/rcov-0.9.6/lib/rcov/formatters/ text_report.rb:10:in `execute' from /usr/lib/ruby/gems/1.8/gems/rcov-0.9.6/lib/rcov/formatters/ base_formatter.rb:65:in `each' from /usr/lib/ruby/gems/1.8/gems/rcov-0.9.6/lib/rcov/formatters/ base_formatter.rb:65:in `each_file_pair_sorted' from /usr/lib/ruby/gems/1.8/gems/rcov-0.9.6/lib/rcov/formatters/ text_report.rb:8:in `execute' from /usr/lib/ruby/gems/1.8/gems/rcov-0.9.6/lib/rcov/ code_coverage_analyzer.rb:146:in `dump_coverage_info' from /usr/lib/ruby/gems/1.8/gems/rcov-0.9.6/lib/rcov/ code_coverage_analyzer.rb:146:in `each' from /usr/lib/ruby/gems/1.8/gems/rcov-0.9.6/lib/rcov/ code_coverage_analyzer.rb:146:in `dump_coverage_info' from /usr/lib/ruby/gems/1.8/gems/rcov-0.9.6/bin/rcov:428 from /usr/lib/ruby/1.8/test/unit.rb:278 I updated rcov to 0.9.7.1 but the error remains the same. Then I removed i18n gem and everything came back to normal again. We will be migrating to rails 3 soon, so how I can solve this? Felipe
on 2010-02-18 20:09
on 2010-02-23 00:04
I got the same problem http://github.com/stffn/declarative_authorization/... any suggestion of which is the correct thing to do ? Regards, rodrigob.
on 2010-02-25 14:58
This should be resolved in in http://github.com/svenfuchs/i18n/commit/bd74060068... which is contained in I18n 0.3.4 and available on Gemcutter. This was also reported on http://github.com/svenfuchs/i18n/issues/closed#issue/9 and http://i18n.lighthouseapp.com/projects/14947-ruby-... Thanks everybody!
on 2010-02-25 21:17
Funny, I just ran into this today and ticketed it in Rails: https://rails.lighthouseapp.com/projects/8994-ruby... Sven, maybe you could explain just how the i18n gem and the built-in Active Support core ext are meant to interact? As that ticket states, when I ran the Active Support tests, it used the method from my i18n gem.
on 2010-02-25 21:39
Hey Henrik, On Feb 25, 2010, at 9:16 PM, Henrik Nyh wrote: > Funny, I just ran into this today and ticketed it in Rails: > https://rails.lighthouseapp.com/projects/8994-ruby... Oops :) Yeah, I that problem should go away with upgrading the I18n gem? > Sven, maybe you could explain just how the i18n gem and the built-in > Active Support core ext are meant to interact? As that ticket states, > when I ran the Active Support tests, it used the method from my i18n > gem. basically Rails shipped the I18n gem as a vendored gem from 2.2.0 (which introduced I18n support in Rails) until 3.0.0 (which stops shipping any dependencies as vendored code, afaik). ActiveSupport is not the only library in Rails that vendored stuff but here's where these gems were located: http://github.com/rails/rails/tree/v2.3.0/activesu... At first users were forced to use the vendored gem no matter which gem version had been released and installed on the user's system in the meanwhile: http://github.com/rails/rails/blob/v2.3.0/activesu... Starting from 18.104.22.168 users could install the gem locally and ActiveSupport would prefer that one over the vendored/shipped version, but ONLY if the version is I18n >= 0.1.3 and <= 0.2.0 (that's what that '~> 0.1.3' expression says): http://github.com/rails/rails/blob/v22.214.171.124/active... In Rails 2.3.5 this was relaxed so that the user could install any I18n version >= 0.1.3 and ActiveSupport would pick it up: http://github.com/rails/rails/blob/v2.3.5/activesu... Starting from Rails 3 afaik Bundler will install and use whatever version you tell it through the Gemfile. I haven't really looked closely at that though.