Forum: wxRuby undefined reference to `wxGraphicsRenderer::CreateBitmap(wxB

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Cfabdb58eeaa0cd3431dd341954c97df?d=identicon&s=25 Carlo B. (waydotnet)
on 2010-01-20 10:46
Hi to all,
i've compiled wxWidgets with this options:

./configure --enable-optimise --enable-stl --enable-unicode
--disable-threads --enable-static  --with-opengl --disable-shared
--enable-monolithic --disable-debug --with-libjpeg=builtin
--with-libpng=builtin  --with-zlib=builtin --enable-graphics_ctx
--enable-mediactrl --enable-unicode --with-libtiff=builtin
--with-expat=builtin --enable-gui -enable-xrc --enable-mdi --enable-gif
--enable-pcx --enable-iff --enable-png --enable-xpm


and also compiled StyledTextCtrl .

My system is :
Windows xp sp3
ruby 1.9.1p243 (2009-07-16 revision 24175) [i386-mingw32]
gcc.exe 3.4.5
swig.exe 1.3.38
rake 0.8.7


when compiled wxruby (from svn), i've recived this error:


c:\msys\MinGW\bin\..\lib\gcc\mingw32\3.4.5\..\..\..\..\mingw32\bin\ld.exe:
warning: auto-importing has been activated without --enable-auto-import
spe
cified on the command line.
This should work unless it involves constant data structures referencing
symbols from auto-imported DLLs.
C:\msys\1.0\src\wxWidgets-2.8.10/lib/libwx_mswu-2.8.a(monolib_graphcmn.o):graphcmn.cpp:(.text+0x3374):
undefined reference to `wxGraphicsRenderer::CreateBitmap(wxBitmap
const&)'
collect2: ld returned 1 exit status
rake aborted!
Command failed with status (1): [g++ -shared -L.
obj/AboutDialogInfo.o o...]
Cfabdb58eeaa0cd3431dd341954c97df?d=identicon&s=25 Carlo B. (waydotnet)
on 2010-01-21 14:28
[SOLVED]

IF i compile wxWidgests  2.8.10 i've this error:
C:\msys\1.0\src\wxWidgets-2.8.10/lib/libwx_mswu-2.8.a(monolib_graphcmn.o):graphcmn.cpp:(.text+0x3374):
undefined reference to `wxGraphicsRenderer::CreateBitmap(wxBitmap
const&)'

If i compile with wxWidgets 2.8.9 WORK !!!

this is the gem :
svn version: 2107
http://www.waydotnet.com/ruby/wxruby-ruby19-2.0.1....

Only problem when install without --no-rdoc

:D

Carlo Bertini
This topic is locked and can not be replied to.