Forum: Rails France kimsufi et rails

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Dc1232dcb658369509bf4f405dde039c?d=identicon&s=25 Thomas T. (tombabibel)
on 2010-01-19 20:47
Bonjour,

Message 1 :
Alors ayé ! j'ai mon kimsufi. J'ai la version gentoo 2. J'ai installer
ruby, ruby gem ect.. et des que j'arrive avec passenger ca se complique.
Il y a manifestement des problèmes de compatibilité tout simplement
parce que apache sur Gentoo 2 est une version modifiée d'ovh.
Alors j'installe passenger en gem et la pour configurer tout ca, cela
devient ardu.
Quand j'ajoute dans le fischier .conf d'apache le chargement de module
Code :

LoadModule passenger_module
/usr/lib/ruby/gems/1.8/gems/passenger-2.0.2/ext/apache2/mod_passenger.so
PassengerRoot /usr/lib/ruby/gems/1.8/gems/passenger-2.0.2
PassengerRuby /usr/bin/ruby18

il y a une erreur de chargement de "mod_passenger.so". J'ai regarder et
ce fichier n'existe pas. C'est pour cela qu'il n'arrive pas a le
charger. Apres des heures et des heures de recherche sur moteurs de
recherche. Je n'ai trouver aucune solution concernant passenger et
apache OVH à moins d'installer un apache 2.x mais du coup ovhm ne
fonctionnera plus alors est-ce que quelqu'un aurait une idée ???? Merci

Message 2:
Bon! alors je suis perdu ! J'aimerai savoir si quelqu'un a déjà réussi a
installer un site rails qui marche sur un kimsufi avec gentoo 2. Si oui,
pouvez-vous m'aider. Qu'avez vous utiliser ? passenger, mongrel, thin
+Nginx ? pouvez vous me donner la methodes pour réussir à installer un
de ces serveurs ou mods. Parce que la je suis out. Merci :'(
Jean-Baptiste Barth (Guest)
on 2010-01-19 22:44
(Received via mailing list)
Bonjour,

Le 19 janvier 2010 20:47, Thomas Tomtom <list-incoming@andreas-s.net> a
écrit :

> LoadModule passenger_module
> /usr/lib/ruby/gems/1.8/gems/passenger-2.0.2/ext/apache2/mod_passenger.so
> PassengerRoot /usr/lib/ruby/gems/1.8/gems/passenger-2.0.2
> PassengerRuby /usr/bin/ruby18
>

L'installation de la gem ne suffit pas. As-tu bien suivi la seconde
étape,
i.e. le lancement d'un script, comme c'est indiqué sur le site de
Passenger
? Le script est assez bien foutu et détecte si tu as tout ce qu'il
faut...

Bon! alors je suis perdu ! J'aimerai savoir si quelqu'un a déjà réussi a
> installer un site rails qui marche sur un kimsufi avec gentoo 2. Si oui,
> pouvez-vous m'aider. Qu'avez vous utiliser ? passenger, mongrel, thin
> +Nginx ? pouvez vous me donner la methodes pour réussir à installer un
> de ces serveurs ou mods. Parce que la je suis out. Merci :'(
>

Ca dépend ce que tu recherches, ce que tu fais déjà tourner, tes
préférences, etc. Le fait que tu sois sur un kimsufi ou sous Gentoo n'a
pas
énormément d'importance. Tu peux rechercher sur cette liste dans les
archives, il me semble qu'il y a déjà eu des discussions à ce sujet.
Perso
j'ai 3 configs sur différentes machines, et les 3 me donnent
satisfaction :
Apache+Passenger, Apache+Thin et Nginx+Mongrel_cluster...

Bon courage && bonne soirée,
Dc1232dcb658369509bf4f405dde039c?d=identicon&s=25 Thomas T. (tombabibel)
on 2010-01-19 22:56
Welcome to the Phusion Passenger Apache 2 module installer, v2.2.9.

This installer will guide you through the entire installation process.
It
shouldn't take more than 3 minutes in total.

Here's what you can expect from the installation process:

 1. The Apache 2 module will be installed for you.
 2. You'll learn how to configure Apache.
 3. You'll learn how to deploy a Ruby on Rails application.

Don't worry if anything goes wrong. This installer will advise you on
how to
solve any problems.

Press Enter to continue, or Ctrl-C to abort.


--------------------------------------------

Checking for required software...

 * GNU C++ compiler... found at /usr/bin/g++
 * Ruby development headers... found
 * OpenSSL support for Ruby... found
 * RubyGems... found
 * Rake... found at /usr/bin/rake
 * rack... found
 * Apache 2... not found
 * Apache 2 development headers... not found
 * fastthread... found
 * Apache Portable Runtime (APR) development headers... not found
 * Apache Portable Runtime Utility (APU) development headers... not
found

Some required software is not installed.
But don't worry, this installer will tell you how to install them.

Press Enter to continue, or Ctrl-C to abort.

--------------------------------------------

Installation instructions for required software

 * To install Apache 2:
   Please run emerge -av apache as root.

 * To install Apache 2 development headers:
   Please run emerge -av apache as root.

 * To install Apache Portable Runtime (APR) development headers:
   Please run emerge -av apr as root.

 * To install Apache Portable Runtime Utility (APU) development headers:
   Please download it from http://httpd.apache.org/
   (APR Utility is an integrated part of Apache.)

If the aforementioned instructions didn't solve your problem, then
please take
a look at the Users Guide:

  /usr/lib64/ruby/gems/1.8/gems/passenger-2.2.9/doc/Users guide
Apache.html



Merci pour le conseil mais le problème subsiste :
Il me demande d'installer apache 2 ! Seulement si je l'installe Ovhm de
ovh ne fonctionnera plus et j'en ai besoin. Alors comment faire ?
Dc1232dcb658369509bf4f405dde039c?d=identicon&s=25 Thomas T. (tombabibel)
on 2010-01-19 23:55
J'ai essayer lightspeed et ruby-lsapi seulement quand je veux installer
ligtspeed sur le gentoo kimsufi j'obtiens :

# emerge lightspeed
Calculating dependencies |
!!! All ebuilds that could satisfy "lightspeed" have been masked.
!!! One of the following masked packages is required to complete your
request:
- sci-physics/lightspeed-1.2a-r1 (masked by: required EAPI 2, supported
EAPI 1)

For more information, see MASKED PACKAGES section in the emerge man page
or
refer to the Gentoo Handbook.

Donc en gros c'est mort.
Avez-vous une solution ?
Dc1232dcb658369509bf4f405dde039c?d=identicon&s=25 Thomas T. (tombabibel)
on 2010-01-20 00:35
bon alors j'ai tout de même réussi a installer lightspeed grâce à la gem
ruby-lsapi.

Seulement dans le site ci dessous on me dit comment configurer le
serveur lightspeed. Mais eux le configure avec l'interface de leur
system d'exploitation apparemment. Moi étant sur serveur en ligne je
n'ai accès qu'aux lignes de commande alors je ne sais pas où se trouve
dans mon kimsufi le fichier à configurer pour mon serveur lightspeed.
Quelqu'un pourrait m'aider ?

http://www.litespeedtech.com/support/wiki/doku.php...
JD (Guest)
on 2010-01-20 10:30
(Received via mailing list)
Le mardi 19 janvier 2010 à 20:47 +0100, Thomas Tomtom a écrit :
> Qu'avez vous utiliser ? passenger, mongrel, thin
> +Nginx ? pouvez vous me donner la methodes pour réussir à installer un
> de ces serveurs ou mods.

Nginx+passenger sur plusieurs serveurs debian/ubuntu et entièrement
satisfait. Pour l'installation et la config, j'ai suivi le tuto sur
http://www.modrails.com et lu la doc simplement.

JD
This topic is locked and can not be replied to.