Forum: Rails France Problème de chargement de gems

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Tranquiliste (Guest)
on 2010-01-11 12:05
(Received via mailing list)
Bonjour,

J'ai une petite question.
J'ai freezé mes gems dans mon appli (car ils ne sont pas installé chez
mon hébergeur).

Mon fichier de config contient:
   config.gem 'mislav-will_paginate', :version => '~> 2.3.3',
                                      :lib => "will_paginate",
                                      :source => 'http://
gems.github.com'
   config.gem 'uuid', :version => '~> 2.0.1'
   config.gem 'macaddr', :version => '~> 1.0.0'
   config.gem 'geokit', :version => '1.3.0'
   config.gem 'prawn'
   config.gem 'prawn-core', :lib => "prawn/core"
   config.gem 'prawn-format', :lib => "prawn/format"
   config.gem "prawn-layout", :lib => "prawn/layout"
   config.gem "prawn-security", :lib => "prawn/security"
   config.gem 'htmlentities'

Dans vendor/gem, j'ai bien tous ces gems, mais quand j'essaye
d'exécuter mon appli il me sort une erreur
no such file to load -- prawn

Comme si il ne trouvait pas le gem.
J'utilise la version 0.6.3 et j'ai vérifié que les dépendances étaient
bien à a bonne version
Avez vous une idée d'où pourrait provenir cette erreur?

Merci
Nicolas
2b92f9b76a4d168a8fc613aaa7f607a8?d=identicon&s=25 Cyril M. (shingara)
on 2010-01-11 12:50
(Received via mailing list)
Le 11/01/10 12:04, Tranquiliste a écrit :
> gems.github.com'
> Dans vendor/gem, j'ai bien tous ces gems, mais quand j'essaye
> d'exécuter mon appli il me sort une erreur
> no such file to load -- prawn
>
> Comme si il ne trouvait pas le gem.
> J'utilise la version 0.6.3 et j'ai vérifié que les dépendances étaient
> bien à a bonne version
> Avez vous une idée d'où pourrait provenir cette erreur?
>


Essaye /vendor/gems avec un S
Tranquiliste (Guest)
on 2010-01-11 14:31
(Received via mailing list)
faute de frappe, dans mon message, ils sont bien dans vendor/gems

Nicolas
2b92f9b76a4d168a8fc613aaa7f607a8?d=identicon&s=25 Cyril M. (shingara)
on 2010-01-11 14:33
(Received via mailing list)
Le 11/01/10 14:30, Tranquiliste a écrit :
> faute de frappe, dans mon message, ils sont bien dans vendor/gems
>


L'extension prawn nécessite d'être compilé je crois. L'est-elle ?
Tranquiliste (Guest)
on 2010-01-11 14:42
(Received via mailing list)
Compiler? Je ne me souviens pas d'avoir compilé quoique ce soit sur
mon mac. Je fais une recherche.

Nicolas
Tranquiliste (Guest)
on 2010-01-11 15:13
(Received via mailing list)
En plus ça a marché (et ça marche en local) la seule chose que j'ai
faite c'est upgrader prawn en 0.6.3 avec les dépendences.

Nicolas
Tranquiliste (Guest)
on 2010-01-11 16:48
(Received via mailing list)
Je ne sais pas exactement ce qui se passait, mais en fait je suis
repasé à prawn 0.4.1 et prawn-layout 0.1.0 et tout à l'air rentré dans
l'ordre. Peut être un pb d'incompatibilité

Nicolas
This topic is locked and can not be replied to.