Forum: Ruby on Rails RE: Switchtower, Windows & Setup

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Marc.Love (Guest)
on 2005-11-12 12:49
(Received via mailing list)
Sweet!  That fixed it all Tom, thanks! (including the fixes with
svn:executable and svn:eol-style)

I guess the switchtower.rake file needs to be modified then to account
for windows machines.  I'll submit a ticket.

>>> tom@craz8.com 11/09/05 06:02PM >>>
The first problem I had with SwitchTower on Windows was due to path
issues.
It seems that the Ruby 'run' command (used in Rake to get to
SwitchTower)
tries to run the 'switchtower' file, and the 'switchtower.cmd' file is
not
executed.  Rake runs and exits quickly, with no hint as to what
happened.

I fixed this by making changes in my switchtower.rake file to
explicitly ask
for the .cmd file and didn't investigate this any further.

Also check out my blog entry here for a few other Windows/Unix issues
I
worked through:
http://blog.craz8.com/articles/2005/11/03/windows-...

I also needed pageant.exe to be running (perhaps the Net::SSH update
fixes
this issue)
This topic is locked and can not be replied to.