Forum: Rails deployment Deployment failing due to invalid rubygems on server

7ed559ec7f9fc6a96ddc1690f06e7f80?d=identicon&s=25 Chris Olsen (chrisolsen)
on 2009-12-09 04:48
I am getting the following message when deploying with capistrano.
However, I do have the latest version  (1.3.5) of rubygems installed on
the server.

> Rails requires RubyGems >= 1.3.2 (you have 1.3.1). Please `gem update --system` and try 
again

I have found a few posts regarding this error, but none of the solutions
have worked for me.

Has anyone seen this before and have a solution?

Thanks for the help.
73c04e9ef9ca435c5b19a2e765ae6d20?d=identicon&s=25 Max Williams (max-williams)
on 2009-12-18 17:39
Chris Olsen wrote:
> I am getting the following message when deploying with capistrano.
> However, I do have the latest version  (1.3.5) of rubygems installed on
> the server.
>
>> Rails requires RubyGems >= 1.3.2 (you have 1.3.1). Please `gem update --system` and try 
again
>
> I have found a few posts regarding this error, but none of the solutions
> have worked for me.
>
> Has anyone seen this before and have a solution?
>
> Thanks for the help.

Maybe the problem is at your end rather than the server end?  Make sure
your local environment has the same gems as the server, and the same
version of rubygems.
7ed559ec7f9fc6a96ddc1690f06e7f80?d=identicon&s=25 Chris Olsen (chrisolsen)
on 2009-12-18 19:32
Sorry for the lack of an update.  The reason was that I had ruby 1.8 and
1.9 installed on the system each with own set of gems.  The ruby 1.8 had
the latest version of rubygems while 1.9 had an older version.
This topic is locked and can not be replied to.