Forum: Ruby How to examine dependencies of previous gems

94f9c083db03be82dca81e95e2ab414a?d=identicon&s=25 Louis Sherwin (sherwin)
on 2009-09-04 17:58
Hi,

I am trying to see if there are any differences in the dependencies for
a specific gem between different releases.

For example:

sherwin-mac{198}% gem -v
1.3.4

sherwin-mac{199}% gem dep -r mongrel -v 1.1.5
Gem mongrel-1.1.5
  gem_plugin (>= 0.2.3, runtime)
  daemons (>= 1.0.3, runtime)
  fastthread (>= 1.0.1, runtime)
  cgi_multipart_eof_fix (>= 2.4, runtime)

sherwin-mac{200}% gem dep -r mongrel -v 1.1.4
No gems found matching mongrel (= 1.1.4)

Am I missing something simple?

tks, louie
Ef3aa7f7e577ea8cd620462724ddf73b?d=identicon&s=25 Rob Biedenharn (Guest)
on 2009-09-04 18:33
(Received via mailing list)
On Sep 4, 2009, at 12:00 PM, Louis Sherwin wrote:

>
> Am I missing something simple?
>
> tks, louie
> --
> Posted via http://www.ruby-forum.com/.
>


Well, we certainly are!  How about: gem list mongrel
Do you have mongrel 1.1.4 installed?

-Rob

Rob Biedenharn    http://agileconsultingllc.com
Rob@AgileConsultingLLC.com
94f9c083db03be82dca81e95e2ab414a?d=identicon&s=25 Louis Sherwin (sherwin)
on 2009-09-04 18:46
Rob Biedenharn wrote:
> On Sep 4, 2009, at 12:00 PM, Louis Sherwin wrote:
>
>
> Well, we certainly are!  How about: gem list mongrel
> Do you have mongrel 1.1.4 installed?
>
> -Rob
>
> Rob Biedenharn    http://agileconsultingllc.com
> Rob@AgileConsultingLLC.com

Hi Rob,

I don't have 1.1.4 installed locally. In fact that is what I'm trying to
avoid. What I am hoping to do is look at the remote gems (-r)  without
having to install each release on my system first.

tks, louie
Ef3aa7f7e577ea8cd620462724ddf73b?d=identicon&s=25 Rob Biedenharn (Guest)
on 2009-09-04 19:12
(Received via mailing list)
On Sep 4, 2009, at 12:46 PM, Louis Sherwin wrote:

>> Rob@AgileConsultingLLC.com
> Posted via http://www.ruby-forum.com/.
>


Oh, that leads to an explanation, too. Does this help?

$ gem list -d mongrel

*** LOCAL GEMS ***

mongrel (1.1.5, 1.1.4, 1.1.3, 1.0.1)
     Author: Zed A. Shaw
     Rubyforge: http://rubyforge.org/projects/mongrel
     Homepage: http://mongrel.rubyforge.org
     Installed at (1.1.5): /Library/Ruby/Gems/1.8
                  (1.1.4): /Library/Ruby/Gems/1.8
                  (1.1.3): /Library/Ruby/Gems/1.8
                  (1.0.1): /System/Library/Frameworks/Ruby.framework/
Versions/1.8/usr/lib/ruby/gems/1.8

     A small fast HTTP library and server that runs Rails, Camping,
Nitro
     and Iowa apps.

$ gem dep mongrel -v=1.1.4
Gem mongrel-1.1.4
   gem_plugin (>= 0.2.3, runtime)
   daemons (>= 1.0.3, runtime)
   fastthread (>= 1.0.1, runtime)
   cgi_multipart_eof_fix (>= 2.4, runtime)


So there doesn't appear to be any difference in the dependencies
between 1.1.4 and 1.1.5.

-Rob

Rob Biedenharn    http://agileconsultingllc.com
Rob@AgileConsultingLLC.com
94f9c083db03be82dca81e95e2ab414a?d=identicon&s=25 Louis Sherwin (sherwin)
on 2009-09-04 19:46
Rob Biedenharn wrote:
>
> Oh, that leads to an explanation, too. Does this help?
>

Sorry I guess I was not clear that my question is about using gem
commands and not specifically about mongrel. I just used mongrel as an
example

I just noticed something the leads me to believe that this issue has to
do with the way the gem server is setup and not with the dependency
command. There is a new release or rails and the default query now shows
the last two releases. I can look a  the dependencies for each of the
releases listed but not any previous release.

gem query -r -n ^rails\$

*** REMOTE GEMS ***

rails (2.3.4, 2.3.3)

gem dep rails -r -v 2.3.3
Gem rails-2.3.3
  rake (>= 0.8.3, runtime)
  activesupport (= 2.3.3, runtime)
  activerecord (= 2.3.3, runtime)
  actionpack (= 2.3.3, runtime)
  actionmailer (= 2.3.3, runtime)
  activeresource (= 2.3.3, runtime)

sherwin-mac{226}% gem dep rails -r -v 2.2.2
No gems found matching rails (= 2.2.2)

tks, louie
Ef3aa7f7e577ea8cd620462724ddf73b?d=identicon&s=25 Rob Biedenharn (Guest)
on 2009-09-04 19:55
(Received via mailing list)
On Sep 4, 2009, at 1:46 PM, Louis Sherwin wrote:

> to
> rails (2.3.4, 2.3.3)
> sherwin-mac{226}% gem dep rails -r -v 2.2.2
> No gems found matching rails (= 2.2.2)
>
> tks, louie

$ gem query --remote --name-matches '^rails$' --all

*** REMOTE GEMS ***

rails (2.3.4, 2.3.3, 2.3.2, 2.2.2, 2.1.2, 2.1.1, 2.1.0, 2.0.5, 2.0.4,
2.0.2, 2.0.1, 2.0.0, 1.2.6, 1.2.5, 1.2.4, 1.2.3, 1.2.2, 1.2.1, 1.2.0,
1.1.6, 1.1.5, 1.1.4, 1.1.3, 1.1.2, 1.1.1, 1.1.0, 1.0.0, 0.14.4,
0.14.3, 0.14.2, 0.14.1, 0.13.1, 0.13.0, 0.12.1, 0.12.0, 0.11.1,
0.11.0, 0.10.1, 0.10.0, 0.9.5, 0.9.4.1, 0.9.4, 0.9.3, 0.9.2, 0.9.1,
0.9.0, 0.8.5, 0.8.0, 0.7.0, 0.6.5, 0.6.0)

You may be right.  The older versions certainly do exist (2.2.2 in
particular), but must not be searched/found the same way.

-Rob

Rob Biedenharn    http://agileconsultingllc.com
Rob@AgileConsultingLLC.com
Please log in before posting. Registration is free and takes only a minute.
Existing account

NEW: Do you have a Google/GoogleMail, Yahoo or Facebook account? No registration required!
Log in with Google account | Log in with Yahoo account | Log in with Facebook account
No account? Register here.