Forum: IronRuby require_relative

B1670888202a45d1521a85a2f2ddec4c?d=identicon&s=25 Jacques du Preez (Guest)
on 2011-06-15 17:05
(Received via mailing list)
Attachment: image001.jpg (4 KB)
Attachment: image002.jpg (3 KB)
Attachment: image003.jpg (3 KB)
Attachment: image004.jpg (2 KB)
Attachment: image005.jpg (2 KB)
_______________________________________________
Ironruby-core mailing list
Ironruby-core@rubyforge.org
http://rubyforge.org/mailman/listinfo/ironruby-core
959b1c9d700abfc065f5f40bf5a966a2?d=identicon&s=25 James Schementi (jschementi)
on 2011-06-15 18:13
(Received via mailing list)
On Jun 15, 2011, at 10:42 AM, Jacques du Preez wrote:
> Hi,
>
> Im getting the following error trying to use the require_relative method in
Ruby:
>
> person.rb:3: undefined method `require_relative' for main:Object (NoMethodError)
>
> Is require_relative not supposed to be standard in Ruby 1.9? I know I can use
require, but I thought require_relative is now standard in 1.9...

IronRuby's Ruby-1.9 support is not complete, and require_relative has
not been implemented yet in IronRuby.

~js
91eb330fb36d1e03c856574dfb77d2bc?d=identicon&s=25 Thibaut Barrère (thbar)
on 2011-06-15 18:17
(Received via mailing list)
Attachment: image003.jpg (3 KB)
Attachment: image002.jpg (3 KB)
Attachment: image004.jpg (2 KB)
Attachment: image001.jpg (4 KB)
Attachment: image005.jpg (2 KB)
_______________________________________________
Ironruby-core mailing list
Ironruby-core@rubyforge.org
http://rubyforge.org/mailman/listinfo/ironruby-core
This topic is locked and can not be replied to.