Forum: Ruby on Rails Ruby 1.8.3

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Ad7805c9fcc1f13efc6ed11251a6c4d2?d=identicon&s=25 alex (Guest)
on 2005-11-12 12:49
(Received via mailing list)
What's the current status for running Rails under 1.8.3?  Last I heard
it was a no-go, but I can't remember why.  As a related question, has
anyone tried the 1.8.4 preview?

The reason this has come up is because I've managed to mess up an Ubuntu
Hoary install:

$ dpkg --list | grep ruby
ii  libpgsql-ruby1 0.7.1-3  PostgreSQL extension library for ruby1.8
ii  libruby1.8     1.8.2-9~hoary1 Libraries necessary to run Ruby 1.8
ii  libzlib-ruby  0.6.0+ruby1.8. Extension library to use zlib from Ruby
ii  ruby1.8       1.8.2-9~hoary1 Interpreter of object-oriented
scripting lan
$
$ ruby1.8 -v
ruby 1.8.3 (2005-06-23) [i486-linux]
$

Which has me *mightily* confused.  I was messing around with the
multiverse and extras repositories last night (since removed from
sources.list), so something's probably crept in there, but I get those
same results after apt-get --purge remove ruby1.8 ruby; apt-get install
rails.

Anyone else seen this?  It's not critical, because I'm quite happy to
compile up 1.8.2 if I can't sort this out the 'proper' way, but it's an
interesting little blip nonetheless...
24d2f8804e6bb4b7ea6bd11e0a586470?d=identicon&s=25 jeremy (Guest)
on 2005-11-12 12:49
(Received via mailing list)
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On Nov 10, 2005, at 3:03 AM, Alex Young wrote:
> What's the current status for running Rails under 1.8.3?  Last I
> heard it was a no-go, but I can't remember why.  As a related
> question, has anyone tried the 1.8.4 preview?

On Rails 0.13.1 and Ruby 1.8.3 there was a Logger incompatibility
that resulted in empty logs.

The Rails 1.0 release candidates test fine with 1.8.2, 1.8.3, and
1.8.4p1.

jeremy
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (Darwin)

iD8DBQFDcyzgAQHALep9HFYRAuvgAKCJmWG9Br3EfNRASopaTSldAmhycgCgxjLh
VPGksRCP8uFQgS7J0eYhVFk=
=s9M3
-----END PGP SIGNATURE-----
E8d4e155929363bd22a7852494d18c25?d=identicon&s=25 ntoll (Guest)
on 2005-11-12 12:49
(Received via mailing list)
Alex,

Upgrading to Breezy will provide you with a great Ruby on Rails friendly
development environment. But remember to install all the ruby packages
with apt and then use gem to grab rails.

Have fun,

Nicholas
Ad7805c9fcc1f13efc6ed11251a6c4d2?d=identicon&s=25 alex (Guest)
on 2005-11-12 12:49
(Received via mailing list)
ntollervey wrote:
> Alex,
>
> Upgrading to Breezy will provide you with a great Ruby on Rails friendly
> development environment. But remember to install all the ruby packages
> with apt and then use gem to grab rails.
>
> Have fun,
Apparently, you're mistaken: upgrading to Breezy provided me with a
doorstop, an afternoon of fun, and a fresh install of Debian Sarge.
Close, though...
8d00a3b94ad158920ca8980269ca57ac?d=identicon&s=25 bitserf (Guest)
on 2005-11-12 12:49
(Received via mailing list)
On 11/11/05, Alex Young <alex@blackkettle.org> wrote:
> What's the current status for running Rails under 1.8.3?  Last I heard
> it was a no-go, but I can't remember why.  As a related question, has
> anyone tried the 1.8.4 preview?
Some folks are having problems with ActionWebService under 1.8.3+, I'm
investigating this. It appears to be a problem in our usage of the
versions of SOAP4R bundled with them.

Leon
Fb7969e2a8d52a98728e834668f91738?d=identicon&s=25 tobias.witek (Guest)
on 2005-11-12 12:49
(Received via mailing list)
On Thu, 2005-11-10 at 19:26 +0000, Alex Young wrote:
> Close, though...
For whatever it's worth, I'm running a Breezy installation with ruby
1.8.3 and a gem installation of rails (0.14.3) and it works without a
problem.
I'm not quite sure how the (obviously) same installation base can yield
to such differing results, though...

t
E8d4e155929363bd22a7852494d18c25?d=identicon&s=25 ntoll (Guest)
on 2005-11-12 12:49
(Received via mailing list)
Alex,

I'm sorry to hear upgrading to Breezy sent your system FUBAR... :-(

I'm afraid, like Tobias, that my experience with such an upgrade was
without hitch. I too am not sure why the same installation base could
yield such differing results.

Better luck with Sarge!

Nicholas
Ad7805c9fcc1f13efc6ed11251a6c4d2?d=identicon&s=25 alex (Guest)
on 2005-11-12 12:49
(Received via mailing list)
Nicholas H.Tollervey wrote:
> Alex,
>
> I'm sorry to hear upgrading to Breezy sent your system FUBAR... :-(
Oh, I'm sure none of it was anybody's fault but my own :-)

>
> I'm afraid, like Tobias, that my experience with such an upgrade was
> without hitch. I too am not sure why the same installation base could
> yield such differing results.
Well, I'm pretty sure there was something Fundamentally Wrong with the
dpkg cache, given my original problem, so relying on a broken system to
fix itself was pretty optimistic.

>
> Better luck with Sarge!
>
After a couple of hours tweaking around, trying to find out what was
wrong and steadily making matters worse - eventually ending up with a
new Ubuntu Breezy installer consistently hanging at the partitioning
stage (great for the nerves, given that there was a Windows partition
that *had* to be preserved) - I decided that discretion was the better
part of valour, and retreated to something I knew a little better...
Ad7805c9fcc1f13efc6ed11251a6c4d2?d=identicon&s=25 alex (Guest)
on 2005-11-12 13:31
(Received via mailing list)
Jeremy Kemper wrote:
> On Rails 0.13.1 and Ruby 1.8.3 there was a Logger incompatibility  that
> resulted in empty logs.
>
> The Rails 1.0 release candidates test fine with 1.8.2, 1.8.3, and  1.8.4p1.

Fab - one less thing to worry about :-)
Ad7805c9fcc1f13efc6ed11251a6c4d2?d=identicon&s=25 alex (Guest)
on 2005-11-12 14:00
(Received via mailing list)
Jeremy Kemper wrote:
> On Rails 0.13.1 and Ruby 1.8.3 there was a Logger incompatibility  that
> resulted in empty logs.
>
> The Rails 1.0 release candidates test fine with 1.8.2, 1.8.3, and  1.8.4p1.

Fab - one less thing to worry about :-)
This topic is locked and can not be replied to.