Forum: Ruby-Forum.com RForum ... "Your config/boot.rb is outdated"

B553fd00b095c9e82e7114ca05aec6f2?d=identicon&s=25 Mark Knoffer (knoffs)
on 2009-07-02 14:07
hello,
i am trying to install rforum for a couple of days, but no luck /: i am
trying to list, what i have done today and hope that somebody can help
me finding out what my errors are.




today, i first tried to (re)install ruby ...






yum install -y ruby

Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: updates.interworx.info
 * updates: mirrors.cmich.edu
 * addons: mirrors.cmich.edu
 * extras: updates.interworx.info
Excluding Packages in global exclude list
Finished
Setting up Install Process
Parsing package install arguments
Package ruby-1.8.6.111-1.i386 already installed and latest version
Nothing to do







yum install -y ruby-devel ruby-docs ruby-ri ruby-irb ruby-rdoc

Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: updates.interworx.info
 * updates: mirrors.cmich.edu
 * addons: mirrors.cmich.edu
 * extras: updates.interworx.info
Excluding Packages in global exclude list
Finished
Setting up Install Process
Parsing package install arguments
Package ruby-devel-1.8.6.111-1.i386 already installed and latest version
Package ruby-ri-1.8.6.111-1.i386 already installed and latest version
Package ruby-irb-1.8.6.111-1.i386 already installed and latest version
Package ruby-rdoc-1.8.6.111-1.i386 already installed and latest version
Resolving Dependencies
--> Running transaction check
---> Package ruby-docs.i386 0:1.8.6.111-1 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================================
 Package               Arch             Version
Repository             Size
=============================================================================================
Installing:
 ruby-docs             i386             1.8.6.111-1
rubyworks             1.5 M

Transaction Summary
=============================================================================================
Install      1 Package(s)
Update       0 Package(s)
Remove       0 Package(s)

Total download size: 1.5 M
Downloading Packages:
ruby-docs-1.8.6.111-1.i386.rpm                                        |
1.5 MB     00:00
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing     : ruby-docs
[1/1]

Installed: ruby-docs.i386 0:1.8.6.111-1
Complete!






gem install rails --include-dependencies

gem install rails --include-dependencies
INFO:  `gem install -y` is now default and will be removed
INFO:  use --ignore-dependencies to install only the gems you list
Successfully installed rails-2.3.2
1 gem installed



uploaded the rforum-dir to domain-dir, extracted, changed database.yml
to ...

# SQLite is enabled by default. Remember to change the dbfile path.
#production:
#  adapter: sqlite3
#  dbfile: /tmp/rforum_prod.db

# Uncomment this section for MySQL:
production:
  adapter: mysql
  host: localhost
  database: admin_ruby
  username: admin_ruby
  password: whatever

# Uncomment this section for PostgreSQL:
#production:
#  adapter: postgresql
#  host: localhost
#  database: rforum
#  username: rforum
#  password: pass

# The following settings are only used for testing and development.
development:
  adapter: mysql
  host: localhost
  database: admin_ruby
  username: admin_ruby
  password: whatever

test:
  adapter: mysql
  host: localhost
  database: admin_ruby
  username: admin_ruby
  password: whatever




cd /home/admin/domains/whatever.com/public_html/rforum
RAILS_ENV=production rake migrate

(in /home/admin/domains/whatever.com/public_html/rails)
Your config/boot.rb is outdated: Run "rake rails:update".
[root@server rails]# (in
/home/admin/domains/whatever.com/public_html/rails)
-bash: syntax error near unexpected token `in'
[root@server rails]# Your config/boot.rb is outdated: Run "rake
rails:update".
-bash: Your: command not found






hope, that somebody knows what i am doing wrong and can help me to solve
it!

regards,
mark
B553fd00b095c9e82e7114ca05aec6f2?d=identicon&s=25 Mark Knoffer (knoffs)
on 2009-07-02 15:37
forgot to include the installed-info ...

# rpm -qa | grep -i ruby

ruby-devel-1.8.6.111-1
rubygem-gem-plugin-0.2.3-1
ruby-ri-1.8.6.111-1
ruby-docs-1.8.6.111-1
ruby-rdoc-1.8.6.111-1
rubygem-rake-0.8.1-1
rubygem-cgi-multipart-eof-fix-2.5.0-1
rubygem-fastthread-1.0.1-1
rubyworks-1.2.0-1
ruby-libs-1.8.6.111-1
ruby-1.8.6.111-1
ruby-irb-1.8.6.111-1
rubygems-1.0.1-1
rubygem-daemons-1.0.9-1
rubygem-mongrel-1.1.3-1
B553fd00b095c9e82e7114ca05aec6f2?d=identicon&s=25 Mark Knoffer (knoffs)
on 2009-07-02 15:55
forgot to include ...

i am on Redhat CentOS 5.0
Please log in before posting. Registration is free and takes only a minute.
Existing account

NEW: Do you have a Google/GoogleMail, Yahoo or Facebook account? No registration required!
Log in with Google account | Log in with Yahoo account | Log in with Facebook account
No account? Register here.