Forum: Redcloth Problem with rake db:migrate

D3d46e37d290f5f5df70129d5fd1349d?d=identicon&s=25 Karl heinz Marbaise (kama)
on 2009-07-02 12:03
Hi,

after installation of RedCloth i have the following error message....(on
Windows as well as on Mac)...

Environment:
C:\wsruby\scms>ruby script/about
About your application's environment
Ruby version              1.8.6 (i386-mswin32)
RubyGems version          1.3.1
Rack version              1.0 bundled
Rails version             2.3.2
Active Record version     2.3.2
Action Pack version       2.3.2
Active Resource version   2.3.2
Action Mailer version     2.3.2
Active Support version    2.3.2
Application root          C:/wsruby/scms
Environment               development
Database adapter          mysql
Database schema version   0


C:\wsruby\scms>rake db:migrate --trace
(in C:/wsruby/scms)
rake aborted!
uninitialized constant Gem::Specification::PLATFORM_CROSS_TARGETS
C:/prog/ruby/lib/ruby/gems/1.8/gems/activesupport-2.3.2/lib/active_support/dependencies.rb:105:in
`const_missing'
C:/wsruby/scms/vendor/plugins/redcloth/lib/tasks/pureruby.rake:1
C:/prog/ruby/lib/ruby/gems/1.8/gems/activesupport-2.3.2/lib/active_support/dependencies.rb:145:in
`load_without_new_constant_marking
'
C:/prog/ruby/lib/ruby/gems/1.8/gems/activesupport-2.3.2/lib/active_support/dependencies.rb:145:in
`load'
C:/prog/ruby/lib/ruby/gems/1.8/gems/activesupport-2.3.2/lib/active_support/dependencies.rb:521:in
`new_constants_in'
C:/prog/ruby/lib/ruby/gems/1.8/gems/activesupport-2.3.2/lib/active_support/dependencies.rb:145:in
`load'
C:/prog/ruby/lib/ruby/gems/1.8/gems/rails-2.3.2/lib/tasks/rails.rb:7
C:/prog/ruby/lib/ruby/gems/1.8/gems/rails-2.3.2/lib/tasks/rails.rb:7:in
`each'
C:/prog/ruby/lib/ruby/gems/1.8/gems/rails-2.3.2/lib/tasks/rails.rb:7
C:/prog/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
C:/prog/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`require'
C:/wsruby/scms/rakefile:10
C:/prog/ruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:2349:in
`load'
C:/prog/ruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:2349:in
`raw_load_rakefile'
C:/prog/ruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:1985:in
`load_rakefile'
C:/prog/ruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:2036:in
`standard_exception_handling'
C:/prog/ruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:1984:in
`load_rakefile'
C:/prog/ruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:1969:in `run'
C:/prog/ruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:2036:in
`standard_exception_handling'
C:/prog/ruby/lib/ruby/gems/1.8/gems/rake-0.8.3/lib/rake.rb:1967:in `run'
C:/prog/ruby/lib/ruby/gems/1.8/gems/rake-0.8.3/bin/rake:31
C:/prog/ruby/bin/rake:16:in `load'
C:/prog/ruby/bin/rake:16

Has anybody an idea what happens here....

Many thanks in advance...

Kind regards
Karl Heinz Marbaise
This topic is locked and can not be replied to.