Forum: Radiant CMS Superclass Error in 0.80 Install

2219b363feb10ee316dbb7ad9741114f?d=identicon&s=25 Ben Morrow (benmorrow)
on 2009-06-19 05:42
I'm upgrading from 0.7.1. And following the unstructions on the blog, I
ran

gem install radiant
rake radiant:update

but then...

rake production db:migrate

gives an error:

[ps7899]$ rake production db:migrate --trace
(in /home/)
** Invoke production (first_time)
** Execute production
** Invoke environment (first_time)
** Execute environment
rake aborted!
super: no superclass method `require'
/home/.gems/gems/radiant-0.8.0/vendor/rails/activesupport/lib/active_support/dependencies.rb:158:in
`require'

Does anybody know the cause?

Cheers,

Ben
2219b363feb10ee316dbb7ad9741114f?d=identicon&s=25 Ben Morrow (benmorrow)
on 2009-06-19 05:58
Ben Morrow wrote:
> I'm upgrading from 0.7.1. And following the unstructions on the blog, I
> ran

Sorry for the typos; it seems that I rushed that last message a bit.

Should have been:

*instructions
*Radiant 0.8.0
2219b363feb10ee316dbb7ad9741114f?d=identicon&s=25 Ben Morrow (benmorrow)
on 2009-06-22 08:08
Ben Morrow wrote:
> rake production db:migrate
>
> gives an error:
>
> [ps7899]$ rake production db:migrate --trace
> (in /home/)
> ** Invoke production (first_time)
> ** Execute production
> ** Invoke environment (first_time)
> ** Execute environment
> rake aborted!
> super: no superclass method `require'

The problem was in my HAML plugin.

Here is the fix:
http://wallerdev.com/2008/07/30/no-superclass-method-require
This topic is locked and can not be replied to.