Forum: Ruby on Rails Mongrel not playing nicely with older rails/ruby

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
4c0a7395fe7206ec35bae335fea46c0c?d=identicon&s=25 Rusty Rustybucket (rustybucket)
on 2009-06-06 01:13
(Received via mailing list)
I'm trying to transfer an older Rails project to a new server, never
would have thought it would have taken me this long (first time with
Ruby On Rails).

Anyways the site uses Ruby 1.8.4, Rails 1.1.6, gems 0.8.10

I installed Mongrel and Mongrel_Cluster and it prompted me for a
version, I selected the newest....  Now when I try to start Mongrel I
get this error:

** Ruby version is not up-to-date; loading cgi_multipart_eof_fix
/usr/local/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/../lib/mongrel/
gems.rb:12:in `require': undefined method `gem' for
Mongrel::Gems:Module (NoMethodError)
  from /usr/local/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/../lib/
mongrel.rb:355
  from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
18:in `require'
  from /usr/local/lib/ruby/gems/1.8/gems/mongrel-1.1.5/bin/
mongrel_rails:11
  from /usr/local/bin/mongrel_rails:18


I know my Ruby version is not up to date... but I don't think I want
to update it for fear of the app not properly working.  Should I
install an older version of Mongrel...?  If so,.... which version?

Thanks in advance for any guidance or assistance you may be able to
provide.

rusty
A91bd6cef23eb3516245a092e196c4da?d=identicon&s=25 Maurício Linhares (mauricio)
on 2009-06-06 05:28
(Received via mailing list)
Looks like what you need is a newer version of Rubygems and not ruby
or mongrel. You can get the latest one here ->
http://rubyforge.org/frs/?group_id=126

-
Maurício Linhares
http://alinhavado.wordpress.com/ (pt-br) |
http://codeshooter.wordpress.com/ (en)
4c0a7395fe7206ec35bae335fea46c0c?d=identicon&s=25 Rusty Rustybucket (rustybucket)
on 2009-06-07 03:09
(Received via mailing list)
Ok, now I get this...? Any clue as to what I'm missing?

** Starting Mongrel listening at 0.0.0.0:3000
** Starting Rails with development environment ...
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in
`require__': no such file to load -- ruby-debug (MissingSourceFile)
  from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
21:in `require'
  from /home/vhosts/dealer.benningtonmarine.com/config/../vendor/rails/
activerecord/lib/../../activesupport/lib/active_support/
dependencies.rb:147:in `require'
  from /home/vhosts/dealer.benningtonmarine.com/config/environment.rb:
68
  from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
21:in `require'
  from /usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3/lib/mongrel/
rails.rb:144:in `rails'
  from /usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3/bin/
mongrel_rails:112:in `cloaker_'
  from /usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3/lib/
mongrel.rb:832:in `listener'
  from /usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3/bin/
mongrel_rails:96:in `cloaker_'
  from /usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3/lib/
mongrel.rb:750:in `initialize'
  from /usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3/bin/
mongrel_rails:83:in `run'
  from /usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3/lib/mongrel/
command.rb:199:in `run'
  from /usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3/bin/
mongrel_rails:235
  from /usr/local/bin/mongrel_rails:18
81b61875e41eaa58887543635d556fca?d=identicon&s=25 Frederick Cheung (Guest)
on 2009-06-07 09:10
(Received via mailing list)
On Jun 7, 2:09 am, rusty <r_c...@hotmail.com> wrote:
> Ok, now I get this...? Any clue as to what I'm missing?
>
that looks like your app is requiring ruby-debug but that the gem
isn't installed

Fred
This topic is locked and can not be replied to.