Forum: Ruby on Rails attachment_fu issue

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Bc676b4c4f934105ca524a4547f94f51?d=identicon&s=25 Milan Dobrota (milandobrota)
on 2009-06-04 01:07
When you use attachment_fu plugin you have to use one of the image
processing libraries. However, when more of them are installed I get the
error: no such file to load -- application.rb How can I force
attachment_fu to use one specific image library?
A39970d780c506b26e9a8b71eda13df2?d=identicon&s=25 Walter McGinnis (Guest)
on 2009-06-04 02:40
(Received via mailing list)
You'll need to give more information probably.
Have you configured you model to use attachment_fu? That is usually
where
you specify the processing.  Reply with that and you might more help.
Also
what specifically are the processors you have installed?  Are you sure
that
error isn't related to something else going on in your controllers?

Cheers,
Walter


On Thu, Jun 4, 2009 at 11:07 AM, Milan Dobrota <
1dc9af4e0f3e7800ba7fce0cea38fd3f?d=identicon&s=25 Allan Mac Gregor R. (Guest)
on 2009-06-04 09:37
(Received via mailing list)
I had similar problems using attachment_fu for one project that I'm
currently developing, You need to provide more info about the error and
your
app configuration, I will personally use paperclip is a great plugin, it
has
a smaller footprint and it has more options than attachment fu plus you
can
find some useful tutorials about how to use it.
Regards

On Wed, Jun 3, 2009 at 6:07 PM, Milan Dobrota <
rails-mailing-list@andreas-s.net> wrote:

>
> When you use attachment_fu plugin you have to use one of the image
> processing libraries. However, when more of them are installed I get the
> error: no such file to load -- application.rb How can I force
> attachment_fu to use one specific image library?
> --
> Posted via http://www.ruby-forum.com/.
>
> >
>


--
Allan MacGregor Rehlaender
http://www.vagabonderz.org
Bc676b4c4f934105ca524a4547f94f51?d=identicon&s=25 Milan Dobrota (milandobrota)
on 2009-06-04 19:01
OK, what I did was rename the application_controller.rb to
application.rb and it started working. But only on localhost. On the
server it won't create any model with attachments (even if I don't
specify the picture - works fine on localhost). I changed the mode to
777 to make sure that there are no permission issues and nothing
happened. I have all of the libraries installed on server (rmagick,
image_science and mini_magick). If I put gem.config in environment.rb it
says that I need to install the gem (both on localhost and server). I've
read somewhere that that is the issue with rails 2.2.2.
I have also tried specifying :with => :mini_magick in the has_attachment
options to force the plugin to use the specific library and it still
wouldn't create the model.
Maybe I should try out paperclip.

P.S. Everything is working on the localhost. I have the feeling that
this is a configuration issue. Is there any way for gem dependencies to
break or something similar?
Bc676b4c4f934105ca524a4547f94f51?d=identicon&s=25 Milan Dobrota (milandobrota)
on 2009-06-05 01:18
I switched to Paperclip and it is working now :)
Should have done that a long time ago :)

Milan Dobrota wrote:
> OK, what I did was rename the application_controller.rb to
> application.rb and it started working. But only on localhost. On the
> server it won't create any model with attachments (even if I don't
> specify the picture - works fine on localhost). I changed the mode to
> 777 to make sure that there are no permission issues and nothing
> happened. I have all of the libraries installed on server (rmagick,
> image_science and mini_magick). If I put gem.config in environment.rb it
> says that I need to install the gem (both on localhost and server). I've
> read somewhere that that is the issue with rails 2.2.2.
> I have also tried specifying :with => :mini_magick in the has_attachment
> options to force the plugin to use the specific library and it still
> wouldn't create the model.
> Maybe I should try out paperclip.
>
> P.S. Everything is working on the localhost. I have the feeling that
> this is a configuration issue. Is there any way for gem dependencies to
> break or something similar?
This topic is locked and can not be replied to.