Forum: Ruby Failing tests from Mechanize gem

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Acd90f2627e42cf3727fed4dfb347c1e?d=identicon&s=25 John Maclean (Guest)
on 2009-06-02 16:46
(Received via mailing list)
Chaps,

I'm using the Mechanize gem and it's all good. However there are some
tests that fail within /lib/ruby/gems/1.9.1/gems/mechanize-0.9.2/test/.

Nothing too major at the mo, just stuff about radio buttons. In the
meantime if I where to get around debugging and squashing the failing
tests, to whom should I send them to?


*** LOCAL GEMS ***

doctest (0.0.1)
hotmailer (1.0.1)
hpricot (0.8.1)
mechanize (0.9.2)
minitest (1.3.1)
nokogiri (1.3.0)
rake (0.8.4)
rdoc (2.2.2)
test-unit (2.0.2)

--
/dev/jayeola

John Maclean
MSc. (DIC)
+7739 171 531
Be30361bb0b0c495e3077db43ad84b56?d=identicon&s=25 Aaron Patterson (Guest)
on 2009-06-02 17:56
(Received via mailing list)
On Tue, Jun 02, 2009 at 11:45:33PM +0900, John Maclean wrote:
> Chaps,
>
> I'm using the Mechanize gem and it's all good. However there are some
> tests that fail within /lib/ruby/gems/1.9.1/gems/mechanize-0.9.2/test/.
>
> Nothing too major at the mo, just stuff about radio buttons. In the
> meantime if I where to get around debugging and squashing the failing
> tests, to whom should I send them to?

You should send them to me.  I am the maintainer.  The only problem is
that currently all tests pass for me.

Make sure you're using the latest checkout from github:

  http://github.com/tenderlove/mechanize/tree/master

Also, make sure that you are running libxml2 2.7.3.  I suspect you're
running in to encoding problems with an older version of libxml2.
This topic is locked and can not be replied to.