Hi, According to its release notes, Rails 2.3.2 should run fine on Ruby 1.9.1. Since I've read about substantial performance gains from 1.9, I decided to upgrade. I built and installed Ruby 1.9.1-p129 on my server (Ubuntu 9.04, amd64 CPU) without any problems. Similarly, I was able to install Rails 2.3.2 via "gem" without any problems. Unfortunately, Rails itself fails to function. Running the "rails" script fails with the following error: <internal:gem_prelude>:234:in `push_gem_version_on_load_path': Could not find RubyGem activesupport (>= 0) (Gem::LoadError) And trying to require one of the component gems also fails, as follows: irb(main):001:0> require "activerecord" LoadError: no such file to load -- i18n/backend/simple from /opt/ruby-1.9.1-p129/lib/ruby/gems/1.9.1/gems/ activerecord-2.3.2/lib/active_record/i18n_interpolation_deprecation.rb: 5:in `require' Installing the "i18n" gem merely causes further problems, as follows: irb(main):001:0> require 'activerecord' NoMethodError: undefined method `alias_method_chain' for I18n::Backend::Simple:Class from /opt/ruby-1.9.1-p129/lib/ruby/gems/1.9.1/gems/ activerecord-2.3.2/lib/active_record/i18n_interpolation_deprecation.rb: 23:in `<class:Simple>' What follows is a list of the installed gems on my system: [zhaytee@orzhova] ~$ gem list *** LOCAL GEMS *** actionmailer (2.3.2) actionpack (2.3.2) activerecord (2.3.2) activeresource (2.3.2) activesupport (2.3.2) fastthread (1.0.7) i18n (0.1.0) passenger (2.2.2) pg (0.8.0) rails (2.3.2) rake (0.8.4) Is Rails 2.3.2 simply not compatible with 1.9.1, despite what the release notes say? Any help would be greatly appreciated. ZhayTee
on 2009-06-01 09:13
on 2009-07-03 13:46
ZhayTee wrote: > Unfortunately, Rails itself fails to function. Running the "rails" > script fails with the following error: > > <internal:gem_prelude>:234:in `push_gem_version_on_load_path': Could > not find RubyGem activesupport (>= 0) (Gem::LoadError) I installed Rails 2.3.2 and Ruby 1.9.1 (from source) with no problem on Ubuntu Hardy. I guess I was too cocky, because I get the error you describe after building ruby 1.9.1p129 from source and installing Rails 2.3.2 on my shiny new iMac running Leopard. Some gems are fine, e.g., irb(main):002:0> require 'haml' => true but some of the Rails gems, or things that depend on them, conk out in the way you describe. I checked my GEM_PATH, and everything is where Ruby should be looking. Would love to hear suggestions. > Is Rails 2.3.2 simply not compatible with 1.9.1, despite what the > release notes say? Any help would be greatly appreciated. They are running great on my Ubuntu VPS and netbook. Gems are another story, especially some of the database adapters. You'll to need to poke around for forks people have hacked together to get those working. Steve
on 2009-07-03 15:25
Steve, try freezing your rails gems before starting the server and let me know what happens.
on 2009-07-15 17:26
Hi ZhayTee, It sounds like ruby 1.9.1 isn't being used to run your app. Make sure all symlinks to the ruby interpret point to 1.9. Also, you will need to reinstall gem with ruby 1.9.1 and then re-download and install the rails gems with the new gem install for 1.9. Worked for us. Cheers, George