Forum: Ruby on Rails turn off model pre-loading in production environment?

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
8e101fbd63f7cdb2628119d908a8d1bc?d=identicon&s=25 Simon Simon (kentor)
on 2009-05-28 15:25
(Received via mailing list)
Hello,

How can i turn off model pre-loading in production environment so that
the app loads the code the exact same way as in the development
environment? Thanks!
8e101fbd63f7cdb2628119d908a8d1bc?d=identicon&s=25 Simon Simon (kentor)
on 2009-05-28 15:42
(Received via mailing list)
Or how can i preload a controller at startup? Or make sure the
controller loads before the models...
4c438a80fc30661ad619ea177cf9cbd0?d=identicon&s=25 Freddy Andersen (Guest)
on 2009-05-28 16:05
(Received via mailing list)
Preload the controller? Could you please give an example
8e101fbd63f7cdb2628119d908a8d1bc?d=identicon&s=25 Simon Simon (kentor)
on 2009-05-28 16:26
(Received via mailing list)
In the dev env, when i go to the localhost from the browser (i use
testing.site.com, i changed the hosts settings), first the weborb code
is loaded and then the code in the models is loaded. But in the
production env it is the other way around, when i go to
testing.theprodsite.com, first the model files are pre-loaded and then
the controllers are loaded but i need to use the request function
available only in the controller and i need the function before the
models are loaded... lemme know if its still unclear. Thanks!
8e101fbd63f7cdb2628119d908a8d1bc?d=identicon&s=25 Simon Simon (kentor)
on 2009-05-28 20:52
(Received via mailing list)
Ok i was able to run the production env as development by changing
stuff in config/environments/testing.rb so its ok now
This topic is locked and can not be replied to.