Forum: Ruby Ruby 1.8 vs. Ruby 1.9

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
8256b90f02902341ef2611eb8eea2a31?d=identicon&s=25 Calvin (Guest)
on 2009-05-20 17:41
(Received via mailing list)
Hi,

Does anyone here think it's a good idea for a beginner to learn Ruby
1.8 and then learn Ruby 1.9? If it's better to just learn 1.9 and not
worry about what 1.8 was like, I would appreciate any and all
responses to this post.

Thanks for your time,

Calvin Stephens
Cd0dbf751457cf6fed1f69070d37006a?d=identicon&s=25 Charles Johnson (Guest)
on 2009-05-20 17:43
(Received via mailing list)
On May 20, 2009, at 10:40 AM, Calvin wrote:

>
IMHO, if you are just starting, then start with 1.9. That is the
direction of ruby.

Cheers--

Charles
---
Charles Johnson
Advanced Computing Center for Research and Education
Vanderbilt University
E9ed4664dfd7ea664ccc5813de4d1fd7?d=identicon&s=25 Hooopo (Guest)
on 2009-05-20 17:45
(Received via mailing list)
I think ,as a beginnner, to learn Ruby 1.8 is a good way,there are so
many lib .
and also, if he has learned 1.8 ,then to learn Ruby 1.9 will be easy
for him.

ps: sorry for my poor English.
282d4190e23301bbaa8a2343370a6c20?d=identicon&s=25 Joshua Collins (Guest)
on 2009-05-20 17:52
(Received via mailing list)
I was wondering the exact same thing!

Before I knew 1.9 was coming out I got a 1.8 book, and I have gone
through
it. However, I am wondering if I should get a 1.9 book now and learn it.

I have not started any major projects using Ruby just yet, and am
curious if
I should practice with 1.8 some before I learn 1.9 or just jump into 1.9
and
start using it for projects?

My only concern is the lack of Gem support 1.9 might have right now. Is
it
something a new comer should worry with? Or, should I just forget the
lack
of Gem support and know that Gem's will eventually update to 1.9 and new
Gems will be made for 1.9.

Anyhow, I know that I will want to learn 1.9 at some point. I just do
not
want to jump in and be a bad position to progress in my learning because
of
1.9 set backs because it is so new.
9210a60b1492363560375d9cd6c842de?d=identicon&s=25 Michael J. I. Jackson (Guest)
on 2009-05-20 19:14
(Received via mailing list)
If you're looking for a good book that covers both 1.8 and 1.9, I
highly recommend O'Reilly's "The Ruby Programming Language". It's the
most comprehensive and concise reference that I've found, and it
bridges the gap between 1.8 and 1.9 nicely, explaining the differences
between the two as you go.

Michael
282d4190e23301bbaa8a2343370a6c20?d=identicon&s=25 Joshua Collins (Guest)
on 2009-05-20 19:24
(Received via mailing list)
What about 'Programming Ruby 1.9: The Pragmatic Programmers' Guide' ?

I know they have a 1.8 version of the book as well, but does the 1.9
version
of the book go over 1.8 and 1.9 both?

I also saw a book promoted here on the list called, 'The Well-Grounded
Rubyist'. It mainly covers 1.9 as well.

Have any of you read these two as well?

I will take a look at that O'Reilly's book ... I have not seen that one
yet.

On Wed, May 20, 2009 at 1:13 PM, Michael J. I. Jackson
<mjijackson@gmail.com
F7b25cca5d6bae54d19cd12508e35d8a?d=identicon&s=25 Boby Selamet Hartono (Guest)
on 2009-05-21 00:45
(Received via mailing list)
2009/5/21 Joshua Collins <kidguko@gmail.com>

>
> > bridges the gap between 1.8 and 1.9 nicely, explaining the differences
> > > it. However, I am wondering if I should get a 1.9 book now and learn
> > > My only concern is the lack of Gem support 1.9 might have right now. Is
> because
> > >> ps: sorry for my poor English.
> > >>
> > >>
> > >
> >
> >
>
I don't want to buy any books but I want to learn Ruby 1.9 as well.
D15a45a973443d4562051eb675b60474?d=identicon&s=25 Tom Cloyd (Guest)
on 2009-05-21 00:46
(Received via mailing list)
Joshua Collins wrote:
> I will take a look at that O'Reilly's book ... I have not seen that one yet.
>> bridges the gap between 1.8 and 1.9 nicely, explaining the differences
>> through
>>
>>> of Gem support and know that Gem's will eventually update to 1.9 and new
>>>
>>
>
>
Another perspective on this: I'm developing a major personal project
(into my 4th month on it), and have been unable to use 1.9 due to key
gems still not working in 1.9. However, due to moderate level of Ruby
knowledge, I must rather often consult a reference. The one I have is
Thomas' 3rd edition of "Programming Ruby". It focuses on 1.9, but seems
to distinctly point out where 1.9 is different from 1.8.x.

What I want to emphasize is two things:

1. depending upon the gems you need, 1.9 may or may not be usable by
you. For me, it's not yet.
2. my principal reference, nevertheless, is a book devoted to 1.9. I
have yet to get in trouble using this book. Most of the time I don't
worry at all about version differences, and my code just works (well,
usually...er...eventually).

So, get a good, up-to-date reference book, and there are several I'd
personally be happy with, and just start coding. As has been said before
on this list, many times, the differences between 1.8 and 1.9 are
meaningful but not earthshaking, at least not to me.

t.

--

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Tom Cloyd, MS MA, LMHC - Private practice Psychotherapist
Bellingham, Washington, U.S.A: (360) 920-1226
<< tc@tomcloyd.com >> (email)
<< TomCloyd.com >> (website)
<< sleightmind.wordpress.com >> (mental health weblog)
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
282d4190e23301bbaa8a2343370a6c20?d=identicon&s=25 Joshua Collins (Guest)
on 2009-05-21 00:58
(Received via mailing list)
Thanks Tom, that makes a lot of sense! :-)
753dcb78b3a3651127665da4bed3c782?d=identicon&s=25 Brian Candler (candlerb)
on 2009-05-21 21:52
Just remember that there are really three distinct Ruby versions now:
1.8.6, 1.8.7 (which has a number of 1.9 features, but not all), and
1.9.x
D15a45a973443d4562051eb675b60474?d=identicon&s=25 Tom Cloyd (Guest)
on 2009-05-22 03:34
(Received via mailing list)
Brian Candler wrote:
> Just remember that there are really three distinct Ruby versions now:
> 1.8.6, 1.8.7 (which has a number of 1.9 features, but not all), and
> 1.9.x
>
Absolutely, and that's probably why my simultaneous use of 1.8.7 AND the
1.9 version of the Pickax goes so smoothly. Makes sense, huh...

t.

--

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Tom Cloyd, MS MA, LMHC - Private practice Psychotherapist
Bellingham, Washington, U.S.A: (360) 920-1226
<< tc@tomcloyd.com >> (email)
<< TomCloyd.com >> (website)
<< sleightmind.wordpress.com >> (mental health weblog)
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
A7690aa3cc37bb04399041f0049bc21a?d=identicon&s=25 Just Another Victim of the Ambient Morality (Guest)
on 2009-05-27 21:05
(Received via mailing list)
"Tom Cloyd" <tomcloyd@comcast.net> wrote in message
news:4A14880B.3000204@comcast.net...
>
> 1. depending upon the gems you need, 1.9 may or may not be usable by
> you. For me, it's not yet.

    How can you tell which libraries are supported or not?  Is there a
simple repository of which gems have been converted?
    I'm still using Ruby 1.8 'cause I've been programming in it for a
number
of personal projects and, of course, those projects use a great number
of
libraries.  I'm just itching to upgrade to Ruby 1.9 except that I still
need
those libraries.  The instant that happens, I'm going for it!  Is there
a
simple way to determine this besides looking up the documentation of
each
library hoping that the maintainer mentions it?
    Thank you...
6371a1d563ecab62a4c2210aeccb6684?d=identicon&s=25 Andrew Barringer (Guest)
on 2009-05-27 21:45
(Received via mailing list)
Q: "How can you tell which libraries are supported or not?  Is there a
simple repository of which gems have been converted?"


A: This may be helpful http://isitruby19.com/
D15a45a973443d4562051eb675b60474?d=identicon&s=25 Tom Cloyd (Guest)
on 2009-05-28 09:28
(Received via mailing list)
Andrew Barringer wrote:
> Q: "How can you tell which libraries are supported or not?  Is there a
> simple repository of which gems have been converted?"
>
>
> A: This may be helpful http://isitruby19.com/
>
>
>
>
>
And that's also about all there is, sadly.

Clearly, some gems work in 1.9 unless you use certain parts of their
functionality, and then they fail.

There be water dragons in that murk!

t.

--

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Tom Cloyd, MS MA, LMHC - Private practice Psychotherapist
Bellingham, Washington, U.S.A: (360) 920-1226
<< tc@tomcloyd.com >> (email)
<< TomCloyd.com >> (website)
<< sleightmind.wordpress.com >> (mental health weblog)
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Ee2809522b2e56d0d6b656486bc5e0db?d=identicon&s=25 Markus Fischer (Guest)
on 2009-05-28 10:31
(Received via mailing list)
Hi,

Calvin wrote:
> Does anyone here think it's a good idea for a beginner to learn Ruby
> 1.8 and then learn Ruby 1.9? If it's better to just learn 1.9 and not
> worry about what 1.8 was like, I would appreciate any and all
> responses to this post.

Here is my personal experience: I started to code my first line of ruby
nearly one week ago, I just used what was available on my Debian Lenny,
at that's 1.8.7 .

I'm parsing text-based script files which are a few MB and I have to
by-character inspect them, I'm not using regex (yet; it's a straight
C-port for now). Since I've heard about 1.9 and saw that 1.9.1 is touted
as stable on ruby-lang I compiled the latest version and wanted to give
it a try, maybe there's some speed up (current parsing on large file
takes > 15 seconds).

Unfortunately I was not able to test my application: I'm using
CommandLine [1] and using 1.9.1 it just silently exits.

That is: no exception, no warning, nothing. I discovered the -W switch
and was shown a message:

commandline/optionparser/optionparser.rb:341: warning: shadowing outer
local variable - e

but changing the variable name didn't fix it.

I tried to get into it with the debugger, but I could not find anything
as I'm not that into ruby yet.

For me, I'm not considered 1.9.1 for now. It's too hard to work with
libraries I still don't know well when I just try to learn the language
and try to get my small project going on.

If I would not depend on other libs, I would surely jump on the wagon,
but that's not possible for me (and especially as a *beginner* you are
just not capable of writing everything yourself, lacking the skills).

- Markus

[1] http://rubyforge.org/docman/view.php/632/233/poste...
31e038e4e9330f6c75ccfd1fca8010ee?d=identicon&s=25 Gregory Brown (Guest)
on 2009-05-28 16:34
(Received via mailing list)
On Thu, May 28, 2009 at 4:30 AM, Markus Fischer <markus@fischer.name>
wrote:

> Unfortunately I was not able to test my application: I'm using CommandLine
> [1] and using 1.9.1 it just silently exits.
>
> That is: no exception, no warning, nothing. I discovered the -W switch and
> was shown a message:
>
> commandline/optionparser/optionparser.rb:341: warning: shadowing outer local
> variable - e

Did you report this error to Jim and also file it on isitruby19.com ?

If not, please do.  Libraries won't get better unless users let us
know the problems they're having.
If you did, thanks!   Try back every few months and I think you'll see
the library scene improve.
As your Ruby skills increase, definitely consider patching your
favorite libraries, it's often easier than you'd expect.

-greg
Ee2809522b2e56d0d6b656486bc5e0db?d=identicon&s=25 Markus Fischer (Guest)
on 2009-05-28 16:48
(Received via mailing list)
Hi,

Gregory Brown wrote:
> Did you report this error to Jim and also file it on isitruby19.com ?

Yes, I did after I read about in the other thread, it's here:
http://isitruby19.com/commandline

I couldn't find anything current about Jim Freeze, all references I
found date back four years ago or so ...

It's alsooften that I'm unsure if I'm the problem due lack of skills and
don't want to hassle the "pro"s :)

but thanks for encouraging,
- Markus
This topic is locked and can not be replied to.