Forum: NGINX help with memcache?

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
27d07ab5a9b0923e138819caa42e09c1?d=identicon&s=25 Ilan Berkner (Guest)
on 2009-05-19 19:49
(Received via mailing list)
Hi All,

Setting up a local environment for testing purposes.  CenOS 5.3, PHP
5.2.9
with php-fpm, etc.

Installed and setup memcache.

Switched php.ini settings to use memcache as session handler.

phpinfo and php test script to use memcache server show settings are OK.

Session management... not working.  I'm really stuck... I can't figure
out
where to look... Basically, what's happening is that php is not
communicating with the memcached daemon for session management... but I
don't know why... can anyone point me in the right direction?  I've gone
up
and down newsgroups and support sites... and have tried installing /
reinstalling...

Thanks
165f6aedf24cc7df8537546fe874de3d?d=identicon&s=25 E. Johnson (Guest)
on 2009-05-20 01:02
(Received via mailing list)
Have you tried invoking the daemon w/ 'memcached -vv'? This runs the
daemon
while showing requests as they come in.
27d07ab5a9b0923e138819caa42e09c1?d=identicon&s=25 Ilan Berkner (Guest)
on 2009-05-20 02:32
(Received via mailing list)
Thank you for the suggestion, I did just that.

There were 2 things:

1) a version mismatch between the memcache server and what php was
running
and
2) the software I was running wasn't configured properly, although I
think
that (1) was the primary issue.

Sorry for posting this on this group... as it wasn't nginx specific...
our
site is running on Nginx of course :-).
This topic is locked and can not be replied to.