Forum: NGINX Best PHP.ini

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
2974d09ac2541e892966b762aad84943?d=identicon&s=25 Wicked (Guest)
on 2009-05-19 17:00
(Received via mailing list)
Hello,

i'm searchin for a good php.ini..

my Server Specs..

CPU: AMD Athlon(tm) 64 X2 Dual Core Processor 4200+
Memory: 2GB Ram
HDD: 2 x 300gb
Linux Distr.: Debian Lenny
Nginx Version: Nginx 0.6.36 with spawn-cgi(lighttpd)
PHP version: PHP 5.2.6-1+lenny3 with Suhosin-Patch 0.9.6.2 (cli) (built:
Apr 26 2009 22:16:23) With Xcache
MySQL version: mysql Ver 14.12 Distrib 5.0.51a, for debian-linux-gnu
(i486)

its for a Vbulletin Board...

i moment i use the default php.ini.. any one can help me??

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,2188,2188#msg-2188
7f006226eff37eaa07b1e8b96f521cb2?d=identicon&s=25 Kiril Angov (Guest)
on 2009-05-19 21:21
(Received via mailing list)
I think you will gain more if you use the latest version of PHP and
latest version of MySQL 5.1 to get the best performance out of your
default settings.

http://www.dotdeb.org

And bother to optimize when you have a performance problem.
2974d09ac2541e892966b762aad84943?d=identicon&s=25 Wicked (Guest)
on 2009-05-19 22:13
(Received via mailing list)
Hello

I have this question postet on vbulletin.com but i have only a anwser
for mysql and not for php or php5-cgi

top says this

Cpu(s): 63.2%us, 14.8%sy,  0.2%ni, 21.6%id,  0.0%wa,  0.0%hi,  0.2%si,
0.0%st

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND
 2261 mysql     15  -5  218m  94m 5364 S   61  4.7 119:27.98 mysqld
 7529 www-data  20   0  169m  24m  11m R   25  1.2   0:17.98 php5-cgi
 7533 www-data  20   0  164m  15m 7808 S   25  0.8   0:14.86 php5-cgi
 7528 www-data  20   0  166m  20m  10m S   23  1.0   0:18.72 php5-cgi
 7525 www-data  20   0  166m  20m  10m S   22  1.0   0:21.54 php5-cgi


and i think this is high server load for 50 user logged into vbulletin
board..

i will upgrade my mysql and php..

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,2188,2205#msg-2205
8258b301dc8e73c0ce419c61c1e21891?d=identicon&s=25 Claude Bing (Guest)
on 2009-05-19 22:29
(Received via mailing list)
Good Lord man, am I seeing those numbers correctly?

For one thing, vBulletin is resource-hungry.  I personally would go with
phpBB3.  I've had a few hundred people logged into phpBB3 and my memory
usage hasn't gone above 400MB, with Apache <--- yes apache, and MySQL
together.

On Tue, May 19, 2009 at 10:06 PM, Wicked <nginx-forum@nginx.us> wrote:

>  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND
> i will upgrade my mysql and php..
>
> Posted at Nginx Forum:
> http://forum.nginx.org/read.php?2,2188,2205#msg-2205
>
>
>


--

Casey
Stengel<http://www.brainyquote.com/quotes/authors/c/casey_...
- "There comes a time in every man's life, and I've had plenty of
them."
7f006226eff37eaa07b1e8b96f521cb2?d=identicon&s=25 Kiril Angov (Guest)
on 2009-05-19 23:13
(Received via mailing list)
Also, take a look at optimizing you MySQL config, there is not much
you can do about the php.
Upgrade your PHP and MySQL as per my previous email. let MySQL run for
at least 48 hours and run this on the server

http://www.day32.com/MySQL/tuning-primer.sh

It will give you advice on what to optimize in MySQL, you have 2GB of
memory and MySQL is not using much of it, that seems like a problem.
72731ad66bf04514d7c8baffa836dfb8?d=identicon&s=25 ultrokevjr (Guest)
on 2009-05-20 04:44
(Received via mailing list)
On Wed, May 20, 2009 at 4:06 AM, Wicked <nginx-forum@nginx.us> wrote:

> i will upgrade my mysql and php..
>
>
To do so will drop security serveries from debian, then you must take
care
all the security patches by yourself then. The latest versions tend to
come
with new bugs also and can't always give best performance most of time.

Just compile php-fpm together with patches and source from debian/lenny
with
php-5.26, then recompile it when debian updates php for security, thus
you
needn't to worry about security things.
7f006226eff37eaa07b1e8b96f521cb2?d=identicon&s=25 Kiril Angov (Guest)
on 2009-05-20 10:02
(Received via mailing list)
What you are talking about is not as valid for PHP and MySQL for
example where these distributes tend to be always one major version
behind. Zend Server ships with the latest PHP 5.2.9 and their pretty
much sell it to their enterprize customers. MySQL 5.1 has seen good
improvements and is currently well into stable state.

I would not use bleeding edge version of OS software but the web
development stack updates pretty often with needed updates.
Fda08117336cfde6562315df04b976e8?d=identicon&s=25 Dave Cheney (Guest)
on 2009-05-20 11:26
(Received via mailing list)
Seconded, I would bet that your mysql instance is doing a lot of IO,
mainly because your innodb buffer size is set to low. Given your
sharing that machine with a bunch of php processes you'll have to
tread carefully to avoid swapping.

I would enable the slow query log (don't forget to set the reporting
interval to 1 second, the default is 10) and also log queries that
don't use indexes. Some schema tweaking may be in order.

Cheers

Dave
Cab66b0caecae0068ab03d1f36b87273?d=identicon&s=25 Olivier B. (Guest)
on 2009-05-20 11:57
(Received via mailing list)
There is 0.0%wa, so I'm not sure this is a IO problem.

Olivier

Dave Cheney a écrit :
Fda08117336cfde6562315df04b976e8?d=identicon&s=25 Dave Cheney (Guest)
on 2009-05-20 12:58
(Received via mailing list)
Good point, there is an outside chance you are seeing a lot of sorts
on small tmp tables that never hit the disk, but unlikely
2974d09ac2541e892966b762aad84943?d=identicon&s=25 Wicked (Guest)
on 2009-05-20 18:01
(Received via mailing list)
Hello,

i have upgrade my php with dotdeb but by mysql i have many problems with
my tables

ERROR 1034 (HY000) at line 1: Incorrect key file for table 'access'; try
to repair it

etc.

and i dont cant repair this tables so i have downgraded the mysql-server
and remove the new mysql-server and it works.. but it is bad.. any
hints?

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,2188,2246#msg-2246
7f006226eff37eaa07b1e8b96f521cb2?d=identicon&s=25 Kiril Angov (Guest)
on 2009-05-20 19:12
(Received via mailing list)
This topic is locked and can not be replied to.