Forum: JRuby JRoR/JBoss deploy error

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
439a9cebe73c87771d06723f6027bfed?d=identicon&s=25 Norman Smith (smithno)
on 2009-05-18 21:14
I finally build a War file with Warbler. I moved the War file into the
Deploy folder within JBoss and start JBoss. The following is the start
of several pages of errors. It seems like an issue with Rack.


12:03:09,578 INFO  [TomcatDeployer] deploy, ctxPath=/SubscriberInfo,
warUrl=.../tmp/deploy/tmp7887202909635424593SubscriberInfo-exp.war/
12:04:03,375 ERROR [[/SubscriberInfo]] unable to create shared
application instance org.jruby.rack.RackInitializationException:
undefined method cache_template_loading=' for ActionView::Base:Class
    from
D:/jboss-portal-2.7.1/server/default/tmp/deploy/tmp7887202909635424593SubscriberInfo-exp.war/WEB-INF/gems/gems/rails-2.2.2/lib/initializer.rb:529:in
`each'
        from
D:/jboss-portal-2.7.1/server/default/tmp/deploy/tmp7887202909635424593SubscriberInfo-exp.war/WEB-INF/gems/gems/rails-2.2.2/lib/initializer.rb:529:in
`initialize_framework_settings'
        from D:/jboss-portal-2.7.1/server/default/tmp/deploy
...

Any ideas?

Norm
439a9cebe73c87771d06723f6027bfed?d=identicon&s=25 Norman Smith (smithno)
on 2009-05-19 13:55
Norman Smith wrote:
>
> I finally build a War file with Warbler. I moved the War file into the
> Deploy folder within JBoss and start JBoss. The following is the start
> of several pages of errors. It seems like an issue with Rack.
>
>
> 12:03:09,578 INFO  [TomcatDeployer] deploy, ctxPath=/SubscriberInfo,
> warUrl=.../tmp/deploy/tmp7887202909635424593SubscriberInfo-exp.war/
> 12:04:03,375 ERROR [[/SubscriberInfo]] unable to create shared
> application instance org.jruby.rack.RackInitializationException:
> undefined method cache_template_loading=' for ActionView::Base:Class
>     from
> 
D:/jboss-portal-2.7.1/server/default/tmp/deploy/tmp7887202909635424593SubscriberInfo-exp.war/WEB-INF/gems/gems/rails-2.2.2/lib/initializer.rb:529:in
> `each'
>         from
> 
D:/jboss-portal-2.7.1/server/default/tmp/deploy/tmp7887202909635424593SubscriberInfo-exp.war/WEB-INF/gems/gems/rails-2.2.2/lib/initializer.rb:529:in
> `initialize_framework_settings'
>         from D:/jboss-portal-2.7.1/server/default/tmp/deploy
> ...
>
> Any ideas?
>
> Norm


I got past this error last night. I had to create and edit
config\warble.rb and modify config\enbironments\production.rb. The War
file now starts. It gets errors on the first screen, but at least I am a
step further along!

Norm
This topic is locked and can not be replied to.