Forum: GNU Radio compiling gnuradio

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
A138131b9b5b78ac4c9ab855ec9a8363?d=identicon&s=25 hgplus (Guest)
on 2009-05-17 17:57
(Received via mailing list)
Hi,

 I am a newbie to gnuradio. To begin with, I was trying to download and
compile gnuradio. I did an svn checkout, and did bootstrap followed by
configure.
But I got the following message in configure output.

checking for Python wxWidgets wrappers >= 2.8... no
checking for Numeric Python extensions... yes
Not building component gr-wxgui.



Also I got the following output from Python when I tried to see what
configure was doing..

Python 2.6.2 (release26-maint, Apr 19 2009, 01:56:41)
[GCC 4.3.3] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>>
>>>
>>>
>>> import wx
>>> assert wx.version().split()[0] >= "2.8"
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
AttributeError: 'module' object has no attribute 'version'
>>>

Could you tell me which package I need to install to get this working ?
If I understand correctly, this is needed for graphical displays of
plots etc.
I am using ubuntu jaunty. I know that I can get the prebuilt gnuradio
for ubuntu, but I wanted to compile from source and install..

Thanks,
Regards,
Hgplus
79723aa1b24981dcec2dbf7fd59403c1?d=identicon&s=25 Brian Padalino (Guest)
on 2009-05-17 18:08
(Received via mailing list)
On Sun, May 17, 2009 at 11:56 AM, hgplus <hgplus@gmail.com> wrote:
>
>>>>
> I am using ubuntu jaunty. I know that I can get the prebuilt gnuradio
> for ubuntu, but I wanted to compile from source and install..

Welcome!

These instructions are pretty complete:

    http://gnuradio.org/trac/wiki/UbuntuInstall

Try that out and hopefully it works for you.

Good luck!

Brian
A138131b9b5b78ac4c9ab855ec9a8363?d=identicon&s=25 hgplus (Guest)
on 2009-05-17 19:01
(Received via mailing list)
Brian Padalino wrote:
>> checking for Numeric Python extensions... yes
>>
>> plots etc.
> Try that out and hopefully it works for you.
>
> Good luck!
>
> Brian
>
>
Thanks Brian... I am able to build gr-wxgui now. It turned out to be due
to some conflict between installed versions of python-wxgtk i.e 2.8
and 2.6.
I needed to uninstall 2.6 for the configure script to recognise 2.8.
Also, it seems that the prebuilt version of gnuradio was depending on
this (2.6) package and when I removed 2.6, the synaptic installed
gnuradio also got removed. Maybe this needs to be added to the wiki..

Thanks,
Warm Regards,
Harith
79723aa1b24981dcec2dbf7fd59403c1?d=identicon&s=25 Brian Padalino (Guest)
on 2009-05-17 19:08
(Received via mailing list)
On Sun, May 17, 2009 at 1:00 PM, hgplus <hgplus@gmail.com> wrote:
> Thanks Brian... I am able to build gr-wxgui now. It turned out to be due
> to some conflict between installed versions of python-wxgtk i.e 2.8
> and 2.6.
> I needed to uninstall 2.6 for the configure script to recognise 2.8.
> Also, it seems that the prebuilt version of gnuradio was depending on
> this (2.6) package and when I removed 2.6, the synaptic installed
> gnuradio also got removed. Maybe this needs to be added to the wiki..

Sounds like some good information to add to the wiki.  Feel free to add
it!

Brian
This topic is locked and can not be replied to.