Forum: JRuby Jruby Rack Error

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
F15fdc7cb2e911b3808837f2be244add?d=identicon&s=25 AD (Guest)
on 2009-05-13 23:45
(Received via mailing list)
for some reason we are getting this all of a sudden, any ideas ?

jruby 1.2.0
rack 0.9.4
jruby-openssl 0.4

SEVERE: Error: application initialization failed
org.jruby.rack.RackInitializationException: unable to create shared
application instance
        at
org.jruby.rack.SharedRackApplicationFactory.init(SharedRackApplicationFactory.java:38)
        at
org.jruby.rack.RackServletContextListener.contextInitialized(RackServletContextListener.java:39)
        at
org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:3764)
        at
org.apache.catalina.core.StandardContext.start(StandardContext.java:4216)
        at
org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:760)
        at
org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:740)
        at
org.apache.catalina.core.StandardHost.addChild(StandardHost.java:544)
        at
org.apache.catalina.startup.HostConfig.deployDescriptor(HostConfig.java:626)
        at
org.apache.catalina.startup.HostConfig.deployDescriptors(HostConfig.java:553)
        at
org.apache.catalina.startup.HostConfig.deployApps(HostConfig.java:488)
        at
org.apache.catalina.startup.HostConfig.start(HostConfig.java:1149)
        at
org.apache.catalina.startup.HostConfig.lifecycleEvent(HostConfig.java:311)
        at
org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:120)
        at
org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1022)
        at
org.apache.catalina.core.StandardHost.start(StandardHost.java:736)
        at
org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1014)
        at
org.apache.catalina.core.StandardEngine.start(StandardEngine.java:443)
        at
org.apache.catalina.core.StandardService.start(StandardService.java:448)
        at
org.apache.catalina.core.StandardServer.start(StandardServer.java:700)
        at org.apache.catalina.startup.Catalina.start(Catalina.java:552)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:597)
        at
org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:295)
        at
org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:433)
Caused by: org.jruby.rack.RackInitializationException: exit
        from
/apphome/coolstack/tomcat5/webapps/myapp/WEB-INF/config/boot.rb:38:in
`run'
        from
file:/apphome/coolstack/tomcat5/webapps/myapp/WEB-INF/lib/jruby-rack-0.9.4.jar!/jruby/rack/rails_boot.rb:20:in
`run'
        from
/apphome/coolstack/tomcat5/webapps/myapp/WEB-INF/config/boot.rb:11:in
`boot!'
        from
/apphome/coolstack/tomcat5/webapps/myapp/WEB-INF/config/boot.rb:109
        from
/apphome/coolstack/tomcat5/webapps/myapp/WEB-INF/config/boot.rb:11:in
`require'
        from
/apphome/coolstack/tomcat5/webapps/myapp/WEB-INF/config/environment.rb:11
        from
/apphome/coolstack/tomcat5/webapps/myapp/WEB-INF/config/environment.rb:26:in
`load'
        from
file:/apphome/coolstack/tomcat5/webapps/myapp/WEB-INF/lib/jruby-rack-0.9.4.jar!/jruby/rack/rails.rb:26:in
`load_environment'
        from
file:/apphome/coolstack/tomcat5/webapps/myapp/WEB-INF/lib/jruby-rack-0.9.4.jar!/jruby/rack/rails.rb:151:in
`new'
        from <script>:2
        from
file:/apphome/coolstack/tomcat5/webapps/myapp/WEB-INF/lib/jruby-rack-0.9.4.jar!/rack/builder.rb:29:in
`instance_eval'
        from
file:/apphome/coolstack/tomcat5/webapps/myapp/WEB-INF/lib/jruby-rack-0.9.4.jar!/rack/builder.rb:29:in
`initialize'
        from <script>:2

        at
org.jruby.rack.DefaultRackApplicationFactory$4.init(DefaultRackApplicationFactory.java:153)
        at
org.jruby.rack.DefaultRackApplicationFactory.getApplication(DefaultRackApplicationFactory.java:50)
        at
org.jruby.rack.SharedRackApplicationFactory.init(SharedRackApplicationFactory.java:26)
        ... 25 more
Caused by: org.jruby.exceptions.RaiseException: exit
        at
#<Class:01x4f079781>.load_rubygems(/apphome/coolstack/tomcat5/webapps/myapp/WEB-INF/config/boot.rb:52)
        at
Rails::GemBoot.load_initializer(/apphome/coolstack/tomcat5/webapps/myapp/WEB-INF/config/boot.rb:38)
        at
Rails::Boot.run(file:/apphome/coolstack/tomcat5/webapps/myapp/WEB-INF/lib/jruby-rack-0.9.4.jar!/jruby/rack/rails_boot.rb:20)
        at
Rails::BootHook.run(/apphome/coolstack/tomcat5/webapps/myapp/WEB-INF/config/boot.rb:11)
        at
#<Class:01x57cee0c8>.boot!(/apphome/coolstack/tomcat5/webapps/myapp/WEB-INF/config/boot.rb:109)
        at
(unknown).(unknown)(/apphome/coolstack/tomcat5/webapps/myapp/WEB-INF/config/boot.rb:11)
        at
Kernel.require(/apphome/coolstack/tomcat5/webapps/myapp/WEB-INF/config/environment.rb:11)
        at
(unknown).(unknown)(/apphome/coolstack/tomcat5/webapps/myapp/WEB-INF/config/environment.rb:26)
        at
Kernel.load(file:/apphome/coolstack/tomcat5/webapps/myapp/WEB-INF/lib/jruby-rack-0.9.4.jar!/jruby/rack/rails.rb:26)
        at
JRuby::Rack::RailsServletHelper.load_environment(file:/apphome/coolstack/tomcat5/webapps/myapp/WEB-INF/lib/jruby-rack-0.9.4.jar!/jruby/rack/rails.rb:151)
        at #<Class:01x384f33c1>.new(<script>:2)
        at
(unknown).(unknown)(file:/apphome/coolstack/tomcat5/webapps/myapp/WEB-INF/lib/jruby-rack-0.9.4.jar!/rack/builder.rb:29)
        at
Kernel.instance_eval(file:/apphome/coolstack/tomcat5/webapps/myapp/WEB-INF/lib/jruby-rack-0.9.4.jar!/rack/builder.rb:29)
        at
Kernel.instance_eval(file:/apphome/coolstack/tomcat5/webapps/myapp/WEB-INF/lib/jruby-rack-0.9.4.jar!/rack/builder.rb:29)
        at Rack::Builder.initialize(<script>:2)
        at (unknown).(unknown)(:1)

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email
F15fdc7cb2e911b3808837f2be244add?d=identicon&s=25 AD (Guest)
on 2009-05-13 23:49
(Received via mailing list)
some more info.... using rack 0.9.3, error goes away.  any ideas why
this would show up in 0.9.4 ?

On Wed, May 13, 2009 at 5:44 PM, AD <straightflush@gmail.com> wrote:
>        at 
org.jruby.rack.RackServletContextListener.contextInitialized(RackServletContextListener.java:39)
>        at 
org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:120)
>        at java.lang.reflect.Method.invoke(Method.java:597)
>        from /apphome/coolstack/tomcat5/webapps/myapp/WEB-INF/config/boot.rb:11:in
> `instance_eval'
>        at 
Rails::GemBoot.load_initializer(/apphome/coolstack/tomcat5/webapps/myapp/WEB-INF/config/boot.rb:38)
>        at 
Kernel.instance_eval(file:/apphome/coolstack/tomcat5/webapps/myapp/WEB-INF/lib/jruby-rack-0.9.4.jar!/rack/builder.rb:29)
>        at 
Kernel.instance_eval(file:/apphome/coolstack/tomcat5/webapps/myapp/WEB-INF/lib/jruby-rack-0.9.4.jar!/rack/builder.rb:29)
>        at Rack::Builder.initialize(<script>:2)
>        at (unknown).(unknown)(:1)
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email
526d60de6472502bb570a9df2842b33b?d=identicon&s=25 Nick Sieger (Guest)
on 2009-05-14 00:16
(Received via mailing list)
Can you check that all the gems got packaged? Also, take a look in
your application's config/boot.rb; I'm guessing you hit the block that
checks if you're running the right version of Rubygems. Can you
imagine why it's suddenly not finding the right Rubygems version? Did
you upgrade the jruby-complete jar as well? Which version did you
grab?

/Nick

On Wed, May 13, 2009 at 4:44 PM, AD <straightflush@gmail.com> wrote:
>        at 
org.jruby.rack.RackServletContextListener.contextInitialized(RackServletContextListener.java:39)
>        at 
org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:120)
>        at java.lang.reflect.Method.invoke(Method.java:597)
>        from /apphome/coolstack/tomcat5/webapps/myapp/WEB-INF/config/boot.rb:11:in
> `instance_eval'
>        at 
Rails::GemBoot.load_initializer(/apphome/coolstack/tomcat5/webapps/myapp/WEB-INF/config/boot.rb:38)
>        at 
Kernel.instance_eval(file:/apphome/coolstack/tomcat5/webapps/myapp/WEB-INF/lib/jruby-rack-0.9.4.jar!/rack/builder.rb:29)
>
---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email
F15fdc7cb2e911b3808837f2be244add?d=identicon&s=25 AD (Guest)
on 2009-05-14 03:18
(Received via mailing list)
I dont think there was a gem issue as dropping jruby-rack.0.9.3
instead of 9.4 fixed the issue.

jruby-complete did not change, it has been 1.2.0 the whole time.  In
terms of the 0.9.4 version let me confirm where it was retreived
from...

No clue on the rubygems version, again this error goes away with 0.9.3
so not sure what is different there.

Thanks for the quick feedback.

Adam



On Wed, May 13, 2009 at 6:15 PM, Nick Sieger <nicksieger@gmail.com>
wrote:
>> for some reason we are getting this all of a sudden, any ideas ?
>>        at 
org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:3764)
>>        at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1022)
>>        at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:295)
>> `require'
>>        from 
file:/apphome/coolstack/tomcat5/webapps/myapp/WEB-INF/lib/jruby-rack-0.9.4.jar!/rack/builder.rb:29:in
>>        at 
Rails::Boot.run(file:/apphome/coolstack/tomcat5/webapps/myapp/WEB-INF/lib/jruby-rack-0.9.4.jar!/jruby/rack/rails_boot.rb:20)
>>        at 
Kernel.instance_eval(file:/apphome/coolstack/tomcat5/webapps/myapp/WEB-INF/lib/jruby-rack-0.9.4.jar!/rack/builder.rb:29)
>
> ---------------------------------------------------------------------
> To unsubscribe from this list, please visit:
>
>    http://xircles.codehaus.org/manage_email
>
>
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email
3bbb3edf178a64eec856ef5142de0bf6?d=identicon&s=25 ajosephmi (Guest)
on 2009-05-14 19:16
(Received via mailing list)
Hi Nick,
I do have the same problem with jruby-rack-0.9.4 and it goes away when I
revert back to jruby-rack-0.9.3. I tried upgrading to
jruby-complete-1.3.0RC1.jar but the problem persists with
jruby-rack-0.9.4.

Env:
tomcat 6.0.14
rails 2.3.2
jruby-rack-0.9.4
jruby-complete-1.3.0RC1.jar

Tony


Nick Sieger-2 wrote:
> On Wed, May 13, 2009 at 4:44 PM, AD <straightflush@gmail.com> wrote:
>> org.jruby.rack.SharedRackApplicationFactory.init(SharedRackApplicationFactory.java:38)
>>        at
>> org.apache.catalina.startup.HostConfig.lifecycleEvent(HostConfig.java:311)
>>        at
>>        at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:295)
>> `boot!'
>>        from
>> 
file:/apphome/coolstack/tomcat5/webapps/myapp/WEB-INF/lib/jruby-rack-0.9.4.jar!/rack/builder.rb:29:in
>> Caused by: org.jruby.exceptions.RaiseException: exit
>>        at
>>        at
>>
>
>
>

--
View this message in context:
http://www.nabble.com/Jruby-Rack-Error-tp23530545p...
Sent from the JRuby - User mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email
F15fdc7cb2e911b3808837f2be244add?d=identicon&s=25 AD (Guest)
on 2009-05-14 19:36
(Received via mailing list)
i am rails 2.2.2, Tomcat 5.5 , jruby-1.2.0 so that doesnt seem to make
any difference there either.

adam

On Thu, May 14, 2009 at 1:15 PM, ajosephmi <ajosephmi@yahoo.com> wrote:
> jruby-complete-1.3.0RC1.jar
>> you upgrade the jruby-complete jar as well? Which version did you
>>>
>>> org.apache.catalina.core.StandardContext.start(StandardContext.java:4216)
>>>        at
>>> org.apache.catalina.core.StandardHost.start(StandardHost.java:736)
>>>        at
>>>        from
>>>        from
>>>        from <script>:2
>>>        at
>>> 
Rails::Boot.run(file:/apphome/coolstack/tomcat5/webapps/myapp/WEB-INF/lib/jruby-rack-0.9.4.jar!/jruby/rack/rails_boot.rb:20)
>>>        at
>>>        at Rack::Builder.initialize(<script>:2)
>> ---------------------------------------------------------------------
> Sent from the JRuby - User mailing list archive at Nabble.com.
>
>
> ---------------------------------------------------------------------
> To unsubscribe from this list, please visit:
>
>    http://xircles.codehaus.org/manage_email
>
>
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email
526d60de6472502bb570a9df2842b33b?d=identicon&s=25 Nick Sieger (Guest)
on 2009-05-14 22:06
(Received via mailing list)
Thanks for confirming Tony. Would one of you mind reporting a bug at
http://kenai.com/jira/browse/JRUBY_RACK ? If you have a sample
application that can demonstrate the problem that would help too. Does
a bare Rails 2.2 or 2.3 app exhibit the problem?

Thanks,
/Nick

On Thu, May 14, 2009 at 12:15 PM, ajosephmi <ajosephmi@yahoo.com> wrote:
> jruby-complete-1.3.0RC1.jar
>> you upgrade the jruby-complete jar as well? Which version did you
>>>
>>> org.apache.catalina.core.StandardContext.start(StandardContext.java:4216)
>>>        at
>>> org.apache.catalina.core.StandardHost.start(StandardHost.java:736)
>>>        at
>>>        from
>>>        from
>>>        from <script>:2
>>>        at
>>> 
Rails::Boot.run(file:/apphome/coolstack/tomcat5/webapps/myapp/WEB-INF/lib/jruby-rack-0.9.4.jar!/jruby/rack/rails_boot.rb:20)
>>>        at
>>>        at Rack::Builder.initialize(<script>:2)
>> ---------------------------------------------------------------------
> Sent from the JRuby - User mailing list archive at Nabble.com.
>
>
> ---------------------------------------------------------------------
> To unsubscribe from this list, please visit:
>
>    http://xircles.codehaus.org/manage_email
>
>
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email
F15fdc7cb2e911b3808837f2be244add?d=identicon&s=25 AD (Guest)
on 2009-05-15 02:10
(Received via mailing list)
ill give this a try.

Tony maybe we can see if there is something with the gems we are
using?  I will go dig into our list we have in warble.rb

Adam

On Thu, May 14, 2009 at 4:06 PM, Nick Sieger <nicksieger@gmail.com>
wrote:
>> Hi Nick,
>> Tony
>>>
>>>> org.jruby.rack.RackInitializationException: unable to create shared
>>>> org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:760)
>>>>        at
>>>> org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1014)
>>>>        at
>>>> `run'
>>>>        from
>>>> 
file:/apphome/coolstack/tomcat5/webapps/myapp/WEB-INF/lib/jruby-rack-0.9.4.jar!/rack/builder.rb:29:in
>>>>        at
>>>> 
Rails::BootHook.run(/apphome/coolstack/tomcat5/webapps/myapp/WEB-INF/config/boot.rb:11)
>>>>        at
>>>>
>>>
>>
>
>    http://xircles.codehaus.org/manage_email
>
>
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email
F15fdc7cb2e911b3808837f2be244add?d=identicon&s=25 AD (Guest)
on 2009-05-19 06:51
(Received via mailing list)
No issues on a barebones rails app. I also installed all my gems and
still no luck getting it to fail on a barebones app.. maybe a version
of warbler (that was the only difference)?

Adam

On Thu, May 14, 2009 at 8:10 PM, AD <straightflush@gmail.com> wrote:
>> application that can demonstrate the problem that would help too. Does
>>> jruby-complete-1.3.0RC1.jar but the problem persists with  jruby-rack-0.9.4.
>>> Nick Sieger-2 wrote:
>>>> On Wed, May 13, 2009 at 4:44 PM, AD <straightflush@gmail.com> wrote:
>>>>> 
org.jruby.rack.SharedRackApplicationFactory.init(SharedRackApplicationFactory.java:38)
>>>>>        at
>>>>> org.apache.catalina.startup.HostConfig.lifecycleEvent(HostConfig.java:311)
>>>>>        at
>>>>>        at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:295)
>>>>> `boot!'
>>>>>        from
>>>>> 
file:/apphome/coolstack/tomcat5/webapps/myapp/WEB-INF/lib/jruby-rack-0.9.4.jar!/rack/builder.rb:29:in
>>>>> Caused by: org.jruby.exceptions.RaiseException: exit
>>>>>        at
>>>>>        at
>>>>>
>>>>
>>>
>>
>>
>

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

    http://xircles.codehaus.org/manage_email
Fc19147e89d6521f92ef9e2c1c4dac24?d=identicon&s=25 Matthew Kanwisher (Guest)
on 2009-05-22 21:25
(Received via mailing list)
Anyone have a workaround for this I'm having the same problem
Solaris 10, Tomcat 5, Rails 2.2.2, Jruby Rack 0.9.4, Jruby 1.2.0

Looks like it can't find ruby gems


org.jruby.rack.RackInitializationException: exit
        from
/var/retuers/deploy/CMS/releases/20090522191558/tmp/war/WEB-INF/config/boot.rb:38:in
`run'
        from
file:/var/retuers/deploy/CMS/releases/20090522191558/tmp/war/WEB-INF/lib/jruby-rack-0.9.4.jar!/jruby/rack/rails_boot.rb:20:in
`run'
        from
/var/retuers/deploy/CMS/releases/20090522191558/tmp/war/WEB-INF/config/boot.rb:11:in
`boot!'
        from
/var/retuers/deploy/CMS/releases/20090522191558/tmp/war/WEB-INF/config/boot.rb:109
        from
/var/retuers/deploy/CMS/releases/20090522191558/tmp/war/WEB-INF/config/boot.rb:11:in
`require'
        from
/var/retuers/deploy/CMS/releases/20090522191558/tmp/war/WEB-INF/config/environment.rb:11
        from
/var/retuers/deploy/CMS/releases/20090522191558/tmp/war/WEB-INF/config/environment.rb:26:in
`load'

~Matt
This topic is locked and can not be replied to.