Forum: Ruby on Rails Yet another cucumber/webrat/selenium problem

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
44a43e7fef8e933e802a7802b4bd3525?d=identicon&s=25 John Small (johnsmall)
on 2009-05-12 14:09
I do wish Cucumber has its own Google group, but no such luck (or at
least it's not linked to from GitHub), so I'll post here.

I've followed the instructions for setting up on
http://wiki.github.com/aslakhellesoy/cucumber/sett....

I get responses that look like it's about to work, Firefox starts,
Selenium takes controls and then.... it all falls apart. Like this;-

==> Waiting for Selenium RC server on port 4444... Ready!
==> Waiting for rails application server on port 3001... Ready!
12:55:48.301 WARN - you appear to be changing domains from
http://localhost:3001 to http://www.example.com/customer_login
this may lead to a 'Permission denied' from the browser (unless it is
running as *iehta or *chrome,
or alternatively the selenium server is running in proxy injection mode)

Where is the hidden configuration setting that allows me to issue
requests to localhost:3001 when I'm using Cucumber with Webrat with
Selenium?

Thanks

John Small
A66a4d323674aba4a904ceeff3f34658?d=identicon&s=25 WJSimacek (Guest)
on 2009-05-12 14:47
(Received via mailing list)
On May 12, 7:09 am, John Small <rails-mailing-l...@andreas-s.net>
wrote:
> I do wish Cucumber has its own Google group, but no such luck (or at
> least it's not linked to from GitHub), so I'll post here.

John,
     Cucumber gets a lot of posts on the rspec group. You can link to
it here:
http://groups.google.com/group/rspec?hl=en

      It's a pretty active group with some smart people. Good luck on
your BDD.

Wayne
This topic is locked and can not be replied to.