Forum: Rails France Déployement en production

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
2eb8c545efa54cc0a05420f6857d5dd1?d=identicon&s=25 Clément S. (cb56)
on 2009-05-11 16:32
Bonjour à tous,
J'ai un problème au niveau du déploiement de mon application Rails.
Etant débutant, j'ai suivi le tutorial sur le site d'Apple
(http://developer.apple.com/tools/deployonrailsleopard.html). Tout
fonctionne parfaitement bien mais le problème est que je souhaiterais
maintenant rajouter un prefix pour avoir :
http://monserver.com/mon_appli_rails/premier_contr...
au lieu de :
http://monserver.com/premier_controller/index.rhtml

J'ai donc suivi les conseils du site d'Apple et rajouté "--prefix
/mon_prefix" à la commande start dans le fichier deploy.rb.

Mais là, après un "cap deploy:setup" et un "cap deploy:cold", plus rien
ne fonctionne. Une erreur 503 se produit sur le site, et dans le
Moniteur d'Activité, les 4 processus Ruby lancés disparaissent et
réapparaissent au bout de quelques secondes, ce qui provoque une
saturation du processeur !

Le serveur est un Mac OS X Server sous Leopard 10.5.6 et toutes les gems
sont à jour.

Si vous avez besoin de plus de détails, n'hésitez pas.
Merci à ceux qui pourront m'aider,

Clément
5183febd0dfb911f94c270ddd174fe71?d=identicon&s=25 guillaume belleguic (Guest)
on 2009-05-11 16:43
(Received via mailing list)
que dit le fichier de log production ?

2009/5/11 Clément S. <list-incoming@andreas-s.net>
2eb8c545efa54cc0a05420f6857d5dd1?d=identicon&s=25 Clément S. (cb56)
on 2009-05-11 16:59
Le log de production indique juste qu'il a été créé avec la date et
l'heure et c'est tout !
This topic is locked and can not be replied to.