Forum: Ruby on Rails OCI Library Initialization Error

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
E2be24e6f02de7a52bfd44d025f0f30e?d=identicon&s=25 Tristan Gutsche (beriah)
on 2009-05-06 04:40
I am attempting to connect to ORACLE11g however i am getting the
following error:

"OCI Library Initialization Error"

IT always errors on OCIENV.init(). I cant see anything wrong on the ENV
configurations.

Has anyone had this problem, or any suggestions on where i should look
for anwers?



I am using the following gems:
ruby-oci8 (1.0.4)
activerecord-oracle-adapter (1.0.0.9250)
activerecord-oracle_enhanced-adapter (1.2.0)
activerecord (2.3.2)

TNS_ADMIN, ORACLE_HOME are configured.



The output is below:

** Invoke db:migrate (first_time)
** Invoke environment (first_time)
** Execute environment
** Execute db:migrate
rake aborted!

OCI Library Initialization Error
C:/Ruby/lib/ruby/gems/1.8/gems/ruby-oci8-1.0.4-x86-mswin32/lib/oci8.rb:58:in
`init'
C:/Ruby/lib/ruby/gems/1.8/gems/ruby-oci8-1.0.4-x86-mswin32/lib/oci8.rb:58
C:/Ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in
`gem_original_require'
C:/Ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in
`require'
C:/Ruby/lib/ruby/gems/1.8/gems/activesupport-2.2.2/lib/active_support/dependencies.rb:153:in
`require'
C:/Ruby/lib/ruby/gems/1.8/gems/activesupport-2.2.2/lib/active_support/dependencies.rb:521:in
`new_constants_in'
C:/Ruby/lib/ruby/gems/1.8/gems/activesupport-2.2.2/lib/active_support/dependencies.rb:153:in
`require'
C:/Ruby/lib/ruby/gems/1.8/gems/activesupport-2.2.2/lib/active_support/core_ext/kernel/requires.rb:7:in
`require_library_or_gem'
C:/Ruby/lib/ruby/gems/1.8/gems/activesupport-2.2.2/lib/active_support/core_ext/kernel/reporting.rb:11:in
`silence_warnings'
C:/Ruby/lib/ruby/gems/1.8/gems/activesupport-2.2.2/lib/active_support/core_ext/kernel/requires.rb:5:in
`require_library_or_gem'
C:/Ruby/lib/ruby/gems/1.8/gems/activerecord-oracle-adapter-1.0.0.9250/lib/active_record/connection_adapters/oci_adapter.rb:29
C:/Ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in
`gem_original_require'
C:/Ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in
`require'
C:/Ruby/lib/ruby/gems/1.8/gems/activesupport-2.2.2/lib/active_support/dependencies.rb:153:in
`require'
C:/Ruby/lib/ruby/gems/1.8/gems/activesupport-2.2.2/lib/active_support/dependencies.rb:521:in
`new_constants_in'
C:/Ruby/lib/ruby/gems/1.8/gems/activesupport-2.2.2/lib/active_support/dependencies.rb:153:in
`require'
C:/Ruby/lib/ruby/gems/1.8/gems/activerecord-2.2.2/lib/active_record/connection_adapters/abstract/connection_specification.rb:72:in
`establish_connection'
C:/Ruby/lib/ruby/gems/1.8/gems/activerecord-2.2.2/lib/active_record/connection_adapters/abstract/connection_specification.rb:58:in
`establish_connection'
C:/Ruby/lib/ruby/gems/1.8/gems/activerecord-2.2.2/lib/active_record/connection_adapters/abstract/connection_specification.rb:53:in
`establish_connection'
C:/Ruby/lib/ruby/gems/1.8/gems/rails-2.2.2/lib/initializer.rb:392:in
`initialize_database'
C:/Ruby/lib/ruby/gems/1.8/gems/rails-2.2.2/lib/initializer.rb:139:in
`process'
C:/Ruby/lib/ruby/gems/1.8/gems/rails-2.2.2/lib/initializer.rb:112:in
`send'
C:/Ruby/lib/ruby/gems/1.8/gems/rails-2.2.2/lib/initializer.rb:112:in
`run'
C:/Users/tgut9335/Documents/NetBeansProjects/hr/config/environment.rb:10
This topic is locked and can not be replied to.