Forum: Ruby which version is the most stable thing for AIX platform?

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
7caba80fca2ac4ddbb7f55957e5c0dec?d=identicon&s=25 Jun Young Kim (Guest)
on 2009-04-29 03:05
(Received via mailing list)
Hi, all.

I am sure that some of yours have had headaches to use ruby on aix
platforms.

we can find out lots of problems related aix installation steps by
googing.

some peoples discussed about zlib problems, core dump, tcl/tk, ....etc.

In my case, I am using 1.8.7 p160 for aix. but ruby is working
normally, but, gem always killed himself by core dump.

so, If you have know the most stable version ruby for aix, let me know
it :)

thanks for all.

ps ) my tools are using diff-lcs, tcl/tk lib, treetop. etc..

situation I met )
$ gem install treetop
..../lib/ruby/1.8/timeout.rb:59: [BUG] Segmentation fault
ruby 1.8.7 (2009-04-08 patchlevel 160) [powerpc-aix5.3.0.0]

IOT/Abort trap (core dumped)
0e728bf538d1848bc253d80a8626bbc2?d=identicon&s=25 Yutaka Kanemoto (Guest)
on 2009-05-05 17:15
(Received via mailing list)
Hi,

I think core team do not have AIX. So, if we (AIX users) want to use
ruby on AIX,
we need to solve issues by ourselves. This is just my thought.

Anyway, I can not recreate your issue.
Here is some output from my machine:

% ruby -v
ruby 1.8.7 (2009-04-08 patchlevel 160) [powerpc-aix5.3.0.0]

% gem --version
1.3.3

% gem install treetop
Successfully installed polyglot-0.2.5
Successfully installed treetop-1.2.5
2 gems installed
Installing ri documentation for polyglot-0.2.5...
Installing ri documentation for treetop-1.2.5...
Installing RDoc documentation for polyglot-0.2.5...
Installing RDoc documentation for treetop-1.2.5...

I have not used treetop so far, but I just tried to install.
I'm not sure if I can help you, I can tell you the difference of
environment.
What kind of compilers( and its versions) did you use to build ruby?
What options did you use when you built ruby?
 I use xlc 9/gcc 4.2.3, and use --enable-shared and --prefix

By the way, what is zlib problems?
7caba80fca2ac4ddbb7f55957e5c0dec?d=identicon&s=25 Jun Young Kim (Guest)
on 2009-05-26 02:56
(Received via mailing list)
sorry for late response.

I am using gcc 4.2.4. this is installed by a package.
and zlib problem meant
whenever I start to a ruby/tk application, I met like " no found to
zlib " errors. However, I checked zlib has been already installed.
(anyway this problem is solved. :) I can solve this by installing zlib
in ruby and a with-zlib option)

this is an option I used.
./configure --prefix=/usr/local --with-tcl-dir=/usr/local --with-tk-
dir=/usr/local --with-tcllib=tclstub8.5 --with-tklib=tkstub8.5 --
enable-tcltk_stubs

at the same time, I installed tcl and tk before installing ruby with
this option.
./configure --prefix=/usr/local --enable-shared

by your suggestion, i will update ruby to p160 and then update gem. :)
This topic is locked and can not be replied to.