Forum: Ruby installation trouble??

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Dfc16eb87727b98cd461650380ec9978?d=identicon&s=25 Lostin Ruby (lostinruby)
on 2009-04-24 11:28
Hi,

I am very new to ruby and have hit a wall with the installation. I am
using a Mac OS X 10.4.11(Tiger). I got everything installed correctly
(Ruby Version 1.8.6, RubyGems 1.3.2, Rails Version 2.3.2, db adapter
sqlite3) and I was trying to work through the Agile Web Development with
Rails 2nd edition. There was an issue with scaffold being deprecated in
newer versions so I scoured the web to find a fix. I tried to uninstall
RubyGems 1.3.2 so that I could work through the book edition 2 with the
intention of installing the newer version later. However now when I try
to start the server I get the message

Rails requires RubyGems >= 1.3.1 (you have 0.9.2). Please `gem update
--system` and try again.

and when I try to update my gems or indeed run any other gem command I
get the error

/usr/local/lib/ruby/site_ruby/1.8/rubygems/source_index.rb:92:in
`load_specification': private method `specification_version=' called for
#<Gem::Specification:0x10b01d4> (NoMethodError)
        from
/usr/local/lib/ruby/site_ruby/1.8/rubygems/specification.rb:421:in
`initialize'
        from (eval):3:in `new'
        from (eval):3:in `load_specification'
        from
/usr/local/lib/ruby/site_ruby/1.8/rubygems/source_index.rb:128:in `eval'
        from
/usr/local/lib/ruby/site_ruby/1.8/rubygems/source_index.rb:92:in
`load_specification'
        from
/usr/local/lib/ruby/site_ruby/1.8/rubygems/source_index.rb:128:in
`load_gems_in'
        from
/usr/local/lib/ruby/site_ruby/1.8/rubygems/source_index.rb:127:in `each'
        from
/usr/local/lib/ruby/site_ruby/1.8/rubygems/source_index.rb:127:in
`load_gems_in'
         ... 14 levels...
        from
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
`gem_original_require'
        from
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
`require'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:112:in
`manage_gems'
        from /usr/local/bin/gem:10

I'm really at a loss so any help would be greatly appreciated. Please
bear in mind that I am very new to Macs and Ruby.

Kind regards,

LostinRuby
This topic is locked and can not be replied to.