Forum: Ruby on Rails rack.rb:17: warning: already initialized constant VERSION

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
9c7d80ebc20ab8994e51b9f7518909ae?d=identicon&s=25 Luca G. Soave (lgs)
on 2009-04-23 19:58
(Received via mailing list)
Despite the resolved thread #2255 (https://rails.lighthouseapp.com/
projects/8994/tickets/2255-bundled-rack-10-doesnt-loaded-first-in-
rails-232) , I get a VERSION warning :

ruby script/console
Loading development environment (Rails 2.3.2)
/home/useraxis/rails/test/vendor/rails/actionpack/lib/
action_controller/vendor/rack-1.0/rack.rb:17: warning: already
initialized constant VERSION
>>

- freezed RELEASE=2.3.2.1 or unfreezed, I get same error
- uninstalled  rack-0.9.1 I get :

[~/rails/test]# ruby script/console
Loading development environment (Rails 2.3.2)
/usr/lib/ruby/site_ruby/1.8/rubygems.rb:636:in
`report_activate_error': Could not find RubyGem rack (>= 0.9.1, < 1.0)
(Gem::LoadError)
        from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:141:in `activate'
        from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:165:in `activate'
        from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:164:in `each'
        from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:164:in `activate'
        from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
35:in `require'
        from /home/useraxis/rails/test/vendor/rails/activesupport/lib/
active_support/dependencies.rb:156:in `require'
        from /home/useraxis/rails/test/vendor/rails/activesupport/lib/
active_support/dependencies.rb:521:in `new_constants_in'
        from /home/useraxis/rails/test/vendor/rails/activesupport/lib/
active_support/dependencies.rb:156:in `require'
         ... 23 levels...
        from /usr/lib/ruby/1.8/irb/init.rb:250:in `load_modules'
        from /usr/lib/ruby/1.8/irb/init.rb:21:in `setup'
        from /usr/lib/ruby/1.8/irb.rb:54:in `start'
        from /home/useraxis/local/bin/irb:13

the line 17 is :    VERSION = [0,1]

Can this fault something else ?
Is someone having the same issue ?

Thanks in advance
Luca
8d7c0c3b32899cccf8d0abb080a18c20?d=identicon&s=25 Peter Hellberg (Guest)
on 2009-05-25 16:43
(Received via mailing list)
I have the same issue, will post if I find a solution to the problem.
8d7c0c3b32899cccf8d0abb080a18c20?d=identicon&s=25 Peter Hellberg (Guest)
on 2009-05-26 14:14
(Received via mailing list)
For future reference:

It seems like Rack-Cache 0.5, Rack 1.0 and Rails 2.3.2 solved the
problem.
(I uninstalled Rack-Cache 0.4, Rack 0.9.1, Shotgun 0.2 and Sinatra
0.9.1.1)
99f81a956dee7db6f6449c78f2ca8e39?d=identicon&s=25 Dan Paul (Guest)
on 2009-07-16 20:34
(Received via mailing list)
Thanks Peter,

I had the same error and I installed Rack-Cache 0.5 and Rack 1.0 and
it fixed my problem hope this helps others.

sudo gem install rack-cache
sudo gem install rack
This topic is locked and can not be replied to.